UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 29445

9.2i EDK - When I try to connect with XMD, the XMD window briefly appears and then quickly disappears

Description

When I try to connect to my board with XMD, the screen appears and then quickly goes away. What could be the problem?

Solution

XPS will not properly launch XMD if you have XPS configured to use a global or user repository. Use one of the following solutions to work around this issue:

Solution 1

Modify the customizable buttons in the XPS toolbar (the two Xilinx logo buttons) as follows:

1. In XPS, select Project -> Customize Buttons.

2. In the User Button One field, enter the following (based on what will be in your project's etc directory):

xmd -opt etc/xmd_microblaze_0.opt

3. Select the Run checkbox in a separate window.

4. Select OK.

Solution 2

Remove the global and user repository settings in XPS as follows:

1. In XPS, select Edit -> Preferences.

2. With the Application Preferences selected, delete the changes in the Global Repository field.

3. Select OK.

4. Select Project -> Project Options.

5. With the Device and Repository tab forward, delete the entry in the Project Peripheral Repository.

6. Select OK and restart XPS.

Solution 3

If you have multiple ISE installations, make sure that ISE 9.2i is the first one in the path. This requires modification of the PATH environment variable on your computer.

This problem has been fixed in the latest EDK 9.2i Service Pack, available at:

http://www.xilinx.com/xlnx/xil_sw_updates_home.jsp
The first service pack containing the fix is EDK 9.2i Service Pack 1.

AR# 29445
Date Created 11/03/2007
Last Updated 12/15/2012
Status Active
Type General Article