UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 31182

10.1 EDK SP2, xps_can_v1_00_a - The data sheet indicates "supported" in the Virtex-4 devices. However, it is not listed in the "mpd" as supported

Description

The xps_can_v1_00_a is supported in the Virtex-4 devices and the .mpd file is in error in not listing it.

Solution

To correct this issue, please include the Virtex-4 architecture support in the ".mpd" file located at:

%Xilinx\10.1\EDK\hw\XilinxProcessorIPLib\pcores\xps_can_v1_00_a\data

Open the "xps_can_v2_1_0.mpd" file and add the following items in the "OPTION ARCH_SUPPORT_MAP" line 29.

OPTION ARCH_SUPPORT_MAP = (virtex4lx=PREFERRED, virtex4sx=PREFERRED, virtex4fx=PREFERRED, . .....)

The issue will be fixed in the EDK 10.1 Service Pack 3. It will be available at:

http://www.xilinx.com/xlnx/xil_sw_updates_home.jsp

AR# 31182
Date Created 06/16/2008
Last Updated 12/15/2012
Status Active
Type General Article