UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 33915

10.1.03/11.x XST - "EXCEPTION:Xdm:FileReader.c:484:$Id: FileReader.c,v 1.41.20.1..."

Description

Keywords: XST, EXCEPTION, NGC, FileReader

When I synthesize the design, XST issues the following error:

"Reading core <gold_code.ngc>.
EXCEPTION:Xdm:FileReader.c:428:$Id: FileReader.c,v 1.36 2004/09/15 20:29:16 jdl Exp $ - Xdm_Exception::UnsupportedFileFormatVersion The Xdm_Model File Format version 'V1.5e' is not supported. Please ensure that the file was last modified by a compatible software version"

OR

"Reading core <gold_code.ngc>.
EXCEPTION:Xdm:FileReader.c:484:$Id: FileReader.c,v 1.41.20.1 2009/06/16 00:37:40 jdl Exp $ - Xdm_Exception::UnsupportedFileFormatVersion The Xdm_Model File Format version 'V1.6e' is not supported. Please ensure that the file was last modified by a compatible software version"

The <gold_code.ngc> is the netlist of a black-box submodule. If I uncheck the "Read Cores" property of Synthesis, the error goes away. What is wrong with this project?

Solution

XST issues this error if the NGC netlist of a black-box submodule is generated by a later version of the ISE software (e.g., 10.1 XST issues this error if the NGC file of the black-box submodule is generated from 11.x).

The use of the NGC file in an older version of the ISE software is not allowed. Although, unchecking "Read Cores" can remove this error, Translate fails with another error, see (Xilinx Answer 33916). So, make sure all NGC files are generated by the same version or older version of the ISE software.
AR# 33915
Date Created 12/08/2009
Last Updated 12/07/2009
Status Active
Type General Article