UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 39072

12.x: ERROR:Compxlib:368 - Compxlib does not support questa version 6.3b or prior releases.

Description

When I try to compile Xilinx libraries using compxlib for Questa 2010, I get the following error. How can I resolve it?

ERROR:Compxlib:368 - Compxlib does not support questa version 6.3b or prior releases. Parsing through the path setting on your system we have identified that you are using questa '2010.09'.

Please contact Mentor Graphics to upgrade to a supported simulator version. If the path setting is incorrect, please ensure that you are pointing to the latest version and re-invoke compxlib.

The list of supported simulator versions are listed in the Simulation Chapter of the Synthesis and Simulation Design Guide on http://www.xilinx.com.

Solution

The reason for the compxlib error is becausethe tool is unable to recognize the new version naming followed my Mentor. This issue is fixed in ISE 13.1.

Meanwhile 12.x users can use the patch at

http://www.xilinx.com/txpatches/pub/applications/misc/mti_questa_2010_patch.zipto get this issue fixed.
AR# 39072
Date Created 11/12/2010
Last Updated 12/15/2012
Status Active
Type General Article
Devices
  • Virtex-5 FXT
  • Virtex-5 LX
  • Virtex-5 LXT
  • More
  • Virtex-5 SXT
  • Virtex-5 TXT
  • Virtex-5Q
  • Virtex-5QV
  • Virtex-6 CXT
  • Virtex-6 HXT
  • Virtex-6 LX
  • Virtex-6 LXT
  • Virtex-6 SXT
  • Virtex-7
  • Less
Tools
  • ISE Design Suite - 12.1
  • ISE Design Suite - 12.2
  • ISE Design Suite - 12.3