UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 43865

XST Crashes while Launching

Description

XST crashes while launching on a RHEL 5 64-bit machine with glibc-2.5-58.el5_6.4 and displays the following error message:

"/tools/xilinx/13.1/ISE/bin/lin64/unwrapped/xst: symbol lookup error:
/tools/xilinx/13.1/ISE_DS/ISE/lib/lin64/libXst2_Core.so: undefined symbol: _ZN5boost7archive6detail17basic_oserializerD2Ev"

MAP also displays the same error message when either the logic optimization is enabled using the -logic_opt switch, or, when register duplication is enabled using the -register_duplication switch.

Solution

Apply the following settings to avoid 13.1 and 13.2 crashes.

13.1 Settings

For a 13.1 XST crash, set the LD_PRELOAD environment variable to libXst2_Core.so as follows:
LD_PRELOAD=/tools/xilinx/13.1/ISE_DS/ISE/lib/lin64/libXst2_Core.so
This parameter resolves the XST issue, but not that of MAP.

For a 13.1 MAP crash, set the LD_PRELOAD environment variable to libXst_Core.so as follows:
LD_PRELOAD=/tools/xilinx/13.1/ISE_DS/ISE/lib/lin64/libXst_Core.so

13.2 Settings

For a 13.2 XST crash, set the LD_PRELOAD environment variable to libXst2_Core.so as follows:
LD_PRELOAD=/tools/xilinx/13.2/ISE_DS/ISE/lib/lin64/libXst2_Core.so
This parameter resolves the XST issue, but not that of MAP.

For a 13.2 MAP crash, set the LD_PRELOAD environment variable to libXst_Core.so as follows:
LD_PRELOAD=/tools/xilinx/13.2/ISE_DS/ISE/lib/lin64/libXst_Core.so

AR# 43865
Date Created 09/15/2011
Last Updated 05/19/2012
Status Active
Type Known Issues
Tools
  • ISE Design Suite - 13.1
  • ISE Design Suite - 13.2