AR# 55402

|

iMPACT 14.3/14.4/14.5/14.6, Virtex-7 690T - BPI Indirect Programming fails with " '0': Errors encountered while loading microprogram"

Description

Flash programming fails when carrying out BPI Indirect Programming on a Virtex-7 690T device. An error similar to the following can be observed on the VC709 board:

INFO:Cse - Core Status Register: [80] : 1
INFO:Cse - Core Status Register: [81] : 1
INFO:Cse - Core Status Register: [82] : 1
INFO:Cse - Core Status Register: [83] : 0
INFO:Cse - Core Status Register: [84] : 1
INFO:Cse - Core Status Register: [85] : 0
INFO:Cse - Core Status Register: [86] : 1
INFO:Cse - Core Status Register: [87] : 0
INFO:Cse - Core Status Register: [88] : 1
INFO:Cse - Core Status Register: [89] : 0
INFO:Cse - Core Status Register: [90] : 0
INFO:Cse - Core Status Register: [91] : 0
INFO:Cse - Core Status Register: [92] : 1
INFO:Cse - Core Status Register: [93] : 1
INFO:Cse - Core Status Register: [94] : 1
INFO:Cse - Core Status Register: [95] : 0
'0': Errors encountered while loading microprogram.
ERROR: Cse - '0': Unable to load 'read' instruction to device

How do I work around this error?

Solution

This is an intermittent issue and might not be seen on all boards. Multiple programming attempts can result in a successful flash programming operation. The problem is related to the core file operation.

A reliable work-around to this issue is to revert to a LabTools install of 14.2.

This issue is resolved in iMPACT 14.7.

Linked Answer Records

Master Answer Records

AR# 55402
Date 12/19/2013
Status Active
Type General Article
Devices
Tools
Boards & Kits
People Also Viewed