UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 69459

AXI Bridge for PCI Express Gen3 (Vivado 2017.1/Vivado 2017.2) - Critical Warning - [filemgmt 20-1741] File 'axi_pcie3_v1_1_bram_wrap.v' is used by one or more modules, but with different contents, and may lead to unpredictable result

Description

Version Found: v3.0 (Rev2) / v3.0 (Rev3)

Version Resolved and other Known Issues: (Xilinx Answer 61898)

When creating an IP Integrator design with two instances of the core, one configured as Root Port and the other configured as Endpoint, the tool gives the following warning message during design implementation:

Critical Warning - [filemgmt 20-1741] File 'axi_pcie3_v1_1_bram_wrap.v' is used by one or more modules, but with different contents, and may lead to unpredictable result

The issue occurs only if one of the cores is configured as Root Port.

If both cores are configured as Endpoint, the critical warning message is not reported.


This article is part of the PCI Express Solution Centre

(Xilinx Answer 34536) Xilinx Solution Center for PCI Express

Solution

This is a known issue to be fixed in a future release of the core. 

To fix the issue in Vivado 2017.1/Vivado 2017.2, please install the patch attached to this Answer Record as described in the 'patch_readme' directory of the patches attached.

Note: "Version Found" refers to the version where the problem was first discovered. The problem might also exist in earlier versions, but no specific testing has been performed to verify earlier versions.

Revision History:

07/18/2017 - Initial release

Attachments

Associated Attachments

AR# 69459
Date 07/25/2017
Status Active
Type Known Issues
IP
  • AXI PCIe Gen3
Page Bookmarked