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• Use GPI - Enable the General Purpose Input port.

• Number of Bits - Set the number of bits of the General Purpose Input port.

• Generate Interrupt - Generate an interrupt when a General Purpose Input changes in 
the specified way - either any change (Both Edges), only when changed from 0 to 1 
(Rising Edge), or only when changed from 1 to 0 (Falling Edge).

The Interrupt parameter tab is shown in Figure 4-7.

X-Ref Target - Figure 4-6

Figure 4-6: GPI Parameter Tab
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• Use External Interrupts - Enable the use of external interrupt inputs.

• Number of External Inputs - Select the number of used external interrupt inputs.

• Level or Edge of External Interrupts - Select whether the input is considered level 
sensitive or edge triggered. Each bit in the value corresponds to the equivalent 
interrupt input. When a bit is set to one, the interrupt is edge triggered, otherwise it is 
level sensitive.

• Positive or Negative External Interrupts - Set whether to use high or low level for 
level sensitive interrupts, and rising or falling edge for edge triggered interrupts. Each 
bit in the value corresponds to the equivalent interrupt input When a bit is set to one, 
high level or rising edge is used, otherwise low level or falling edge is used.

• Use Low-latency Interrupt Handling - Enable the use of low-latency interrupt 
handling.

Parameter Values
To obtain an I/O Module that is uniquely tailored a specif ic system, certain features can be 
parameterized in the I/O module design. This allows for configuring a design that only uses 
the resources required by the system, and operates with the best possible performance. The 
features that can be parameterized in I/O Module designs are shown in Table 4-1.

X-Ref Target - Figure 4-7

Figure 4-7: Interrupt Parameter Tab
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Table 4-1: I/O Module Parameters

Parameter Name Feature/Description Allowable
Values

Default
Value VHDL Type

C_FAMILY(1) FPGA Architecture Supported
architectures

 virtex5 string

I/O Bus Parameter
C_USE_IO_BUS Use I/O Bus 0 = Not Used

1 = Used
0 integer

UART Parameters
C_USE_UART_RX Use UART Receive 0 = Not Used

1 = Used
0 integer

C_USE_UART_TX Use UART Transmit 0 = Not Used
1 = Used

0 integer

C_UART_BAUDRATE Baud rate of the UART in 
bits per second

integer
(e.g. 115200)

9600 integer

C_UART_PROG_
BAUDRATE

Programmable UART 
Baud rate

0 = Not Used
1 = Used

0 integer

C_UART_DATA_BITS The number of data bits 
in the serial frame

5 - 8 8 integer

C_UART_USE_PARITY Determines whether 
parity is used or not

0 = No Parity
1 = Use Parity

0 integer

C_UART_ODD_PARITY If parity is used, 
determines whether 
parity is odd or even

0 = Even Parity
1 = Odd Parity

0 integer

C_UART_RX_INTERRUPT Use UART RX Interrupt in 
INTC

0 = Not Used
1 = Used

0 integer

C_UART_TX_INTERRUPT Use UART TX Interrupt in 
INTC

0 = Not Used
1 = Used

0 integer

C_UART_ERROR_
INTERRUPT

Use UART ERROR 
Interrupt in INTC

0 = Not Used
1 = Used

0 integer

FIT Parameters
C_USE_FITx(2) Enable implementation of 

FIT
0 = Not Used
1 = Used

0 integer

C_FITx_No_CLOCKS(2) The number of clock 
cycles between strobes

>2 6216 integer

C_FITx_INTERRUPT(2) Use FITx_Interrupt in INTC 0 = Not Used
1 = Used

0 integer

PIT Parameters
C_USE_PITx(2) Enable implementation of 

PIT
0 = Not Used
1 = Used

0 integer

C_PITx_SIZE(2) Size of PITx counter 1 - 32 1 integer

C_PITx_READABLE(2) Make PITx counter 
software readable

0 = Not SW
readable
1 = SW readable

1 integer

http://www.xilinx.com
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C_PITx_PRESCALER(2)(3) Select PITx prescaler 0 = No prescaler
1 = FIT1
2 = FIT2
3 = FIT3
4 = FIT4
5 = PIT1
6 = PIT2
7 = PIT3
8 = PIT4
9 = External

0 integer

C_PITx_INTERRUPT(2) Use PITx_Interrupt in INTC 0 = Not Used
1 = Used

0 integer

GPO Parameters
C_USE_GPOx(2) Use GPOx 0 = Not Used

1 = Used
0 integer

C_GPOx_SIZE(2) Size of GPOx 1 - 32 32 integer

C_GPOx_INIT(2) Initial value for GPOx Fit Range 
(31:0)

all zeros std_logic_vector

GPI Parameters
C_USE_GPIx(2) Use GPIx 0 = Not Used

1 = Used
0 integer

C_GPIx_SIZE(2) Size of GPIx 1 - 32 32 integer

C_GPIx_INTERRUPT(2) Use GPIx_Interrupt in 
INTC

0 = None
1 = Both Edges
2 = Rising Edge
3 = Falling Edge

0 integer

INTC Parameters
C_INTC_USE_EXT_INTR Use I/O Module external 

interrupt inputs
0 = Not Used
1 = Used

0 integer

C_INTC_INTR_SIZE Number of external 
interrupt inputs used

1 - 16 1 integer

C_INTC_LEVEL_EDGE Level or edge triggered 
for each external 
interrupt

For each bit:
0 = Level
1 = Edge

level std_logic_vector

C_INTC_POSITIVE Polarity for each external 
interrupt

For each bit:
0 = active-Low
1 = active-High

active-High std_logic_vector

C_INTC_HAS_FAST Use fast interrupt mode 0 = Not Used
1 = Used

0 integer

C_INTC_ADDR_WIDTH Interrupt Address width 5 - 32 32 integer

Table 4-1: I/O Module Parameters (Cont’d)

Parameter Name Feature/Description Allowable
Values

Default
Value VHDL Type
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C_INTC_BASE_VECTORS Relocatable base vector 
address

0x00000000 -
0xFFFFFF80(4)

0x00000000 std_logic_vector

1. Values automatically populated by tool.
2. x =1, 2, 3 or 4.
3. Selecting PIT prescaler the same as PITx is illegal, e.g. PIT2 cannot be prescaler to itself.
4. The 7 least signif icant bits must all be 0.

Table 4-1: I/O Module Parameters (Cont’d)

Parameter Name Feature/Description Allowable
Values

Default
Value VHDL Type
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Required Constraints
There are no required constraints for this core.

Device, Package, and Speed Grade Selections
There are no Device, Package or Speed Grade requirements for this core.

Clock Frequencies
There are no specific clock frequency requirements for this core.

Clock Management
The I/O Module is fully synchronous with all clocked elements clocked by the Clk input.

To operate properly when connected to MicroBlaze™, the Clk must be the same as the 
MicroBlaze Clk .

Clock Placement
There are no specific Clock placement requirements for this core.

http://www.xilinx.com
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Banking
There are no specific Banking rules for this core.

Transceiver Placement
There are no Transceiver Placement requirements for this core.

I/O Standard and Placement
There are no specific I/O standards and placement requirements for this core.

http://www.xilinx.com
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Customizing and Generating the Core

Constraining the Core
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Customizing and Generating the Core
This chapter includes information on using Xilinx tools to customize and generate the core 
in the ISE® Design Suite.

GUI
The I/O Module parameters are divided in seven tabs: System, UART, FIT Timers, PIT Timers, 
GPO, GPI and Interrupt.

The System tab showing the Addresses parameters is shown in Figure 6-1.

• I/O Module Register Base Address - Base address of the internal registers.

• I/O Module Register High Address - High address of the internal registers.

X-Ref Target - Figure 6-1

Figure 6-1: System Tab

http://www.xilinx.com
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• I/O Module Register Address Decode Mask - A mask indicating which address bits 
the module takes into account when decoding a register access.

• Enable IO Bus - Enables the I/O Bus to connect to DRP or external peripherals.

• I/O Module IO Bus Base Address - Base address of the I/O Bus.

• I/O Module IO Bus High Address - High address of the I/O Bus.

• I/O Module IO Bus Address Decode Mask - A mask indicating which address bits the 
module takes into account when decoding an I/O Bus access.

The UART parameter tab is shown in Figure 6-2.

• Enable Receiver - Enables UART receiver for character input. This is automatically 
connected to standard input (stdin) in the software program.

• Enable Transmitter - Enables UART transmitter for character output. This is 
automatically connected to standard output (stdout) in the software program.

• Define Baud Rate - Sets the UART baud rate. To get the correct baud rate, the input 
clock frequency must also be correctly defined.

X-Ref Target - Figure 6-2

Figure 6-2: UART Parameter Tab

http://www.xilinx.com
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• Programmable Baud Rate - Determines if the UART baud rate is programmable. The 
default baud rate is calculated based on the input clock frequency and the defined 
baud rate.

• Number of Data Bits - Defines the number of data bits used by the UART. Should 
almost always be set to 8.

• Use Parity - Enable this parameter to use parity checking of the UART characters.

• Even or Odd Parity - Select odd or even parity. Only available when parity is used.

• Implement Receive Interrupt - Generate an interrupt when the UART has received a 
character. When the interrupt is not enabled the UART must be polled to check if data 
has been received.

• Implement Transmit Interrupt - Generate an interrupt when the UART has sent a 
character. When the interrupt is not enabled the UART must be polled to wait until data 
has been transmitted.

• Implement Error Interrupt - Generate an interrupt if an error occurs when the UART 
receives a character. This error can be a framing error, an overrun error or a parity error 
(if parity is used), When the interrupt is not enabled the UART must be polled to check 
if an error has occurred after a character has been received.

The FIT Timer parameter tab showing the parameters for one of the four timers is shown in 
Figure 6-3.

• Use FIT - Enable the Fixed Interval Timer.

X-Ref Target - Figure 6-3

Figure 6-3: FIT Timers Parameter Tab

http://www.xilinx.com
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• Number of Clocks Between Strobes - The number of clock cycles between each 
strobe.

• Generate Interrupt - Generate an interrupt for each Fixed Interval Timer strobe.

The PIT Timer parameter tab showing the parameters for one of the four timers is shown in 
Figure 6-4.

• Use PIT - Enable the Programmable Interval Timer.

• Number of Bits for Timer - The maximum number of cycles to count before stopping 
or restarting.

• Shall Counter Value be Readable - The Programmable Interval Timer counter is 
readable by software when this parameter is set. Unless resource usage is critical it is 
recommended that this is kept enabled.

• Define Prescaler - Selects a prescaler as source for the Programmable Interval Timer 
count. When no prescaler is selected the core input clock is used. Any Programmable 
Interval Timer or Fixed Interval Timer can be used as prescaler, as well as a dedicated 
external enable input.

• Generate Interrupt - Generate an interrupt when the Programmable Interval Timer has 
counted down to zero.

X-Ref Target - Figure 6-4

Figure 6-4: PIT Timers Parameter Tab
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I/O Module v1.03a www.xilinx.com 48
PG052 March 20, 2013

Chapter 6: Customizing and Generating the Core

The GPO parameter tab showing the parameters for one of the four General Purpose Output 
ports is shown in Figure 6-5.

• Use GPO - Enable the General Purpose Output port.

• Number of Bits - Set the number of bits of the General Purpose Output port.

• Initial Value of GPO - Set the initial value of the General Purpose Output port. The 
right most bit in the value is assigned to bit 0 of the port, the next right most to bit 1, 
and so on.

The GPI parameter tab showing the parameters for one of the four General Purpose Input 
ports is shown in Figure 6-6.

X-Ref Target - Figure 6-5

Figure 6-5: GPO Parameter Tab
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• Use GPI - Enable the General Purpose Input port.

• Number of Bits - Set the number of bits of the General Purpose Input port.

• Generate Interrupt - Generate an interrupt when a General Purpose Input changes in 
the specified way - either any change (Both Edges), only when changed from 0 to 1 
(Rising Edge), or only when changed from 1 to 0 (Falling Edge).

The Interrupt parameter tab is shown in Figure 6-7.

X-Ref Target - Figure 6-6

Figure 6-6: GPI Parameter Tab
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• Use External Interrupts - Shows if external interrupt inputs are used.

• Number of External Inputs - Shows the number of used external interrupt inputs.

• Use Low-latency Interrupt Handling - Enable the use of low-latency interrupt 
handling.

Parameter Values
To allow the user to obtain an I/O Module that is uniquely tailored a specific system, certain 
features can be parameterized in the I/O module design. This allows the user to configure 
a design that only utilizes the resources required by the system, and operates with the best 
possible performance. The specif ic features that can be parameterized in Xilinx I/O Module 
EDK designs are shown in Table 6-1. See SECTION II: VIVADO DESIGN SUITE, Chapter 4, 
Customizing and Generating the Core for additional parameters.

X-Ref Target - Figure 6-7

Figure 6-7: Interrupt Parameter Tab
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Table 6-1: EDK I/O Module Parameters

Parameter Name Feature/Description Allowable
Values

Default
Value VHDL Type

C_FREQ(1) Frequency of CLK input 100000000 integer

C_INSTANCE(1) Instance name Any legal VHDL
string

“iomodule” string

C_BASEADDR LMB I/O Module Register Base 
Address

Valid Address
Range(2)

0xFFFFFFFF std_logic_vector

C_HIGHADDR LMB I/O Module Register High 
Address

Valid Address
Range(2)

0x00000000 std_logic_vector

C_MASK LMB I/O Module Register Address 
Space Decode Mask

Valid decode
mask(3)

0x00800000 std_logic_vector

C_IO_HIGHADDR LMB I/O Module I/O Bus Base 
Address

Valid Address
Range(2)

0xFFFFFFFF std_logic_vector

C_IO_LOWADDR LMB I/O Module I/O Bus Address Valid Address
Range(2)

0x00000000 std_logic_vector

C_IO_MASK LMB I/O Module I/O Bus Address 
Space Decode Mask

Valid decode
mask(3)

0x00800000 std_logic_vector

C_LMB_AWIDTH LMB Address Bus Width 32 32 integer

C_LMB_DWIDTH LMB Data Bus Width 32 32 integer
1. Values automatically populated by tool.
2. The range specif ied by BASEADDR and HIGHADDR must comprise a complete, contiguous power-of-two range, 

such that range = 2n, and the n least signif icant bits of BASEADDR must be zero.
3. The decode mask determines which bits are used by the LMB decode logic to decode a valid access to LMB.
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Clock Management
The I/O Module is fully synchronous with all clocked elements clocked by the Clk input.

To operate properly when connected to MicroBlaze™, the Clk must be the same as the 
MicroBlaze Clk .
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Migrating
This appendix describes migrating from older versions of the IP to the current IP release.

For information on migrating to the Vivado™ Design Suite, see the Vivado Design Suite 
Migration Methodology Guide [Ref 3].

http://www.xilinx.com
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Debugging
This appendix includes details about resources available on the Xilinx Support website and 
debugging tools. In addition, this appendix provides a step-by-step debugging process to 
guide you through debugging the I/O Module core.

The following topics are included in this appendix:

• Finding Help on Xilinx.com

• Debug Tools

• Simulation Debug

• Hardware Debug

Finding Help on Xilinx.com
To help in the design and debug process when using the I/O Module, the Xilinx Support 
web page (www.xilinx.com/support) contains key resources such as product documentation, 
release notes, answer records, information about known issues, and links for opening a 
Technical Support WebCase.

Documentation
This product guide is the main document associated with the I/O Module. This guide, along 
with documentation related to all products that aid in the design process, can be found on 
the Xilinx Support web page (www.xilinx.com/support) or by using the Xilinx 
Documentation Navigator.

Download the Xilinx Documentation Navigator from the Design Tools tab on the Downloads 
page (www.xilinx.com/download). For more information about this tool and the features 
available, open the online help after installation.

Release Notes
Known issues for all cores, including the I/O Module are described in the IP Release Notes 
Guide (XTP025).

http://www.xilinx.com
www.xilinx.com/support
www.xilinx.com/support
www.xilinx.com/download
www.xilinx.com/support
http://www.xilinx.com/support/documentation/ip_documentation/xtp025.pdf
http://www.xilinx.com/support/documentation/ip_documentation/xtp025.pdf
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Contacting Technical Support
Xilinx provides technical support at www.xilinx.com/support for this LogiCORE™ IP product 
when used as described in the product documentation. Xilinx cannot guarantee timing, 
functionality, or support of product if implemented in devices that are not defined in the 
documentation, if customized beyond that allowed in the product documentation, or if 
changes are made to any section of the design labeled DO NOT MODIFY.

To contact Xilinx Technical Support:

1. Navigate to www.xilinx.com/support.

2. Open a WebCase by selecting the WebCase link located under Support Quick Links.

When opening a WebCase, include:

• Target FPGA including package and speed grade.

• All applicable Xilinx Design Tools and simulator software versions.

• Additional f iles based on the specif ic issue might also be required. See the relevant 
sections in this debug guide for guidelines about which f ile(s) to include with the 
WebCase.

Debug Tools
The main tools available to address I/O Module design issues are the Vivado™ Lab tools.

Vivado Lab Tools
Vivado™ inserts logic analyzer and virtual I/O cores directly into your design. Vivado Lab 
Tools allows you to set trigger conditions to capture application and integrated block port 
signals in hardware. Captured signals can then be analyzed. This feature represents the 
functionality in the Vivado IDE that is used for logic debugging and validation of a design 
running in Xilinx FPGAs in hardware.

The Vivado logic analyzer is used to interact with the logic debug LogiCORE IP cores, 
including:

• ILA 2.0 (and later versions)

• VIO 2.0 (and later versions)

Reference Boards
All Xilinx development boards support the I/O Module. These boards can be used to 
prototype designs and establish that the core can communicate with the system.

http://www.xilinx.com
http://www.xilinx.com/support/clearexpress/websupport.htm
www.xilinx.com/support
http://www.xilinx.com/support
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Simulation Debug
The simulation debug flow for Questa SIM is described below. A similar approach can be 
used with other simulators.

• Check for the latest supported versions of Questa SIM in the Xilinx Design Tools: 
Release Notes Guide. Is this version being used? If not, update to this version.

• If using Verilog, do you have a mixed mode simulation license? If not, obtain a 
mixed-mode license.

• Ensure that the proper libraries are compiled and mapped. In Xilinx Platform Studio this 
is done within the tool using Edit > Preferences > Simulation, and in Vivado Design 
Suite using Flow > Simulation Settings.

• Have you associated the intended software program for the MicroBlaze processor with 
the simulation? Use Project > Select Elf File in Xilinx Platform Studio to do this. Make 
sure to regenerate the simulation f iles with Simulation > Generate Simulation HDL 
Files afterwards. The equivalent command in Vivado Design Suite is Tools > Associate 
ELF Files.

• When observing the traff ic on the LMB interface connected to the LMB BRAM I/F 
Controller, see the MicroBlaze Processor Reference Guide [Ref 1] for the LMB timing.

Hardware Debug
This section provides debug steps for common issues. The Vivado Lab tools debugging 
feature is a valuable resource to use in hardware debug. The signal names mentioned in the 
following individual sections can be probed using the debugging feature to debug specific 
problems.

Many of these common issues can also be applied to debugging design simulations. Details 
are provided on:

• General Checks

• LMB Checks

General Checks
Ensure that all the timing constraints for the core were properly incorporated from the 
example design and that all constraints were met during implementation. 

http://www.xilinx.com
http://www.xilinx.com/support/documentation/sw_manuals/xilinx14_5/irn.pdf
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• Does it work in post-place and route timing simulation? If problems are seen in 
hardware but not in timing simulation, this could indicate a PCB issue. Ensure that all 
clock sources are active and clean. 

• If using MMCMs in the design, ensure that all MMCMs have obtained lock by 
monitoring the LOCKED port.

LMB Checks
To monitor the LMB interface, the signals LMB_ABus, LMB_WriteDBus, LMB_ReadStrobe, 
LMB_AddrStrobe, LMB_WriteStrobe, LMB_BE, Sl_DBus, and Sl_Ready can be 
connected to the Vivado Lab tools logic analyzer.

To sample the interface signals, the Vivado Lab tools should use the Clk clock signal.

http://www.xilinx.com
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Device Drivers
The I/O Module is supported by the IO Module driver, included with Xilinx Software 
Development Kit.

http://www.xilinx.com
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Xilinx Resources
For support resources such as Answers, Documentation, Downloads, and Forums, see the 
Xilinx Support website at:

www.xilinx.com/support.

For a glossary of technical terms used in Xilinx documentation, see:

www.xilinx.com/company/terms.htm.
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These documents provide supplemental material useful with this user guide:

1. MicroBlaze Processor Reference Guide (UG081)

2. 7 Series FPGAs Configuration User Guide (UG470)

3. Vivado™ Design Suite Migration Methodology Guide (UG911)

4. Vivado Design Suite user documentation
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