ISE Design Suite
Using SmartXplorer
SmartXplorer allows you to run multiple implementation flows using different sets of implementation properties designed to optimize design performance. In addition, SmartXplorer can greatly reduce overall runtime by utilizing multiple host machines or processors to run individual strategies simultaneously, which differs by operating system as follows:
  • Linux operating system - SmartXplorer can run multiple jobs in parallel on different machines across the following types of networks:
    • Linux network - SmartXplorer manages the job distribution across the network based on the list of machines you specify.
    • Load Sharing Facility (LSF) or Sun Grid Engine (SGE) compute farm - LSF or SGE manages the job distribution based on the number of machines you specify.
    Note If you do not have access to a Linux network, SmartXplorer can run multiple strategies in parallel on a single Linux machine that has multiple processors available.
  • Windows operating system - SmartXplorer can run multiple strategies in parallel on a single Windows machine that has multiple processors available.
Note On both Linux and Windows operating systems, SmartXplorer can run jobs serially on a single processor.
For more information on SmartXplorer, see the “SmartXplorer” chapter in the Command Line Tools User Guide (UG628).
To Run SmartXplorer from Project Navigator
  1. Select Tools > SmartXplorer > Launch SmartXplorer, or click the SmartXplorer toolbar button Image.
  2. In the Exploration Mode area of the Launch SmartXplorer dialog box, set the following options:
    • Select one of the following options to specify which exploration mode to use:
      • Use built-in SmartXplorer strategies for
        Select this option to use predefined SmartXplorer strategies. The process property settings defined in these strategies override your existing process property settings. Default values are used for any properties that are not explicitly defined in the SmartXplorer strategies.
        Note Some strategies are supported for certain device families only.
      • Use current process properties and iterate Cost Table only - Starting Placer Cost Table
        Select this option to use all of your existing process property settings, except for the Starting Placer Cost Table property. The Cost Table is incremented with each SmartXplorer run iteration.
        Use the Starting Placer Cost Table property in this dialog box to specify the first Cost Table to use in the SmartXplorer run. There are 100 cost tables, numbered 1 through 100. Each cost table assigns weighted values to relevant factors, such as constraints, length of connection, and available routing resources.
        Note This option is the replacement for Multi-Pass Place & Route.
      • Use custom SmartXplorer strategy file
        Select this option to specify your own custom SmartXplorer strategy. The process property settings defined in this strategy override your existing process property settings. Default values are used for any properties that are not explicitly defined in the SmartXplorer strategy. For information on creating a custom SmartXplorer strategy file, see the “SmartXplorer” chapter of the Command Line Tools User Guide (UG628).
    • In the Maximum number of runs option, set the number of times to run implementation. The maximum is 100.
      Note When using predefined SmartXplorer strategies, if the Maximum number of runs is greater than the number of predefined SmartXplorer strategies, additional runs are made by incrementing the Starting Placer Cost Table.
    • Optional. Select Run all strategies/iterations to continue running SmartXplorer until the maximum number of runs is met. This option is useful if you want to find out which strategy best meets your design goals while still meeting timing.
      Note If this option is disabled, SmartXplorer automatically stops when one of the strategies meets timing.
    • Optional. Select Perform power analysis for each run. When this option is selected, power analysis is run for each placed and routed result, using the settings specified in the Power Report Properties dialog box.
  3. Linux operating system only. In the Host Mode to run SmartXplorer iterations area, set the following options:
    • Select one of the following options to specify which host to use:
      • Use hosts specified in list below
        In the field below this option, enter a host name and click the Add button to add it to the list. Enter as many hosts as needed. To remove a host from the list, select the host, and click Remove. The host name is identical to the machine name.
        Note To specify multiple processors to be used as separate hosts on a single machine, list the host name multiple times.
      • Use host list file
        In the field next to this option, specify a host list file that contains the list of hosts. Click the Browse button to find the file.
        To create a host list file for an LSF or SGE compute farm, use the following syntax:
        • LSF compute farm syntax: :LSF {"queue_name": "MYQUEUE", "max_concurrent_runs":N, "bsub_options": "additional_options"}
        • SGE compute farm syntax: :SGE {"queue_name": "MYQUEUE", "max_concurrent_runs":N, "qsub_options": "additional_options"}
        where:
        • queue_name defines the queue name. You must replace MYQUEUE with an LSF or SGE queue name.
        • max_concurrent_runs defines the maximum number of jobs that can be run in parallel. You must replace N with a positive integer value.
        • bsub_options defines additional LSF options. You must replace additional_options with LSF options or, if you are not using additional options, with an empty string: “”.
        • qsub_options defines additional SGE options. You must replace additional_options with SGE options or, if you are not using additional options, with an empty string: “”.
    • Program to execute commands on remote hosts
      This option specifies which program to use for logging into remote hosts and executing commands on the host. Values are rsh or ssh. The default is rsh.
  4. Windows operating system only. In the Number of parallel runs on this machine option, set the number of processors available.
    The default value of this field matches the number of processors you have available on the host machine. The maximum is 99.
  5. Optional. In the Results Options area, select one or both of the following options:
    • Automatically copy best result to working project directory when SmartXplorer is complete
      Results are only copied if timing is met for one of the runs (Timing score = 0). If timing is not met, the results are not copied, even if this option is selected.
    • Keep only N best runs (other run results will be deleted)
      When this option is selected, you can specify a value for N in which the maximum value allowed is equal to the value of the Maximum number of runs option. The output files for the N best runs will be retained, and the rest of the files will be deleted.
  6. Optional. In the Other SmartXplorer command line options field, enter additional command line options. Separate multiple options with a space.
    The options entered in this property appear first on the command line, before all other property options specified in the dialog box. Avoid setting duplicate property options. For more information, see the “SmartXplorer” chapter of the Command Line Tools User Guide (UG628).
  7. Click OK to start SmartXplorer.
To Abort SmartXplorer Runs
From the SmartXplorer Results window, you can abort currently running SmartXplorer runs using either of the following methods:
  • To abort an individual run, click the checkbox to the left of the strategy name, and click the Abort Run(s) button. You can abort multiple runs at one time.
  • To abort all SmartXplorer runs, click the Abort All button to the right of the SmartXplorer status bar.
Note Any completed runs remain in their current state, and you can analyze or copy these results to your project using Copy Result.
To View SmartXplorer Results
When SmartXplorer is running, the SmartXplorer Results window opens in the Project Navigator Workspace. This window contains the following columns, which show the results of each of the SmartXplorer runs and the properties used for each strategy:
  • Strategy - shows the name of the strategy used for each run. Click the strategy name in the Strategy column to see the implementation process properties used by that strategy.
  • Host - shows the host used for each run.
  • Output - shows the output directory for each run.
  • Status - shows the current implementation status for each run. Click the link in this column to see the Design Summary and reports for the selected run.
  • Timing Score - shows the current timing score for each run.
  • Run Time - shows the runtime elapsed for each run.
  • Resource Utilization - shows utilization for various device resources, as reported by SmartXplorer. Each resource type reported is shown in a separate column.
    Note The SmartXplorer Results window only shows a subset of the architectural resource types. For a full report, click the link in the Status column to see the Design Summary and reports for the selected run.
You can change the display of these columns as follows:
  1. In the SmartXplorer Results window, click the Display Options button at the bottom of the tab.
    Note Alternatively, you can right-click in the SmartXplorer Results window and select Display Options.
  2. In the SmartXplorer Results Options dialog box, set the following options:
    • Column Sizes - controls how column width is determined.
    • Data to Display - controls which columns appear in the SmartXplorer Results window and in the SmartXplorer Run Comparison window when you compare SmartXplorer results.
  3. Click Apply or OK.
In addition, you can right-click in the column headers of the SmartXplorer Results window and select Hide Column to control the column display. You can also drag and drop columns to change the order.
Note To view the SmartXplorer Results window at any time, select Tools > SmartXplorer > Show SmartXplorer Results. This shows the results of the most recent SmartXplorer run.
To Copy SmartXplorer Results
You can copy the results of a selected run into the active project as follows:
  1. In the SmartXplorer Results window, click the checkbox next to an individual run.
  2. Click the Copy Results button at the bottom of the tab.
    Note The Copy Result button is enabled as each run is completed. You can copy results as soon as the button is enabled, even if SmartXplorer is still completing the remaining runs.
If you use the Use built-in SmartXplorer strategies option in the Launch SmartXplorer dialog box and copy a SmartXplorer result, the strategy used for that run is automatically applied to the project and also added to the Design Goals and Strategies dialog box. To apply this Design Strategy to your project at a later time, do the following:
  1. Select Project > Design Goals & Strategies.
  2. In the Design Goals and Strategies dialog box, set the Design Goal to Timing Performance.
  3. Select the Strategy from the drop-down list.
    Note For more information, see Using Design Goals and Strategies.
If you use the Use current process properties and iterate Cost Table only option in the Launch SmartXplorer dialog box, the process properties reflect the settings used in the SmartXplorer run, including the appropriate Cost Table value. If you use the Use custom SmartXplorer strategy file option in the Launch SmartXplorer dialog box and the custom strategy file contains command line options to run synthesis, copying the SmartXplorer result does not update the process properties for synthesis.
To Compare SmartXplorer Results
You can compare the results of multiple SmartXplorer runs as follows:
  1. In the SmartXplorer Results window, click the checkboxes next to the runs you want to compare.
  2. Click the Compare button at the bottom of the tab.
The SmartXplorer Run Comparison window shows the compared results in tabular format.
Note To change the order of the rows in the SmartXplorer Run Comparison window, you can drag and drop the rows. To change the rows that appear in the SmartXplorer Run Comparison window, click the Display Options button in the SmartXplorer Results window, and select the data to display in the Compare Table column of the SmartXplorer Results Options dialog box.
See Also

© Copyright 1995–2013, Xilinx® Inc. All rights reserved.