Notice of Disclaimer
The information disclosed to you hereunder (the “Materials”) is provided solely for the selection and use of Xilinx products. To the maximum extent permitted by applicable law: (1) Materials are made available “AS IS” and with all faults, Xilinx hereby DISCLAIMS ALL WARRANTIES AND CONDITIONS, EXPRESS, IMPLIED, OR STATUTORY, INCLUDING BUT NOT LIMITED TO WARRANTIES OF MERCHANTABILITY, NON-INFRINGEMENT, OR FITNESS FOR ANY PARTICULAR PURPOSE; and (2) Xilinx shall not be liable (whether in contract or tort, including negligence, or under any other theory of liability) for any loss or damage of any kind or nature related to, arising under, or in connection with, the Materials (including your use of the Materials), including for any direct, indirect, special, incidental, or consequential loss or damage (including loss of data, profits, goodwill, or any type of loss or damage suffered as a result of any action brought by a third party) even if such damage or loss was reasonably foreseeable or Xilinx had been advised of the possibility of the same. Xilinx assumes no obligation to correct any errors contained in the Materials or to notify you of updates to the Materials or to product specifications. You may not reproduce, modify, distribute, or publicly display the Materials without prior written consent. Certain products are subject to the terms and conditions of the Limited Warranties which can be viewed at http://www.xilinx.com/warranty.htm; IP cores may be subject to warranty and support terms contained in a license issued to you by Xilinx. Xilinx products are not designed or intended to be fail-safe or for use in any application requiring fail-safe performance; you assume sole risk and liability for use of Xilinx products in Critical Applications: http://www.xilinx.com/warranty.htm#critapps.

© Copyright 2012-2013 Xilinx, Inc. Xilinx, the Xilinx logo, Artix, ISE, Kintex, Spartan, Virtex, Vivado, Zynq, and other designated brands included herein are trademarks of Xilinx in the United States and other countries. All other trademarks are the property of their respective owners.

Revision History
The following table shows the revision history for this document.

<table>
<thead>
<tr>
<th>Date</th>
<th>Version</th>
<th>Revision</th>
</tr>
</thead>
<tbody>
<tr>
<td>03/20/2013</td>
<td>2013.1</td>
<td>Added Launching the Vivado Design Suite in Chapter 1.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Added associated Tcl commands for various procedures in Chapter 2, Working with Projects.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Updated Working with IP Sources, added Working with IP Integrator Sources, and added note about Vivado™ IP integrator to Working with Embedded Sources in Chapter 3, Working with Source Files.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Added associated Tcl commands for various procedures and added information on creating and applying constraints at the RTL level to Chapter 4, Elaborating the RTL Design.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Updated Figure 2-16, Figure 3-1, Figure 3-2, Figure 3-5, Figure 3-7, Figure 3-13, Figure 3-14, Figure 3-15, Figure 3-16, Figure 3-17, Figure 3-21, Figure 3-25, Figure 3-26, Figure 3-30, Figure 4-2, and Figure 4-3.</td>
</tr>
<tr>
<td>06/19/2013</td>
<td>2013.2</td>
<td>Removed references to Vivado IP integrator as early access.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Added note about selecting boards to Creating an RTL Project, added information about init.tcl file to Archiving Projects, and added Working with Source Control Systems in Chapter 2, Working with Projects.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Updated Figure 2-11 and Figure 2-12.</td>
</tr>
<tr>
<td>Date</td>
<td>Version</td>
<td>Revision</td>
</tr>
<tr>
<td>------------</td>
<td>---------</td>
<td>--------------------------------------------------------------------------</td>
</tr>
<tr>
<td>10/02/2013</td>
<td>2013.3</td>
<td>Updated Working with Source Control Systems, Using the Project Summary, and IP Settings in Chapter 2, Working with Projects. Updated Associating an ELF File and Cross Probing to Source Files in Chapter 3, Working with Source Files. Updated Running DRCs in Chapter 4, Elaborating the RTL Design. Updated Figure 2-5, Figure 2-12, Figure 2-13, Figure 2-14, Figure 2-16, Figure 2-18, Figure 3-4, Figure 3-29, Figure 4-3, and Figure 4-4.</td>
</tr>
<tr>
<td>12/18/2013</td>
<td>2013.4</td>
<td>No technical updates. Re-release only.</td>
</tr>
</tbody>
</table>
# Table of Contents

Revision History .................................................................................................................. 2

## Chapter 1: Introduction

Overview ................................................................................................................................. 6
Launching the Vivado Design Suite. ....................................................................................... 6

## Chapter 2: Working with Projects

Overview ................................................................................................................................. 9
Project Types ......................................................................................................................... 9
Creating a Project. .................................................................................................................. 11
Managing Projects ............................................................................................................... 25
Using the Project Summary. ................................................................................................. 29
Configuring Project Settings ............................................................................................... 31
Creating a Project Using a Tcl Script .................................................................................. 38

## Chapter 3: Working with Source Files

Overview ................................................................................................................................. 40
Working with Sources in Project Mode ................................................................................ 40
Working with Sources in Non-Project Mode ....................................................................... 83

## Chapter 4: Elaborating the RTL Design

Overview ................................................................................................................................. 85
Elaborating the Design in Project Mode. ............................................................................. 85
Elaborating the Design in Non-Project Mode ..................................................................... 93

## Chapter 5: Debugging the Design

Overview ................................................................................................................................. 94
RTL-Level Design Simulation .............................................................................................. 94
In-System Debugging .......................................................................................................... 95

## Appendix A: Additional Resources

Xilinx Resources .................................................................................................................... 96
Solution Centers ................................................................................................................... 96
Introduction

Overview

The Vivado® Design Suite enables you to take your design from full register-transfer level (RTL) creation to bitstream generation. System-level design entry consists of setting up your design, including creating a project (if applicable), creating and adding source files, elaborating the RTL design, and inserting and configuring debug information. You can enter your design using the graphical user interface (GUI), known as the Vivado Integrated Design Environment (IDE), or using Tcl commands and scripts.

Launching the Vivado Design Suite

You can launch the Vivado Design Suite and run the tools using different methods depending on your preference. For example, you can choose a Tcl script-based compilation style method in which you manage sources and the design process yourself, also known as Non-Project Mode. Alternatively, you can use a project-based method to automatically manage your design process and design data using projects and project states, also known as Project Mode. Either of these methods can be run using a Tcl scripted batch mode or run interactively in the Vivado IDE. For more information on the different design flow modes, see the Vivado Design Suite User Guide: Design Flows Overview (UG892) [Ref 1].

Note: Installation, licensing, and release information is available in the Vivado Design Suite User Guide: Release Notes, Installation, and Licensing (UG973) [Ref 2]. For information on getting software updates through XilinxNotify, see the Vivado Design Suite User Guide: Getting Started (UG910) [Ref 3].
Working with Tcl

If you prefer to work directly with Tcl, you can interact with your design using Tcl commands using either of the following methods:

- Enter individual Tcl commands in the Vivado Design Suite Tcl shell outside of the Vivado IDE.
- Enter individual Tcl commands in the Tcl Console at the bottom of the Vivado IDE.
- Run Tcl scripts from the Vivado Design Suite Tcl shell.
- Run Tcl scripts from the Vivado IDE.

For more information about using Tcl and Tcl scripting, see the Vivado Design Suite User Guide: Using Tcl Scripting (UG894) [Ref 4] and Vivado Design Suite Tcl Command Reference Guide (UG835) [Ref 5]. For a step-by-step tutorial that shows how to use Tcl in the Vivado tools, see the Vivado Design Suite Tutorial: Design Flows Overview (UG888) [Ref 6].

Launching the Vivado Design Suite Tcl Shell

Use the following command to invoke the Vivado Design Suite Tcl shell either at the Linux command prompt or within a Windows Command Prompt window:

```
vivado -mode tcl
```

*Note:* On Windows, you can also select Start > All Programs > Xilinx Design Tools > Vivado 2013.x > Vivado 2013.x Tcl Shell.

Launching the Vivado Tools Using a Batch Tcl Script

You can use the Vivado tools in batch mode by supplying a Tcl script when invoking the tool. Use the following command either at the Linux command prompt or within a Windows Command Prompt window:

```
vivado -mode batch -source <your_Tcl_script>
```

*Note:* When working in batch mode, the Vivado tools exit after running the specified script.
Working with the Vivado IDE

If you prefer to work in a GUI, you can launch the Vivado IDE from Windows or Linux. For more information on the Vivado IDE, see the Vivado Design Suite User Guide: Using the Vivado IDE (UG893) [Ref 7].

**RECOMMENDED:** Launch the Vivado IDE from your working directory. This makes it easier to locate the project file, log files, and journal files, which are written to the launch directory.

Launching the Vivado IDE on Windows

Select **Start > All Programs > Xilinx Design Tools > Vivado 2013.x > Vivado 2013.x.**

**Note:** You can also double-click the Vivado IDE shortcut icon on your desktop.

![Figure 1-1: Vivado IDE Desktop Icon](image)

Launching the Vivado IDE from the Command Line on Windows or Linux

Enter the following command at the command prompt:

```
vivado
```

**Note:** When you enter this command, it automatically runs `vivado -mode gui` to launch the Vivado IDE. If you need help, type `vivado -help`.

Launching the Vivado IDE from the Vivado Design Suite Tcl Shell

Enter the following command at the Tcl command prompt:

```
start_gui
```
Working with Projects

Overview

When working in Project Mode, you can enter your design using various project types. This chapter describes each project type and explains how to create and manage projects. It also covers the Project Summary, Project Settings, and how to create a project using a Tcl script.

Project Types

Using the Vivado® IDE, you can create the following types of projects. Each project type includes different input source types.

- Register-transfer level (RTL) project
- Post-synthesis project
- I/O planning project
- Imported project

Note: A project cannot be changed to a different project type after it is created. The only exception is the I/O planning project, which can be used as the basis for an RTL project.

RTL Projects

You can use the Vivado IDE to manage the entire design flow from RTL creation through bitstream generation. You can add RTL source files, EDIF netlists for blocks of the design, and IP. IP can include XCI files generated by the Vivado tools, XCO files generated by the CORE Generator™ tool, and precompiled NGC-format IP netlists.

You can elaborate and analyze the RTL to ensure proper constructs, launch and manage various synthesis and implementation runs, and analyze the design and run results. You can also experiment with different constraints or implementation strategies.
**Post-Synthesis Projects**

You can create projects using post-synthesis netlists. Netlists can be created using the Vivado IDE, XST, or any supported third-party synthesis tool. For example, the Vivado IDE can import EDIF, NGC, structural SystemVerilog, or Verilog format netlists as well as Vivado design checkpoint (DCP) files. The netlist can be made up of a single file that is all-inclusive or a set of files that is hierarchical and consists of multiple, module-level netlists.

You can analyze the logic netlist, launch and manage various implementation runs, and analyze the design and run results. You can also experiment with different constraints or implementation strategies.

*Note:* When you import an NGC or EDIF file with embedded timing constraints, the constraints are not used. For information on creating Xilinx® design constraints (XDC) files, see the *Vivado Design Suite User Guide: Using Constraints* (UG903) [Ref 8]. For information on converting user constraints files (UCF) to XDC constraints, see the *Vivado Design Suite Migration Methodology Guide* (UG911) [Ref 9].

**I/O Planning Projects**

You can perform I/O planning early in the design cycle by creating an empty I/O planning project. You can create I/O ports within the Vivado IDE or import them with either comma separated value (CSV) or XDC input files. You can also create I/O planning projects to explore the logic resources available in the different device architectures.

After I/O assignment, the Vivado IDE can create CSV, XDC, and RTL output files for use later in the design flow when RTL sources or netlists are available. The output files can also be used to create schematic symbols for use in the printed circuit board (PCB) design process.

*Note:* You can use an I/O planning project as the basis for an RTL-based design project. For more information, see the *Vivado Design Suite User Guide: I/O and Clock Planning* (UG899) [Ref 10].

**Imported Projects**

You can import project data from Synopsys Synplify, XST, or ISE® Design Suite Project Navigator to migrate an RTL project into the Vivado tools. The project source files and compilation order are imported, but implementation results and project settings are not.
Creating a Project

The New Project wizard takes you through the steps to define a project name and location, add source files and constraint files to the project, and select a target device.

1. In the Vivado IDE, select **File > New Project**.
   
   *Note:* Alternatively, you can select the **New Project** toolbar button . You can also select **Create a New Project** on the Getting Started Page.

2. In the New Project wizard, review the overview, and click **Next**.

3. In the Project Name page (Figure 2-1), set the following options, and click **Next**.
   - **Project name**: Specifies the name of the project (for example, `project_1`).
   - **Project location**: Specifies the location for the new project directory.
   - **Create Project Subdirectory**: Adds a subdirectory with the same name as the project to the specified project location.

   *Note:* By default, this checkbox is enabled and the project file (.xpr extension) is created at `<project_location>/<project_name>`. All folders and data files created for the project are stored in the `<project_name>` subdirectory. If you disable this checkbox, the project file (xpr extension) is created at `<project_location>`, and all folders and data files created for the project are stored in that project location.

![New Project Wizard—Project Name Page](image.png)

*Figure 2-1: New Project Wizard—Project Name Page*
4. In the Project Type page (Figure 2-2), specify the type of project, which determines the types of source files that are associated with the project.

![New Project Wizard—Project Type Page](image)

**Figure 2-2:** New Project Wizard—Project Type Page

5. Depending on the type of project you are creating, continue with the instructions in one of the following sections. The remaining pages of the wizard guide you through adding appropriate sources to the project.

- Creating an RTL Project
- Creating a Post-Synthesis Project
- Creating an I/O Planning Project
- Importing an External Project

### Creating an RTL Project

You can specify RTL source files to create a project for use with RTL code development and analysis as well as synthesis and implementation. For more information on RTL development and analysis, see Chapter 4, Elaborating the RTL Design.

**IMPORTANT:** If you plan to add XMP files to your design, do not include spaces in your path structure. XPS does not currently support spaces in paths. In general, Xilinx does not recommend including spaces in your path structure.

1. Follow the steps in Creating a Project.
2. In the Project Type page, select **RTL Project**, and click **Next**.

**Note:** If necessary, you can select **Do not specify sources at this time**. This skips the steps of adding design sources and enables you to select the target part and create the project.
3. In the Add Sources page (Figure 2-3), set the following options, and click **Next**: 

- **Add Files**: Opens a file browser so you can select files to add to the project. You can add the following file types to an RTL project: HDL, EDIF, NGC, BMM, ELF, and other file types.
  
  **Note**: In the Add Source Files dialog box, each file or directory is represented by an icon indicating it as a file or folder. A small red square indicates it is read only.

- **Add Directories**: Opens a directory browser to add source files from the selected directories. Files in the specified directory with valid source file extensions are added to the project.

- **Create File**: Opens the Create Source File dialog box in which you can create new VHDL, Verilog, Verilog header, or SystemVerilog files. Create Source File dialog box, set the following options:
  
  - **File type**: Specifies one of the following file formats: Verilog file (.v extension), Verilog Header file (.vh extension), SystemVerilog file (.sv extension), or VHDL file (.vhdl extension).
  
  - **File name**: Specifies a name for the new HDL source file.
  
  - **File location**: Specifies a location in which to create the file.
  
  **Note**: A placeholder for the file is added to the list of sources. The file is created when you click **Finish**.

- **Library**: Specifies the RTL library for a file or directory. You can select a library name, or specify a new library name by typing in the Library text field.
  
  **Note**: This option applies to VHDL files only. By default, HDL sources are added to the **work** library. You can create or reference additional user VHDL libraries as needed. For Verilog and SystemVerilog files, leave the library set to **work**.

- **HDL Source for**: Specifies whether the source being loaded is an RTL source file for synthesis and simulation or an RTL test bench for simulation only.

- **Delete**: Removes the selected source files from the list of files to be added.

- **Move Selected File Up**: Moves the file or directory up in the list order. The order of the files affects the order of elaboration and compilation during downstream processes such as synthesis and simulation.

- **Move Selected File Down**: Moves the file or directory down in the list order.

- **Scan and Add RTL Include Files into Project**: Scans all RTL source files and imports any referenced Verilog `include files into the local project directory structure.

- **Copy Sources into Project**: Copies files into the local project directory instead of referencing the original files. If you added directories of source files using Add Directories, the directory structure is maintained when the files are copied locally into the project. For more information, see **Using Remote Sources or Copying Sources into Project** in Chapter 3.
- **Add Sources from Subdirectories**: Adds source files from the subdirectories of directories specified with Add Directories.

- **Target Language**: Specifies the target language for the design as either Verilog or VHDL. New RTL files default to the specified target language. Output files are generated from the design in the specified target language.

![New Project Wizard—Add Sources Page](image)

*Figure 2-3: New Project Wizard—Add Sources Page*

4. **Optional**: In the Add Existing IP page (Figure 2-4), set the following options, and click Next:

- **Add Files**: Invokes a file browser so you can select Xilinx Core Instance (XCI) files, which are native to the Vivado Design Suite, or CORE Generator core (XCO) files.

  The XCI file is an IP-XACT component instance XML file that records the values of project options, customization parameters, and port parameters used to create the IP.

  **Note**: When you add XCI IP created with the Vivado IP catalog, the Vivado IDE automatically imports all available generated targets, such as HDL sources, into the project. When you run synthesis, the IP and the top-level design are synthesized together.

- **Add Directories**: Invokes a file browser so you can select a directory that contains XCI files, which are native to the Vivado Design Suite, or XCO files. After you select the directory, all XCI and XCO files located in the directory and its subdirectories are added to the list of IP.
- **Remove Selected Files and Directories**: The ‘X’ button removes the selected source files and directories from the list.

- **Copy Sources into Project**: Copies files into the local project directory instead of referencing the original files.

*Note*: In some cases, third-party providers offer IP as synthesized NGC or EDIF netlists. To load these files into a design, use the Add Sources command, and specify Add or Create Design Sources. You can also load parameterized cores into the project from within the Vivado IDE using the IP Catalog, as described in Working with IP Sources in Chapter 3.

---

**Figure 2-4**: New Project Wizard—Add Existing IP Page

5. **Optional**: In the Add Constraints page (Figure 2-5), set the following options, and click Next:

- **Add Files**: Invokes a file browser so you can select Synopsys Design Constraint (SDC) or XDC files to add to the project.

- **Create File**: Creates a new top-level XDC file for the project.

- **Remove**: Removes the selected file from the constraint list.

- **Up / Down**: Moves a constraint file up or down in the listed order. Commands are order-dependent; the last-read command of a constraint overwrites the effects of an earlier command.

- **Copy Constraints into Project**: Copies constraint files into the local project directory instead of referencing the original files.

*Note*: Any SDC or XDC file found in the same directories as the RTL or netlist source files associated with the project are automatically listed as constraint files to be added to the project.
6. In the Default Part page (Figure 2-6), select a Xilinx part or targeted design platform (TDP) board, and click **Next**:

   - **Parts**: Lists available devices. Information about the device resources displays in a table view, such as I/O pin count, the number of look-up tables (LUTs) and flip-flops (FFs), and available block RAM. You can filter the list using the Product Category, Family, Sub-Family, Package, Speed Grade, and Temp Grade filters.

   - **Boards**: Lists available TDP boards and the Xilinx part used on the board. Information about device resources displays in a table view similar to the one shown for Parts. You can filter the list using the Family, Package, and Speed Grade filters.

     **Note**: If you select a board, the Vivado IP Catalog includes a Board tab for certain IP during IP customization. You can use this tab to create I/O constraints for the IP, which work with the selected board. For more information, see the Vivado Design Suite User Guide: Designing with IP (UG896) [Ref 11] and Vivado Design Suite User Guide: Designing IP Subsystems Using IP Integrator (UG994) [Ref 12].

   - **Search**: Limits the listed devices to those matching the search criteria you specify.

---

**TIP**: When you select a part, only supported IP is shown in the Vivado IP catalog by default. You can change the default setting to show all IP by deselecting the **Hide** toolbar button in the Vivado IP catalog.
7. In the New Project Summary page, view the selected options that define the project, and click **Finish**.
8. **Optional**: If you used the **Create File** option in **step 3**, the Define Modules dialog box (**Figure 2-7**) appears. In this dialog box, define the module or architecture in the Verilog, Verilog Header, SystemVerilog, or VHDL code using the following options, and click **OK**:

- **Entity name/Module name**: Specifies the name for the entity construct in the VHDL code or the module name in the Verilog or SystemVerilog code.
  
  **Note**: Although the entity or module name defaults to the file name, it does not have to match the file name.

- **Architecture name**: Specifies the Architecture for the RTL source file. By default, the name is Behavioral.
  
  **Note**: This option only applies to VHDL code and does not appear when defining Verilog or SystemVerilog modules.

- **I/O Port Definitions**: Define the ports to be added to the module definition:
  
  - **Port Name**: Defines the name of the port to appear in the RTL code.
  
  - **Direction**: Specifies whether the port is an Input, Output, or Bidirectional port.
  
  - **Bus**: Specifies whether the port is a bus port. Define the width of the bus using the MSB and LSB options.
  
  - **MSB**: Defines the number of the most significant bit (MSB). This combines with the LSB field to determine the width of the bus being defined.
  
  - **LSB**: Defines the number of the least significant bit (LSB).
  
  **Note**: MSB and LSB are ignored if the port is not a bus port.

![Define Module Dialog Box](image)

**Figure 2-7**: **Define Module Dialog Box**

The RTL source files are created and added to your project. The Sources window lists the newly defined modules. To edit the new source files in the Vivado IDE Text Editor,
double-click the file or select **Open File** from the popup menu. For information on editing the newly created file, see **Using the Text Editor in Chapter 3**.

### Creating a Post-Synthesis Project

A post-synthesis project begins with a synthesized netlist and corresponding constraints. You can then analyze, floorplan, and implement the design.

**Note:** You can use either XST or third-party synthesis tools to create the synthesized netlist.

**IMPORTANT:** *When working with EDIF and NGC files, the top cell name must match the name of the file.*

1. Follow the steps in **Creating a Project**.
2. In the Project Type page, select **Post-Synthesis Project**, and click **Next**.
   **Note:** If necessary, you can select **Do not specify sources at this time**. This skips the steps of adding design sources and enables you to select the target part and create the project.
3. In the Add Netlist Sources page (**Figure 2-8**), use the following options to specify netlist files to read, identify the file containing the top module, and define directories to search for lower-level module netlist, and click **Next**.
   - **Add Files:** Invokes a file browser so you can select netlist files (Verilog, SystemVerilog, EDIF or NGC) or DCP files to add to the project.
     **Note:** Enable the **Top** radio button for the file that contains the top-level netlist.
   - **Add Directories:** Invokes a directory browser so you can select directories to search for modules. Files in the specified directory with valid source file extensions are added to the project.
   - **Remove Selected Files and Directories:** The ‘X’ button removes the selected source files and directories from the list.
   - **Move Selected Files and Directories Up:** The up arrow icon moves the file or directory up in the list order.
   - **Move Selected Files and Directories Down:** The down arrow icon moves the file or directory down in the list order.
   - **Copy Sources into Project:** Copies files into the local project directory instead of referencing the original files. If you added directories of source files using Add Directories, the directory structure is maintained when the files are copied locally into the project. For more information, see **Using Remote Sources or Copying Sources into Project in Chapter 3**.
   - **Add Sources from Subdirectories:** Looks for netlist files in the subdirectories of directories specified with Add Directories.
4. Optional: In the Add Constraints page (Figure 2-5), set the following options, and click Next:

- **Add Files**: Invokes a file browser so you can select SDC or XDC files to add to the project.
- **Create File**: Creates a new top-level XDC file for the project.
- **Remove**: Removes the selected file from the constraint list.
- **Up / Down**: Moves a constraint file up or down in the listed order. Commands are order-dependent; the last-read command of a constraint overwrites the effects of an earlier command.
- **Copy Constraints into Project**: Copies constraint files into the local project directory instead of referencing the original files.

**Note**: Any SDC or XDC file found in the same directories as the RTL or netlist source files associated with the project are automatically listed as constraint files to be added to the project.

5. In the Default Part page (Figure 2-6), select a Xilinx part or TDP board, and click Next:

- **Parts**: Lists available devices. Information about the device resources displays in a table view. You can filter the list using the Product Category, Family, Sub-Family, Package, Speed Grade, and Temp Grade filters.
- **Boards**: Lists available TDP boards, and the Xilinx part used on the board. Information about device resources displays in a table view, such as I/O pin count, the number of LUTs and flip-flops, and available block RAM. You can filter the list using the Family, Package, and Speed Grade filters.
- **Search**: Limits the listed devices to those matching the search criteria you specify.

6. In the New Project Summary page, view the selected options that define the project, and click Finish.
Creating an I/O Planning Project

You can use an I/O planning project for device exploration and for planning the device pinout for an in-progress system-level design. You can create this type of project prior to completing the HDL or the synthesized netlist. For example, this allows you to exchange design information with the system-level or PCB designer. For more information about I/O planning, see the *Vivado Design Suite User Guide: I/O and Clock Planning* (UG899) [Ref 10].

1. Follow the steps in Creating a Project.
2. In the Project Type page, select *I/O Planning Project*, and click *Next*.
3. Optional: In the Import Ports dialog box (Figure 2-9), use the following options to select a file for importing I/O Port definitions and constraints, and click *Next*.
   - **Import CSV**: Selects a CSV file with I/O Ports definitions. For more information on CSV files, see the *Vivado Design Suite User Guide: I/O and Clock Planning* (UG899) [Ref 10].
   - **Import XDC**: Selects an XDC with I/O Port-related constraints only.
   - **Do not import I/O ports at this time**: Creates an empty project. You can create or import I/Os later.

   *Note*: Use an RTL project to perform I/O pin planning on a design using RTL header or source files.

![New Project Wizard—Import Ports Page](image_url)
4. In the Default Part page (Figure 2-6), select a Xilinx part or TDP board, and click **Next**:
   - **Parts**: Lists available devices. Information about the device resources displays in a table view. You can filter the list using the Product Category, Family, Sub-Family, Package, Speed Grade, and Temp Grade filters.
   - **Boards**: Lists available TDP boards, and the Xilinx part used on the board. Information about device resources displays in a table view, such as I/O pin count, the number of LUTs and flip-flops, and available block RAM. You can filter the list using the Family, Package, and Speed Grade filters.
   - **Search**: Limits the listed devices to those matching the search criteria you specify.

5. In the New Project Summary page, review the options you selected to define the project, and click **Finish** to create and open the project.

**Importing an External Project**

You can import an existing RTL-level project file created outside of the Vivado IDE (for example, using Synopsys Synplify, XST, or ISE Design Suite Project Navigator). The Vivado IDE detects the source files in the specified project and automatically adds the files to the new project. Settings such as top module, target device, and VHDL library assignment are imported from the existing project.

**Note:** For more information on importing an XST or ISE Design Suite project, see the *Vivado Design Suite Migration Methodology Guide* (UG911) [Ref 9].

1. Follow the steps in **Creating a Project**.
2. In the Project Type page, select **Imported Project**, and click **Next**.
3. In the Import Project page (Figure 2-10), use the following options to specify the project file to import, and click **Next**.
   - **ISE**: Imports the specified Xilinx ISE Design Suite (.xise extension) project file.
   - **Synplify**: Imports the specified Synplify (.prj extension) project file.
   - **XST**: Imports the specified XST (.xst extension) project file.
   - **Copy Sources into Project**: Copies files into the local project directory instead of referencing the original files.
Creating a Project

4. In the New Project Summary page, review the options that define the project, and click Finish.

The Vivado IDE imports the RTL source files and constraint files from the specified project, and creates a project file in the specified directory. The Vivado IDE writes a summary of the import process to the Import Summary Report log file in the new project directory. In this summary file, you can review the steps used in creating the project as well as any errors or warnings.

Tcl Commands for Creating Projects

Following are Tcl commands associated with creating a project. For an example script, see Creating a Project Using a Tcl Script.

Note: For more information on Tcl commands, see the Vivado Design Suite Tcl Command Reference Guide (UG835) [Ref 5], or type <command> -help.

Tcl Commands for Creating a Project

Following are the associated Tcl commands:

- **Tcl Commands**: create_project and set_property
- **Tcl Command Example (RTL Project)**: create_project my_project C:/team/designs/my_project -part xc7k325tffg676-2
- **Tcl Command Examples (Post-Synthesis Project)**:
  
  ```
  create_project my_IO_project C:/team/designs/my_IO_project -part xc7k325tffg676-2
  set_property design_mode GateLvl [current_fileset]
  ```

Figure 2-10: New Project Wizard—Import Project Page

![New Project Wizard—Import Project Page](image)
• **Tcl Command Examples (I/O Planning Project):**

```
create_file project_io C:/projects/project_io -part xc7vx485tffg1157-1
set_property design_mode PinPlanning [current_fileset]
```

**Tcl Commands for Importing a Project**

Following are the associated Tcl commands:

- **Tcl Command**: create_project and import_xise
- **Tcl Command Examples**:

```
create_project project_import_ise C:/projects/project_import_ise
import_xise C:/projects/old/wave_gen_vhd_s6/wave_gen_vhd_s6.xise -copy_sources
```

**Tcl Commands for Adding Design Sources, Constraints Files, and Simulation Sources**

Following are the associated Tcl commands:

- **Tcl Command**: add_files or import_files
- **Tcl Command Examples**:

```
add_files top.v
import_files -fileset constrs_1 C:/projects/sources/timing.xdc
add_files -norecurse source_dir
import_files source_dir
```

*Note*: The `add_files` command references the file from its current location. The `import_files` command copies the file into the project.

**CAUTION!** *The read_xdc, read_vhdl, read_verilog, read_ip, and read_edif Tcl commands are designed for use with Non-Project Mode only. For more information, see Working with Sources in Non-Project Mode in Chapter 3.*
Managing Projects

Tcl Commands for Adding Existing IP Sources

Following are the associated Tcl commands:

- **Tcl Command**: `add_files` or `import_ip`

- **Tcl Command Example**: `import_ip C:/projects/sources/char_fifo/char_fifo.xci`

*Note*: The `add_files` command references the XCI file and associated output products from their current location. The `import_ip` command copies the XCI file and associated output products into the project.

Tcl Commands for Setting the Project Part

Following are the associated Tcl commands:

- **Tcl Command**: `create_project` or `set_property`

- **Tcl Command Examples**:
  
  ```
  create_project my_project C:/projects/my_project -part xc7k325tffg676-2
  
  set_property PART xc7k70tfbg676-2 [current_project]
  ```

*Note*: You can set the part either when you create the project or after you create the project.

Managing Projects

Opening a Project

When a project is opened, the Vivado IDE restores the state of the project from the time the project was closed. The project state includes the current source file order, disabled and enabled source files, active and target constraint files, and the state of synthesis, simulation, and implementation runs.

To open a project, use one of the following methods:

- In the Getting Started page, click **Open Project**.
- Select **File > Open Project**.
- Click the **Open Project** toolbar button.
- In the Tcl Console, enter the `open_project` command.
From the Open Project dialog box, you can select a project file (.xpr extension). The File Preview window in the Open Project dialog box displays information about the currently selected file.

*Note:* Alternatively, you can double-click the Vivado IDE project file (.xpr extension) in Windows Explorer to open the project.

**Tcl Command for Opening a Project**

Following is the associated Tcl command:

- **Tcl Command:** open_project
- **Tcl Command Example:** open_project c:/projects/project1.xpr

**Opening Multiple Projects**

To open multiple projects in a single session, use any of the methods described in Opening a Project to open an additional project while a project is already open. The Vivado IDE prompts you to close the current project. If you do not close the first project, both projects are opened. Each open project has a separate main window.

When opening multiple projects from the same Vivado IDE application process, be aware that the commands used in all open projects are written to the Tcl Console. When reviewing the transcript of commands, it might not be clear which project the commands are associated with. In addition, there is only a single vivado.jou and a single vivado.log file for the application for all projects.

*Note:* System memory requirements can hinder performance when opening multiple projects.

**Saving a Project**

Projects are automatically saved for you. For example, any time you make a change to a project, such as changes to source configuration, properties on files, or run options, the project is automatically saved on disk.

To save a project to a new location, select **File > Save Project As**. This copies the entire project directory structure to a specified location and maintains the status of the existing runs.

**Tcl Command for Saving a Project**

Following is the associated Tcl command:

- **Tcl Command:** save_project_as
- **Tcl Command Example:** save_project_as new_project c:/projects/
Managing Projects

Closing a Project

To close a project, select File > Close Project. When you close a project, you are prompted to save any unsaved changes to the design or source files.

Tcl Command for Closing a Project

Following is the associated Tcl command: close_project

Archiving Projects

You can create a project archive to store as backup or to send to a remote site. When archiving a project, the Vivado IDE does the following:

- Parses the hierarchy of the design.
- Copies the required source files, include files, and remote files from the library directories.
- Copies the constraints.
- Optionally, copies the results of the various synthesis, simulation, and implementation runs.
- Creates a ZIP file of the project.

To archive a project:

1. Select File > Archive Project.
2. In the Archive Project dialog box (Figure 2-11), set the following options, and click OK.
   - **Archive name**: Specifies the name of the project archive.
   - **Archive location**: Specifies a location to store the project archive file.
   - **Include configuration settings**: Includes the init.tcl file, which contains Tcl initialization commands that are helpful in debugging your design. For more information, see the Vivado Design Suite Tcl Command Reference Guide (UG835) [Ref 5].
   - **Include run results**: Includes the settings and results of the runs performed on the project.
Managing Projects

The Vivado IDE creates a project archive in ZIP file format that contains the required source files, include files, and run files (if specified) as well as an archive.log file of the archival process. You can review the creation of the archive in the archive.log file.

**Tcl Command for Archiving a Project**

Following is the associated Tcl command:

- **Tcl Command**: `archive_project`
- **Tcl Command Example**: `archive_project -exclude_run_results proj3.zip`

**Working with Source Control Systems**

You can use the **File > Write Project Tcl** command to generate a Tcl script that recreates the current project. The generated script includes Tcl commands that:

- Create the project
- Set the project type
- Create filesets
- Add or import source files
- Define runs and run properties

You can store this Tcl script and the various design sources in a source control system for source file management and project archival.

**Note:** For information on working with IP and source control systems, see the *Vivado Design Suite User Guide: Designing with IP* (UG896) [Ref 11].
Using the Project Summary

The Vivado IDE includes an interactive Project Summary (Figure 2-12) that updates dynamically as design commands are run and as the design progresses through the design flow. It provides project and design information, such as the project part, project status, and state of synthesis and implementation. It also provides links to detailed information, such as links to the Messages, Log, and Reports windows as well as the Project Settings dialog box. You can use the scroll bar or the Collapse and Expand buttons to view or hide the different data categories.

The Project Summary contains the following sections:

- **Project Settings**: Shows the project name, product family, project part, and top module name.
- **Board**: Shows the product name, the board name that includes the part family, board, and version number, the board file that contains detailed information about the board, a link to the product page on the Xilinx website, and overview information about the board.
- **Synthesis and Implementation**: Summarizes the state of synthesis and implementation in the active run. These sections show the target part, the strategy applied in the run, the tool flow used, and the constraint set used. Click the Part, Strategy, or Flow links to open the Project Settings dialog box for either synthesis or implementation. Click the Constraints link to open the Constraint Set Properties in the Source File Properties window.
  
  *Note*: For more information, see Configuring Project Settings and Working with Constraints in Chapter 3.
- **DRC Violations**: After implementation, summarizes information on design rule checks (DRCs).
- **Timing**: After implementation, summarizes timing results.
- **Utilization**: After synthesis, summarizes utilization results for the project in both table and graph form.
- **Power**: After implementation, summarizes power analysis results.
To open the Project Summary, do either of the following:

- Select **Windows > Project Summary**.
- Select the **Project Summary** toolbar button \(\sum\).

![Project Summary](image_url)

*Figure 2-12: Project Summary*
Configuring Project Settings

You can configure project settings to meet specific needs for each project. Project settings include general settings related to the top module definition as well as settings for the following: simulation, synthesis, implementation, bitstream, and IP.

To open the Project Settings dialog box, use any of the following methods:

- Select **Tools > Project Settings**.
- Click the **Project Settings** toolbar button.
- In the Flow Navigator, click **Project Settings** in the Project Manager section, or click one of the following: **Simulation Settings**, **Synthesis Settings**, **Implementation Settings**, or **Bitstream Settings**.
- In the Project Summary, click the **Edit** link next to the Project Settings header, or click the strategy or flow in either the Synthesis or Implementation section.

Depending on how you invoke the Project Settings dialog box, the appropriate category appears by default. For example, if you click **Simulation Settings** in the Flow Navigator, the Simulation category appears in the Project Settings dialog box. The following sections provide detailed information for each category.

General Settings

The General Settings (Figure 2-13) enable you to specify the project name, part, target language, target simulator, top module name, and language options.

- **Name**: Specifies the project name.
- **Project Device**: Specifies the target device to be used as a default for both synthesis and implementation. Click the browse button to open the Select Device dialog box to choose a device.
  
  **Note**: If you have multiple synthesis or implementation runs, you can also change the device used for a specific run by changing the run settings from the Run Properties window. For information, see Using the Runs Properties Window in the *Vivado Design Suite User Guide: Using the Vivado IDE* (UG893) [Ref 7].

- **Target Language**: Specifies the target output language for the design as either Verilog or VHDL. The tool generates RTL output from the design in the specified target language. Specific examples of output controlled by the target language are synthesis, simulation, top-level wrappers, test benches, and IP instantiation templates.

- **Top Module Name**: Specifies the top RTL module name of the design. You can also enter a lower-level module name to experiment with synthesis on a specific module. Click the browse button to automatically search for the top module and display a list of possible top modules.
• **Language Options**
  - **Verilog Options**: Click the browse button to set the following options in the Verilog Options dialog box:
    - **Verilog Include Files Search Paths**: Specifies the paths to search for files referenced by `include` statements in the source Verilog files.
    - **Defines**: Specifies Verilog macro definitions for the project.
    - **Uppercase all identifiers**: Sets all Verilog identifiers to uppercase.
  - **Generics/Parameters**: VHDL supports generics while Verilog supports defining parameters for constant values. Both of these techniques allow parameterized designs that can be reused in different situations. Click the browse button to define generic and parameter values to override defaults defined in the source files.
  - **Top Library**: Specifies the top-level module library name.
  - **Loop Count**: Specifies the maximum loop iteration value. The default is 1000.

  **Note**: The Loop Count option is used during RTL elaboration but does not apply to synthesis. For synthesis, you must specify the `-loop_iteration_limit` switch in the More Options field of the Synthesis Settings dialog box.

  ![General Settings](image)

  **Figure 2-13: General Settings**
Simulation Settings

The Simulation Settings (Figure 2-14) enable you to specify the simulation set, the simulation top module name, and a tabbed listing of compilation and simulation options. You can select an option to see a description at the bottom of the dialog box. For more information on the Simulation Settings, see the Vivado Design Suite User Guide: Logic Simulation (UG900) [Ref 13].

Figure 2-14: Simulation Settings
Synthesis Settings

The Synthesis Settings (Figure 2-15) enable you to specify the constraints set, the synthesis strategy, and the synthesis options. The options are defined by the selected synthesis strategy, but you can override these with your own settings. You can select an option to see a description at the bottom of the dialog box. For more information on the Synthesis Settings, see the *Vivado Design Suite User Guide: Synthesis* (UG901) [Ref 14].

**Note:** You can pre-synthesize IP in your project, which decreases the synthesis runtime. For information on using this bottom-up synthesis flow, see the *Vivado Design Suite User Guide: Designing with IP* (UG896) [Ref 11].

**TIP:** You can add Tcl scripts to be sourced before and after synthesis using the `tcl.pre` and `tcl.post` files. For more information, see the *Vivado Design Suite User Guide: Using Tcl Scripting* (UG894) [Ref 4].
Implementation Settings

The Implementation Settings (Figure 2-16) enable you to specify the constraints set, the implementation strategy, and the implementation options. The options are defined by the selected implementation strategy, but you can override these with your own settings. For example, you can use the options to run optional steps such as power optimization and physical synthesis. You can select an option to see a description at the bottom of the dialog box. For more information on the Implementation Settings, see the Vivado Design Suite User Guide: Implementation (UG904) [Ref 15].

TIP: You can add Tcl scripts to be sourced before and after any stage of implementation using the tcl.pre and tcl.post files available at each stage. For more information, see the Vivado Design Suite User Guide: Using Tcl Scripting (UG894) [Ref 4].
Bitstream Settings

The Bitstream Settings (Figure 2-17) enable you to define options prior to generating the bitstream. You can select an option to see a description at the bottom of the dialog box. For more information on the Bitstream Settings, see the *Vivado Design Suite User Guide: Programming and Debugging* (UG908) [Ref 16].

![Figure 2-17: Bitstream Settings](image-url)
IP Settings

The IP Settings (Figure 2-18) include the following tabs:

- **Repository Manager**: Specifies directories to add to the IP repositories list. IP can either be packaged by the user or acquired from a third party supplier. After you click Apply, you can see the IP within each repository.

- **Packager**: Sets default values for packaging new IP, including vendor, library, and taxonomy. This tab also allows you to set the default behavior when opening the IP Packager and allows you to specify file extensions to be filtered automatically.

  **Note**: If necessary, you can change the default values for packaging IP during the IP packaging process.

For more information on the IP Settings, see the *Vivado Design Suite User Guide: Designing with IP* (UG896) [Ref 11].

**Note**: The IP Settings and the Vivado IP catalog are only available when working with an RTL project or when using Manage IP from the Getting Started page. When using Manage IP, a subset of the IP settings is available unless a project is created.

![Figure 2-18: IP Settings](image-url)
**Tcl Command for Configuring Project Settings**

Following is the associated Tcl command for configuring different properties for the project. The example shows how to configure the target language property for the project:

- **Tcl Command**: `set_property`
- **Tcl Command Example**: `set_property target_language Verilog [current_project]`

RECOMMENDED: You can set multiple properties, including properties for the project or for synthesis or implementation runs. The best way to learn the property name and target is by performing the operation in the Vivado IDE and looking at the corresponding Tcl commands in the Tcl Console.

---

**Creating a Project Using a Tcl Script**

As an alternative to creating a project in the Vivado IDE, you can create a project using a Tcl script. Most actions run in the Vivado IDE result in a Tcl command being executed. The Tcl commands appear in the Vivado IDE Tcl Console and are also captured in the `vivado.jou` and `vivado.log` files. The `vivado.jou` file contains just the commands, and the `vivado.log` file contains both commands and any returned messages. You can use these files to develop scripts for use with Project Mode. For more information on Tcl commands, see the Vivado Design Suite Tcl Command Reference Guide (UG835) [Ref 5].

Following is a sample script that creates a project, adds various sources, configures settings, launches synthesis and implementation runs, and creates a bitstream.

```tcl
# Typical usage: vivado -mode tcl -source run_bft_project.tcl
# Create the project and directory structure
create_project -force project_bft_batch ./project_bft_batch -part xc7k70tfbg484-2
# Add various sources to the project
add_files {./Sources/hdl/FifoBuffer.v ./Sources/hdl/async_fifo.v 
./Sources/hdl/bft.vhdl}
add_files -fileset sim_1 ./Sources/hdl/bft_tb.v
add_files ./Sources/hdl/bftLib/
add_files -fileset constrs_1 ./Sources/bft_full.xdc
# Now import/copy the files into the project
import_files -force
# Set VHDL library property on some files
set_property library bftLib [get_files {*round_*.vhdl core_transform.vhdl 
bft_package.vhdl}]
# Update to set top and file compile order
update_compile_order -fileset sources_1
update_compile_order -fileset sim_1
```
# Launch Synthesis
launch_runs synth_1
wait_on_run synth_1
open_run synth_1 -name netlist_1
#
# Generate a timing and power reports and write to disk
# Can create custom reports as required
report_timing_summary -delay_type max -report_unconstrained -check_timing_verbose \
-max_paths 10 -input_pins -file syn_timing.rpt
report_power -file syn_power.rpt
#
# Launch Implementation
launch_runs impl_1 -to_step write_bitstream
wait_on_run impl_1
#
# Generate a timing and power reports and write to disk
# comment out the open_run for batch mode
open_run impl_1
report_timing_summary -delay_type min_max -report_unconstrained \
-check_timing_verbose -max_paths 10 -input_pins -file imp_timing.rpt
report_power -file imp_power.rpt
#
# Can open the graphical environment if visualization desired
# comment out the for batch mode
#start_gui

**TIP:** You can break up a line in your Tcl script using the backslash (\) character. The line that follows the backslash is processed as part of the preceding line.
Chapter 3

Working with Source Files

Overview

Source files include project sources, design sources, constraints sources, simulation sources, intellectual property (IP) sources, digital signal processing (DSP) sources, embedded sources, and IP subsystems. When working in Project Mode, you can create these source files using the Vivado® IDE or using Tcl commands or scripts, and the Vivado IDE automatically manages your source files. In Non-Project Mode, you can create these source files using Tcl commands or scripts, but you must manually manage your source files. This chapter covers creating and managing sources in Project Mode and creating sources in Non-Project Mode.

Working with Sources in Project Mode

Using the Vivado IDE, you can create and manage source files that are local to the current project or remotely referenced from a library. You can add Verilog and VHDL source files to a project at any point in the design flow. You can also create or add constraint files, simulation sources, DSP sources, and embedded sources to your design as well as add existing IP.

Note: For information on Tcl commands associated with adding sources, see Tcl Commands for Adding Design Sources, Constraints Files, and Simulation Sources in Chapter 2. For more information on Tcl commands, see the Vivado Design Suite Tcl Command Reference Guide (UG835) [Ref 5], or type <command> -help.

Working with Design Sources

In the Vivado IDE, you can create and manage design source files, including HDL or netlist files.

Tip: For information on the icons used in the Sources window, see the Vivado Design Suite User Guide: Using the Vivado IDE (UG893) [Ref 7] and Vivado Design Suite User Guide: Designing with IP (UG896) [Ref 11].
Creating Design Sources

1. Select **File > Add Sources**.

   *Note: Alternatively, you can click **Add Sources** in the Flow Navigator, or select **Add Sources** from the popup menu in the Sources window.*

2. In the Add Sources wizard (**Figure 3-1**), select **Add or Create Design Sources**, and click **Next**.

![Add Sources Wizard](image)

**Figure 3-1:** Add Sources Wizard

3. In the Add or Create Design Sources page (**Figure 3-2**), click **Create File**.
4. In the Create Source File dialog box (Figure 3-3), set the following options, and click OK:
   - **File type**: Specifies one of the following file formats: Verilog file (.v extension), Verilog Header file (.vh extension), SystemVerilog file (.sv extension), VHDL file (.vhd extension).
   - **File name**: Specifies a name for the new HDL source file.
   - **File location**: Specifies a location in which to create the file.

   Note: A placeholder for the file is added to the list of sources. The file is created when you click Finish.

5. You can click Create File multiple times to define a number of new modules to add to the project.
6. In the Add Sources dialog box, specify the appropriate Library for the source file.

   **Note**: By default, HDL sources are added to the *work* library. You can create or reference additional user VHDL libraries as needed.

7. Click **Finish** to add the specified sources to the project.

8. **Optional**: In the Define Modules dialog box (Figure 3-4), define the module or architecture in the Verilog, Verilog Header, SystemVerilog, or VHDL code using the following options, and click **OK**:

   - **New Source Files**: If you created multiple files, click the name of the module you want to define.
      
      **Note**: This field is only present if you created multiple files.

   - **Entity name/Module name**: Specifies the name for the entity construct in the VHDL code or the module name in the Verilog or SystemVerilog code.
      
      **Note**: Although the entity or module name defaults to the file name, it does not have to match file name.

   - **Architecture name**: Specifies the Architecture for the RTL source file. By default, the name is Behavioral.
      
      **Note**: This option only applies to VHDL code and does not appear when defining Verilog or SystemVerilog modules.

   - **I/O Port Definitions**: Define the ports to be added to the module definition:
      
      - **Port Name**: Defines the name of the port to appear in the RTL code.

      - **Direction**: Specifies whether the port is an Input, Output, or Bidirectional port.

      - **Bus**: Specifies whether the port is a bus port. Define the width of the bus using the MSB and LSB options.

      - **MSB**: Defines the number of the most significant bit (MSB). This combines with the LSB field to determine the width of the bus being defined.

      - **LSB**: Defines the number of the least significant bit (LSB).

      **Note**: MSB and LSB are ignored if the port is not a bus port.
The RTL source files are created and added to your project. The Sources window lists the newly defined modules. To edit the new source files in the Vivado IDE Text Editor, double-click the file or select **Open File** from the popup menu. For information on editing the newly created file, see **Using the Text Editor in Chapter 3**.

### Adding Design Sources

1. Select **File > Add Sources**.

   **Note:** Alternatively, you can click **Add Sources** in the Flow Navigator, or select **Add Sources** from the popup menu in the Sources window.

2. In the Add Sources wizard (**Figure 3-1**), select **Add or Create Design Sources**, and click **Next**.

3. In the Add or Create Design Sources page (**Figure 3-2**), set the following options, and click **Finish**.

   - **Add Files**: Opens a file browser so you can select files to add to the project. You can add the following file types to an RTL project: HDL, EDIF, NGC, BMM, ELF, DCP, and other file types.

     **Note:** In the Add Source Files dialog box, each file or directory is represented by an icon indicating it as a file or folder. A small red square indicates it is read only.

   - **Add Directories**: Opens a directory browser to add source files from the selected directories. Files in the specified directory with valid source file extensions are added to the project.

   - **Create File**: Opens the Create Source File dialog box in which you can create new VHDL, Verilog, Verilog header, or SystemVerilog files.

---

**Figure 3-4: Define Module Dialog Box**

The RTL source files are created and added to your project. The Sources window lists the newly defined modules. To edit the new source files in the Vivado IDE Text Editor, double-click the file or select **Open File** from the popup menu. For information on editing the newly created file, see **Using the Text Editor in Chapter 3**.
- **Library**: Specifies the RTL library for a file or directory by selecting one from the currently defined library names, or specify a new library name by typing in the Library text field.

  **Note**: This option applies to VHDL files only. By default, HDL sources are added to the work library. You can create or reference additional user VHDL libraries as needed. For Verilog and SystemVerilog files, leave the library set to work.

- **Delete**: Removes the selected source files from the list of files to be added.

- **Move Selected File Up**: Moves the file or directory up in the list order. The order of the files affects the order of elaboration and compilation during downstream processes such as synthesis and simulation.

- **Move Selected File Down**: Moves the file or directory down in the list order.

- **Scan and Add RTL Include Files into Project**: Scans the added RTL files and adds any referenced Verilog `include files into the local project directory structure.

- **Copy Sources into Project**: Copies files into the local project directory instead of referencing the original files.

  **Note**: If you added directories of source files using Add Directories, the directory structure is maintained when the files are copied locally into the project. For more information, see Using Remote Sources or Copying Sources into Project.

- **Add Sources from Subdirectories**: Adds source files from the subdirectories of directories specified using the Add Directories option.

### Specifying the Top Module and Reordering Source Files

The Vivado IDE automatically determines the top-level of the design hierarchy and the order of elaboration, synthesis, and simulation for source files added to the project. The hierarchy of the design is displayed in the Hierarchy view of the Source window. The file order is displayed in the Compile Order view of the Sources window.

You can override the automatic determination of the top module by manually specifying the top of the design hierarchy. To specify the top module, select **Set as Top** from the popup menu command in the Hierarchy view of the Sources window.

**Note**: If the specified top module cannot be found in the design source files and the hierarchy update mode is set to automatic, the selected top is automatically reset to the best candidate.

When you change the top module, the Vivado IDE automatically reorders files according to the requirements of the new top module. Select **Refresh Hierarchy** from the popup menu in the Sources window to automatically reorder files based on updates to the source files.

You can override the automatic determination of the compile order using **Hierarchy Update** from the popup menu command in the Sources window. When in manual mode, you can manually order files according to your own requirements. To manually order source files, select a file and drag it up or down in the file list order in the Compile Order view of
Sources window. Alternatively, after selecting the file, execute Move Up, Move Down, Move to Top, or Move to Bottom from the Sources window popup menu.

To see a full list of the compile or evaluation order for all sources, use the reportCompileOrder command in the Tcl Console. This command lists the order that files are compiled or evaluated for synthesis, implementation, and simulation. RTL compile order is listed for synthesis and simulation. Constraints evaluation order is listed for synthesis and implementation.

**Note:** For more information on the Sources window, see the Vivado Design Suite User Guide: Using the Vivado IDE (UG893) [Ref 7].

### Enabling or Disabling Source Files

When you add or create source files, the source files are enabled in the Sources window by default. You can disable source files to prevent them from being elaborated, synthesized, or used in simulation.

- To disable source files, select the files in the Sources window, and select the Disable File popup command.
- To enable disabled files, select the files in the Sources window, and select the Enable File popup command.

### Using Remote Sources or Copying Sources into Project

To provide project management flexibility, you can reference source files from a remote location or copy the source files into the project directory. When you add remote files, the Vivado IDE automatically detects the latest file version, then prompts you to Refresh your open designs or to Synthesize with the latest updates made to the file. If you plan to move or archive the project, you can copy the files into the project so that the files are contained within the project.

**Note:** When you copy files into a project, the project is easier to port to another system. However, the Vivado IDE does not automatically recognize changes to the original files. To update copied files when the original remote files change, you must remove and re-add the files, or you must replace the files using the Replace File popup menu command in the Sources window.
To copy sources into the project, do one of the following:

- When you add sources to the project using the Add Sources command, you can copy the sources to the local project directory by selecting the **Copy Sources into Project** option.
- If you initially add the sources as remote sources, but later wish to copy them into the project directory, use **Copy File into Project** or **Copy All Files into Project** in the popup menu in the Sources window to copy some or all individual remote source files into the project directory.

The Sources window uses the following icons to indicate whether sources are local or remote:

- **Local source**: Files that were copied into the local project directory.
- **Remote source**: Files that were not copied into the local project directory.
- **Missing source**: File that could not be located, either local or remote.
- **Read-only source**: Read-only file in the Vivado IDE.

Note: The file might be read/write on disk, but it is not read/write in the Vivado IDE.

**Updating Local Source Files**

When referencing remote sources, the Vivado IDE automatically detects the updated source file changes. However, with source files that are copied to the local project, any changes to the original source file are not recognized. You must manually update local source files, if necessary.
You can update source files that are copied into the local project directory using either of the following methods:

- In the Sources window, select the file, and select Replace File from the popup menu.

  A file browser opens with the original source file referenced. If the original location changed, you are required to browse to the location and select the file. Click OK to reload the original source file, and update the project file with any changes to the source file.

  **Note:** You can also specify a different file, and the Vivado IDE replaces the selected file with the new file. For instance, if the original file is File_1.v, and you select File_2.v, the original File_1.v is removed from the project and File_2.v is copied into the project.

- In the Sources window, select Add Sources from the popup menu to add the newly updated source files to the project.

  The Vivado IDE imports the added file into the project. However, because there is already a local source with the same name, the Import Source Conflicts dialog box (Figure 3-5) prompts you to resolve the conflict by overwriting the existing file or by not loading the newly added file. This happens only if the Copy Sources into Project box is checked in the Add Sources wizard; otherwise, the externally referenced file of the same name is added to the project.

![Figure 3-5: Import Source Conflicts Dialog Box](image-url)
Working with Constraints

The Vivado IDE supports the Xilinx® design constraint (XDC) and Synopsys design constraint (SDC) file formats. The SDC format is for timing constraints while the XDC format is for both timing and physical constraints. Constraints can include placement, timing, and I/O restrictions. You can create constraints during various steps in the design flow, including RTL analysis, synthesis, and implementation.

The Vivado IDE provides flexibility in defining and using constraints in a project. You can use a single XDC file to add and maintain the design constraints, or you can use multiple XDC files to organize the constraints into separate files. You can create multiple constraint sets to experiment with various types of constraints, or store multiple versions of constraints. Each constraint set can contain one or more constraint files.

You can open multiple designs referencing a single constraint set. However, you must be careful to manage changes made to multiple designs that reference the same constraint set. If the Vivado IDE detects unsaved changes in multiple designs, it prompts you to select which design to save to the referenced constraint file.

**CAUTION!** When saving constraints files, be careful not to overwrite any unsaved constraint definitions in an unsaved design.

An implemented design saves a snapshot of the constraint set used during the implementation run. In some cases, this constraint set might have the same name as the active constraint set in the open project. When opening an implemented design, the constraint set loaded from the implementation run might be older than the constraint set currently in the project memory. This can cause the loss of newly-defined constraints when you save the design. Generally, the Vivado IDE manages these revision issues and prompts you to take the appropriate action as needed. However, please be aware of the potential conflict between the current constraint set in memory and any existing constraints associated with an implemented design.

In the Vivado IDE, the following windows enable you to create and work with constraints:

- **Timing Constraints Window**: Shows all XDC file timing constraints for the project in a table format. You can interactively edit existing constraints, which are saved back to the source file, or create new constraints.
- **Device Constraints Window**: Enables you to set various SelectIO™ interface constraints on displayed banks.
- **Physical Constraints Window**: Enables you to create and manage Pblocks.

*Note*: For more information, see the *Vivado Design Suite User Guide: Using Constraints* (UG903) [Ref 8].
Adding and Creating Constraint Files

1. Select File > Add Sources.

   Note: Alternatively, you can click Add Sources in the Flow Navigator, or select Add Sources from the popup menu in the Sources window.

2. In the Add Sources wizard (Figure 3-1), select Add or Create Constraints, and click Next.

3. In the Add or Create Constraints page (Figure 3-6), set the following options, and click Finish.

   - **Specify Constraint Set**: Defines the constraint set into which the constraint files are placed. By default, the currently active constraint set is selected, but you can specify a different constraint set or define a new constraint set using the drop-down menu.
   
   - **Add Files**: Specifies the XDC, SDC, or Tcl files to add to the project.
     
     Note: For more information on working with Tcl scripts, see the Vivado Design Suite User Guide: Using Constraints (UG903) [Ref 8].
   
   - **Create File**: Creates a new top-level XDC for the project.
   
   - **Remove**: Removes the selected file from the Constraint File list.
   
   - **Up / Down**: Moves a constraint file up or down in the listed order of XDC, SDC, or Tcl files. XDC, SDC, or Tcl files consist of commands that set timing and physical constraints and are order-dependent. If there are multiple files in a constraint set, the order in which they appear in the Sources window corresponds to the order that the Vivado IDE processes the files. The first file in the list is the first file processed. If the same constraint appears in more than one constraint file, the last file read has precedence in defining the constraint.
   
   - **Copy Constraints into Project**: Copies constraint files into the local project directory instead of referencing the original files.
Setting the Target XDC File

The Vivado IDE writes newly created constraints to the XDC file identified as the target XDC file when you save the constraints. By default, in a new constraint set, there is no target XDC file. When you create new constraints, you must set a target XDC file when you save the constraints. To indicate that constraints need to be saved, the *Save Constraints* toolbar button is enabled.

When you click the *Save Constraints* toolbar button, the Save Constraints File dialog box (*Figure 3-7*) appears in which you can choose either an existing XDC file in the active constraint set, or create a new file and add it to the active constraint set.

*Figure 3-7:  Save Constraints File Dialog Box*

If an XDC file is set as a target, the word “(target)” appears next to the file name in the Sources window (*Figure 3-8*). You can change the target XDC file at any time using the *Set as Target Constraint File* popup menu command in the Sources window.
**Working with Sources in Project Mode**

**Referencing Original XDC Files or Copying Files**

As with other source files, you can reference XDC files from a remote location or copy the files locally into the project directory. When you add remote files, the Vivado IDE automatically detects the latest file version and prompts you to **Reload the design** with the latest files.

To copy constraints into the project, do one of the following:

- When you add constraints to the project using the Add Sources command, you can copy the constraints to the local project directory by selecting the **Copy Constraints into Project** option.
- If you initially add the constraints as remote sources but later wish to copy them into the project directory, use **Copy File into Project** or **Copy All Files into Project** in the popup menu in the Sources window to copy some or all individual remote source files into the project directory.

**Note:** For more information, see Using Remote Sources or Copying Sources into Project.

**Using Constraint Sets**

A constraint set is one or more constraint files that are maintained independently and concatenated into a single XDC file for analysis and implementation. A constraint set defines the constraint files to be used at specific moments, or under specific conditions, in the design process. By defining multiple constraint sets, you can, for example, specify different active constraints to resolve floorplanning and timing problems.

The XDC files can be used during synthesis, implementation, or both. By default all XDC files are set to be used in both synthesis and implementation. To change the **Used In** setting for an XDC file, select the file in the Sources window, and check or uncheck the appropriate box in the General view of the Source File Properties window (Figure 3-9).
Creating and Editing Constraint Sets

1. In the Sources window, select **Edit Constraint Sets** from the popup menu.

2. In the Edit Constraint Set dialog box, do one of the following:
   - To edit a constraint set, click the drop-down menu next to the Specify Constraint Set field, and select a constraint set.
   - To create a constraint set, click the drop-down menu next to the Specify Constraint Set field, and select **Create Constraint Set**. In the Create Constraint Set Name dialog box (Figure 3-10), enter a name for the constraint set, and click **OK**.

---

**Figure 3-9:** Used In Property for an XDC File

**Figure 3-10:** Create Constraint Set Name Dialog Box
3. In the Edit Constraint Set dialog box, set the following options, and click **OK**:

- **Add Files**: Specifies XDC or SDC files to add to the constraint set.
- **Create File**: Specifies a name and location for a new XDC file to add to the constraint set.
- **Remove**: Removes the selected file from the Constraint File list.
  
  **Note**: You can only remove files that have not yet been added to the constraint set using the **OK** button. To remove a file that was already added to the constraint set, select the file in the Sources window, and select **Remove File from Project** from the popup menu.

- **Up / Down**: Moves a constraint file up or down in the listed order of XDC and SDC files. XDC and SDC files consist of commands that set timing and physical constraints and are order-dependent. If there are multiple files in a constraint set, the order in which they appear in the Sources window corresponds to the order that the Vivado IDE processes the files. The first file in the list is the first file processed. If the same constraint appears in more than one constraint file, the last file read has precedence in defining the constraint.

- **Copy Constraints into Project**: Copies constraint files into the local project directory instead of referencing the original files.

### Creating Constraints Sets Using the Save Constraints As Command

You can also create a new constraint set by saving changes and additions made to constraints during the design and analysis process. With multiple places to make constraint changes, it is convenient to save changes to a constraint set to manage changes or support “what-if” analysis. Select **File > Save Constraints As** to open the Save Constraints As dialog box (Figure 3-11), and enter a new constraint set name in which to save all constraints.

![Save Constraints As Dialog Box](image)
The Save Constraints As dialog box does the following:

- Creates a new constraint set.
- Copies the active constraint files into the new constraint set in the local project directory.
- Writes any modifications to the constraints to the copied constraint files, leaving the original XDC files unchanged.
- Provides an option to make the new constraint set active in the project.

**Defining the Active Constraint Set**

If more than one constraint set exists, you must designate an active constraint set. The Vivado IDE uses the active constraint set by default when you launch the synthesis or implementation runs or when you open an elaborated, synthesized or implemented design.

To set the active constraint set, select the constraint set in the Sources window, and click **Make active** from the popup menu. In the Sources window, the active constraint set appears in bold with the word “(active)” next to it (Figure 3-12).

**Exporting Constraints**

In some cases, you might want to use the Vivado IDE to create constraint files for use in scripting command line design flows. To export constraints for a command line flow, select **File > Export > Export Constraints**.

In addition, you can export the I/O standard constraints for I/O ports and banks (both user-specified values and default values assigned by the Vivado IDE) to an XDC file. To export constraints, select **File > Export > Export I/O Ports**, and generate an XDC file.
Enabling or Disabling Constraint Files

When you add or create constraint files, the files are enabled in the Sources window by default. You can disable constraint files to prevent them from being used during elaboration, synthesis, or in implementation.

- To disable constraint files, select the files in the Sources window, and select the **Disable File** popup command.
- To enable disabled files, select the files in the Sources window, and select the **Enable File** popup command.

Changing the Constraint Evaluation Order

You can reorder user constraints within the associated constraint set. In the Sources window, drag and drop the XDC files to rearrange the order.

To get an ordered list of all XDC files that the Vivado IDE processes, use the following command in the Tcl Console: `report_compile_order -constraints`. This lists all the constraints in the design, including user constraints and IP.

*Note:* For more information on how to change the order of constraints, see the *Vivado Design Suite User Guide: Using Constraints* (UG903) [Ref 8].

Converting UCF Constraints

The Vivado IDE supports only XDC and SDC files. It does not support user constraints files (UCF). You can convert UCF constraints to XDC using either of the following methods:

- Open the design in the PlanAhead™ tool. In the Tcl Console, type `write_xdc <filename>.xdc`.

  *Note:* The `write_xdc` command is not a file converter. The command writes out the constraints that were successfully applied to the design as an XDC file. This conversion is only a starting point for migration to XDC-based constraints.

  **RECOMMENDED:** This method is recommended for converting physical constraints only. It is not recommended for converting timing constraints, especially timing exceptions.

- Manually convert the UCF constraints to XDC.

  **RECOMMENDED:** This method is strongly recommended for converting UCF constraints, especially timing constraints and timing exceptions. Fundamental differences between the UCF and XDC constraints make automatic conversion less than optimal. For example, UCF files target nets for the constraints while XDC files typically target a cell, port, or pin.

  *Note:* For more information, see the *Vivado Design Suite Migration Methodology Guide* (UG911) [Ref 9] or the *Vivado Design Suite User Guide: Using Constraints* (UG903) [Ref 8].
## Working with Sources in Project Mode

### Working with Simulation Sources

In the Vivado IDE, you can add simulation sources to the project for behavioral simulation of an RTL Project. Simulation source files include hardware description language (HDL)-based test bench files to use as a stimulus for simulation. Simulation sources are used for behavioral simulation in the Vivado simulator.

The Vivado IDE stores simulation source files in simulation sets that display in folders in the Sources window, and are remotely referenced or stored in the local project directory. Simulation sets enables you to define different sources for different simulation configurations. For example, one simulation source can provide stimulus for behavioral simulation using one test bench while another can contain a different test bench. When adding simulation sources to the project, you can specify which simulation set into which to add files.

**Note:** For more information, see the Vivado Design Suite User Guide: Logic Simulation (UG900) [Ref 13].

### Adding and Creating Simulation Source Files

1. Select **File > Add Sources**.

   **Note:** Alternatively, select **Add Sources** from the popup menu or from the Flow Navigator.

2. In the Add Sources wizard (Figure 3-1), select **Add or Create Simulation Sources**, and click **Next**.

3. In the Add or Create Simulation Sources page (Figure 3-13), set the following options, and click **Finish**.

   - **Specify Simulation Set**: Enters the name of the simulation set to put test bench files and directories. Select the **Create Simulation Set** option from the drop-down menu to define a new simulation set.
   - **Add Files**: Opens a file browser so you can select simulation source files to add to the project.
   - **Add Directories**: Opens a directory browser to add all simulation source files from the selected directories. Files in the specified directory with valid source file extensions are added to the project.
   - **Library**: Specifies the library for an added file or directory by selecting one from the currently defined library names, or specify a new library name by typing in the Library text field.

     **Note:** This option applies to VHDL files only. By default, HDL sources are added to the work library. You can create or reference additional user VHDL libraries as needed. For Verilog and SystemVerilog files, leave the library set to work.
   - **Create File**: Opens the Create Source File dialog box in which you can create new simulation source files.
- **Remove**: Removes the selected source files from the list of files to be added.
- **Move Selected File Up**: Moves the file up in the list order.
- **Move Selected File Down**: Moves the file down in the list order.
- **Scan and Add RTL Include Files into Project**: Scans the added RTL files and adds any referenced include files.
- **Copy Sources into Project**: Copies the original source files into the project and uses the local copied version of the file in the project.

  **Note**: If you selected to add directories of source files using the Add Directories command, the directory structure is maintained when the files are copied locally into the project. For more information, see Using Remote Sources or Copying Sources into Project.

- **Add Sources from Subdirectories**: Adds source files from the subdirectories of directories specified in the Add Directories option.
- **Include all design sources for simulation**: Copy all design source files from the sources_1 fileset into the simulation fileset.

![Add Sources Wizard — Add or Create Simulation Sources Page](image)

*Figure 3-13: Add Sources Wizard—Add or Create Simulation Sources Page*
Working with IP Sources

In the Vivado IDE, you can add and manage the following types of IP cores in an RTL project:

- Vivado Design Suite Xilinx Core Instance files (XCI)
- User IP packaged with Vivado IP packager (XCI)
- CORE Generator™ cores (XCO)

To maintain the existing state of the IP core when adding XCO files, a corresponding NGC file must be present in the directory to run implementation successfully. Otherwise, if an upgrade for the IP is available, you can right-click the IP core, and select Upgrade IP from the popup menu.

- Third-party IP

In some cases, third-party providers offer IP as synthesized NGC or EDIF netlists. You can load these files into a design using the Add Sources command. For information, see Working with Design Sources.

- IP design checkpoint (DCP) files

By default, synthesized checkpoint files are generated automatically for IP that supports an out-of-context flow. During customization, you can disable DCP file generation by deselecting the Generate Synthesized Checkpoint (.dcp) option in the Generate Output Products dialog box and clicking Generate. For more information on the options to use for synthesizing IP, see the Vivado Design Suite User Guide: Synthesis (UG901) [Ref 14] and Vivado Design Suite User Guide: Designing with IP (UG896) [Ref 11].

Note: For more information on IP, including adding, packaging, simulating, and upgrading IP, see the Vivado Design Suite User Guide: Designing with IP (UG896) [Ref 11].

Adding Existing IP

1. Select File > Add Sources.
   
   Note: Alternatively, select Add Sources from the popup menu, or from the Flow Navigator.

2. In the Add Sources wizard (Figure 3-1), select Add Existing IP, and click Next.
3. In the Add Existing IP page (*Figure 3-14*), set the following options, and click **Finish**.

- **Add Files**: Opens a file browser in which you can select XCI files, which are native to the Vivado Design Suite, or XCO files.
- **Add Directories**: Opens a directory browser in which you can select XCI or XCO files from the specified directory or subdirectory.
- **Remove**: Removes the selected source files from the list of files to be added.
- **Copy Sources into Project**: Copies the original IP core files into the project and uses the local copied version of the file in the project.

![Figure 3-14: Add Sources Wizard—Add Existing IP Page](image)

The added IP cores display separately in the IP Sources view of the Sources window, as well as with other source files in the Hierarchy, Libraries, and Compile Order views. You can select these cores in the Sources window to see the files that make up the core, and to view the properties in the Source File Properties window.

**Note:** You can also add EDIF, Verilog, or SystemVerilog netlists or NGC files for IP cores into either RTL or netlist-based projects. For more information, see *Creating a Post-Synthesis Project in Chapter 2*. 
Working with Sources in Project Mode

Working with IP Integrator Sources

In the Vivado IDE, you can add and manage IP subsystem designs (.bd extension) in an RTL project. Using the Vivado IP integrator, you can create an IP subsystem design. The IP integrator enables you to create complex system designs by instantiating and interconnecting multiple IP cores from the Vivado IP catalog. You can create designs interactively through the IP integrator canvas in the Vivado IDE or programmatically with Tcl commands. For information on using the IP integrator, see the Vivado Design Suite User Guide: Designing IP Subsystems Using IP Integrator (UG994) [Ref 12].

Note: The Vivado IP integrator offers a subset of the IP available in the Vivado IP catalog.

Creating or Opening Block Design Sources

To create or open a block design source that was added to the project:

1. In the Flow Navigator, expand IP Integrator.
2. Select Create Block Design.

Adding Block Design Sources

To add a block design source that was created outside of the project:

1. Select File > Add Sources.
   
   Note: Alternatively, select Add Sources from the popup menu or from the Flow Navigator.

2. In the Add Sources wizard (Figure 3-1), select Add Existing Block Design Sources, and click Next.

3. In the Add Existing Block Design Sources page (Figure 3-15), set the following options, and click Finish.
   
   - Add Files: Opens a file browser in which you can select IP integrator block designs (BD) files to add to the design.
   - Remove: Removes the selected source files from the list of files to be added.
   - Move Selected File Up: Moves the file up in the list order.
   - Move Selected File Down: Moves the file down in the list order.
If the target part used in the subsystem design is different from the target part in the current project, the Mismatched Parts dialog box opens (Figure 3-16). Choose one of the following options to handle the difference:

- **Ignore the Difference**: Imports the IP subsystem designs without changing the target part for either the current project or the IP subsystem.
- **Apply sub-design part to the project**: Changes the target part in the current project to use the target part from the subsystem design.
- **Apply project part to sub-designs**: Changes the target part in the subsystem designs to use the target part in the current project.

![Mismatched Parts dialog box](image)
Working with DSP Sources

In the Vivado IDE, you can import an existing Xilinx System Generator design model file (.mdl extension) as a DSP module. You can add the model to any hierarchy level as a sub-module or import it at the top-level of the design. You can also define a new DSP module from within the Vivado IDE and launch Xilinx System Generator to complete the design.

System Generator is a DSP design tool from Xilinx that allows the RTL source files, Simulink® and MATLAB® software models, and C/C++ components of a DSP system to come together in a single simulation and implementation environment.

A System Generator design is often a sub-design that is incorporated into a larger HDL design. While System Generator supports creating and implementing standalone FPGA designs, the recommended flow is to begin with a project in Vivado IDE, and develop a DSP module source for the project using System Generator. This allows the Vivado IDE to manage the project for the FPGA design, while handling the DSP module as a single source file that is developed and managed within System Generator.

Adding DSP Modules

1. Select File > Add Sources.
   
   **Note:** Alternatively, select Add Sources from the popup menu, or from the Flow Navigator.

2. In the Add Sources wizard (Figure 3-1), select Add or Create DSP Sources, and click Next.

3. In the Add or Create DSP Sources page (Figure 3-17), set the following options, and click Finish.
   
   - **Add Sub-Design:** Opens a file browser to navigate to existing System Generator model file (MDL) files to add to the project.
   
   - **Create Sub-Design:** Launches System Generator in which you can define a new DSP module to add to the project.
   
   - **Add Files:** Opens a file browser to navigate to existing System Generator model file (MDL) files to add to the project.
   
   - **Create File:** Launches System Generator so you can define a new DSP module to add to the project.
   
   - **Remove:** Removes the selected DSP source from the list of files to be added.
   
   - **Move Up:** Moves the selected source up in the list order.
   
   - **Move Down:** Moves the selected source down in the list order.
   
   - **Copy Sources into Project:** Copies the original DSP model files into the project and uses the local copied version of the file in the project.
4. When **Create Sub-Design** is selected, System Generator and MATLAB are launched to create and manage the DSP source files, as shown in Figure 3-18.

The added DSP design sources display separately in the IP Sources view of the Sources window. DSP sources display with other source files in the Hierarchy, Libraries, and Compile Order views of the Sources window. You can select the DSP modules in the Sources window to see the associated files and to view the properties in the Source File Properties window.

**Note:** You can also add DSP sources using the `create_sysgen` Tcl command, which can be used to create a new DSP sub-module. The Vivado IDE creates a new MDL file and adds it as a sub-module to your project.
Generating Targets

After the System Generator design is completed, you can generate the FPGA target files using the DSP module popup menu commands in the Sources window. These commands are available when a DSP source is selected in the Sources window (Figure 3-19).

![Figure 3-19: DSP Sources in the Sources Window](image)

Targets are the different design elements of the DSP module that are required to support synthesis, simulation, and implementation of the current project. These include a top module definition, an Instantiation Template, the synthesized netlist, and any supporting documents.

In the Sources window, following are the popup menu commands for DSP sources:

- **Create Top HDL**: Creates a top-level wrapper for the DSP module and imports it into the project. Use this command when the System Generator design is the top level of the current project.

- **View Instantiation Template**: Creates an instantiation template to use for instantiating the DSP module into the RTL design. The Instantiation Template can be cut and paste into another RTL file to create an instance of the DSP module in the hierarchy.

- **Create Testbench**: Writes test vector files that are extracted from the Simulink simulation and generates an HDL test bench and script files for simulation. The test bench is added to the Sources window in a simulation set.

- **Generate**: Generates the synthesis, implementation, and simulation target data from the System Generator model. This invokes System Generator and MATLAB to create the necessary data.

- **Reset**: Removes the specified target data from the current project and from the local project repository so that it can be regenerated as needed.
Working with Sources in Project Mode

Working with Embedded Sources

The Embedded Development Kit (EDK) is a suite of tools and IP that you can use to integrate your hardware and software system components. EDK includes the Xilinx Platform Studio (XPS) and Software Development Kit (SDK).

You can use XPS to design the hardware portion of your embedded processor system. Specification of the microprocessor, peripherals, and the interconnection of these components, along with their respective detailed configuration, takes place in XPS. For more information on effective embedded system design, see the EDK Concepts, Tools, and Techniques Guide (UG683) [Ref 17].

Although the EDK environment supports creating and implementing designs, the recommended flow is to begin with a project in the Vivado IDE and develop an embedded processor source for the project using XPS. This allows the Vivado IDE to manage the project for the FPGA design, while handling the embedded processor design as a single source file that is developed and managed within XPS. Figure 3-20 shows the integrated embedded design flow.

**IMPORTANT:** The Vivado IP integrator is the replacement for Xilinx Platform Studio (XPS) for new embedded processor designs, including designs targeting Zynq® devices and MicroBlaze™ processors. In the Vivado Design Suite, XPS supports designs targeting MicroBlaze processors only. In the ISE Design Suite and EDK, XPS supports designs targeting Zynq devices and MicroBlaze processors.

**TIP:** For existing XPS designs that target Zynq devices, migrate the designs to the Vivado IP integrator as described in the Vivado Design Suite Migration Methodology Guide (UG911) [Ref 9].
Adding Embedded Processors

You can import existing Xilinx Microprocessor Project (.xmp extension) files from XPS, or define new embedded processor sub-designs and open XPS to create and manage the project as follows.

**Note:** Alternatively, you can use XPS and System Generator standalone and import the resulting netlist and constraints into the Vivado project as sources.

**IMPORTANT:** When you add XMP files your design, do not include spaces in your path structure. XPS does not currently support spaces in paths.

1. Select **File > Add Sources**.
   **Note:** Alternatively, select **Add Sources** from the popup menu or from the Flow Navigator.

2. In the Add Sources wizard (Figure 3-1), select **Add or Create Embedded Sources**, and click **Next**.
3. In the Add or Create Embedded Sources page (Figure 3-21), set the following options, and click **Finish**.
   - **Add Sub-Design**: Opens a file browser to navigate to existing XMP files to add to the Vivado IDE project.
   - **Create Sub-Design**: Launches XPS to allow you to define the new sub-design to add to the Vivado IDE project. For more information, see Creating a Sub-Design.
   - **Remove**: Removes the selected sub-design from the list of files to be added.
   - **Move Up**: Moves the selected sub-design up in the list order.
   - **Move Down**: Moves the selected sub-design down in the list order.
   - **Copy Sources into Project**: Copies the original embedded processor design (XMP) files into the project and uses the local copied version of the file in the project.

![Add Sources Wizard—Add or Create Embedded Sources Page](image)

*Figure 3-21: Add Sources Wizard—Add or Create Embedded Sources Page*

The added sub-designs display separately in the IP Sources view of the Sources window, as well as with other source files in the Hierarchy, Libraries, and Compile Order views. You can select these sub-designs in the Sources window to see the files that are associated with the module, and to view the properties in the Source File Properties window.
Creating an HDL Wrapper

To synthesize a design that includes an XMP file, you must create an HDL wrapper for the XMP file as follows.

1. In the Sources window, right-click the XMP file, and select Create HDL Wrapper.
2. In the Create HDL Wrapper dialog box, select Let Vivado manage wrapper and auto-update.
   
   Note: If you want to manage the file yourself, select Copy generated wrapper to allow user edits.
3. Click OK.

Tcl Command for Creating an HDL Wrapper

Following is the associated Tcl command:

• Tcl Command: make_wrapper
• Tcl Command Example: make_wrapper -files [get_files <path-to-xmp-file>/system.xmp] -top -fileset [get_filesets sources_1] -import

Creating a Sub-Design

Following is a brief overview of the process of defining the embedded design. For more information, refer to the EDK Concepts, Tools, and Techniques Guide (UG683) [Ref 17] and Embedded System Tools Reference Manual (UG111) [Ref 18].

If you selected Create Sub-Design in the Add or Create Embedded Sources dialog box, XPS is launched. In XPS, you can define the new embedded sub-design. Project properties in the Vivado IDE, such as target part or TDP, are automatically passed to XPS when it opens. XPS recognizes that this is a new sub-design and prompts you to use the Base System Builder wizard to help design the board for the design.

1. Click Yes to continue.
2. In the Base System Builder (BSB) wizard (Figure 3-22), specify the following options, and click OK.
The BSB wizard helps you quickly build a working system. Some embedded design projects can be completed using the BSB wizard alone. For more complex projects, the BSB wizard provides a baseline system that you can then customize to complete your embedded design.

**Note:** Much of the form is filled in with data from the current project, and **cannot** be modified. This is to protect the integration of the Vivado IDE project with the XPS project.

- **Project File:** Indicates the name of the sub-design specified in the Create Sub-Design dialog box. This name comes from the Vivado IDE.
- **Select an Interconnect Type:** Specifies the AXI System. This is a hard coded selection, because legacy processor local bus (PLB) designs are not supported in the Vivado tools.
- **Select Existing .bsb Settings File:** Optionally, specify a BSB settings file from a previous session to automatically apply the same selections into this BSB session.
- **Set Project Peripheral Repository Search Path:** Specify user repositories containing custom pcores, Board Support Packages (BSPs), and Software Services. To specify more than one repository search path, separate each path with a semi-colon (;).

![Base System Builder Wizard](image)

**Figure 3-22:** Base System Builder Wizard
3. In the Board and System Selection page (Figure 3-23), define the TDP or platform for the embedded processor design, and click Next.

The definition of the TDPs offered is limited to those containing the target part that you selected for the project in the Vivado IDE. From the target development board, the BSB is able to determine what devices are on the target board, such as the specific FPGA device, external memories, I/O devices, clock resources, and reset polarity. The following wizard pages are customized based on the information that can be retrieved for the selected board, minimizing the amount of input that is required.

Note: If the selected FPGA is not featured on any of the supported boards, you receive a message indicating that no boards for the device were found, and you must select Create a System for a Custom Board.

![Base System Builder Wizard—Board and System Selection Page](image-url)
4. In the Processor, Cache, and Peripheral Configuration dialog box (Figure 3-24), select which of the peripherals available on the specified TDP to include in your embedded design, and click Finish.

![Figure 3-24: Base System Builder Wizard—Processor, Cache, and Peripheral Configuration Page](image)

The embedded design is created, and the project opens in XPS. You can edit and manage the embedded processor sub-design in the XPS tool.

**Note:** You can also create an XPS source using the `create_xps` Tcl command, which can be used to create a new embedded system in the project. The Vivado IDE creates a new XMP file and adds it as a sub-module to your project.
Generating Targets

When you exit the XPS tool, the top-level project design file (.xmp extension) and the Microprocessor Hardware Specification file (.mhs extension) are added in the Sources window in the Vivado IDE. Expanding the Embedded Design Sources in the Sources window displays the various target files associated with the sub-design (Figure 3-25).

![Embedded Design Sources](image)

**Figure 3-25: Embedded Design Sources**

Targets are the different design elements of the XPS sub-design that are required to support the object in the current project. These include the top module definition, an Instantiation Template, the synthesized netlist, and any supporting documents such as log files and data sheets. The project file for the embedded design (XMP) is displayed in the Hierarchy view of the Sources window.

In the Sources window, following are the popup menu commands for embedded sources:

- **Create Top HDL**: Creates a top-level wrapper for the embedded design, and imports it into the project. Use this command when the embedded design is the top level of the current design.

- **View Instantiation Template**: Creates an instantiation template to use for instantiating the embedded design module into the RTL design. You can cut and paste the Instantiation Template into another RTL file to create an instance of the sub-design in the hierarchy.

  *Note*: The template file is *not* added to the project.

- **Create Testbench**: Creates a test bench for the embedded design. The test bench is added to the Sources window in a simulation set.

- **Generate**: Creates the specified target data for synthesis, implementation, or simulation. The target data includes the Verilog or VHDL files, the wrapper files, the block memory map (BMM) model, and the top-level simulation model for the sub-design.

- **Reset**: Removes the specified target data from the current project. This also removes the generated target data from the local project repository so that it can be regenerated as needed.
When you generate the target data, the /synthesis and /implementation subdirectories are created for the embedded sub-design. This also occurs when you use either the Hardware > Generate Netlist or Hardware > Generate Bitstream commands in XPS.

If you added an existing XPS embedded design source, /synthesis and /implementation are subdirectories of the embedded design, external from the current project. However, if you used the Create Sub-Design command to add the embedded processor design to the current project, the /synthesis and /implementation subdirectories are local to the project directory in:
<project>.srcs\sources_1\edk\<subdesign_name>

Exporting Hardware

The Vivado IDE is also integrated with SDK to support the design of software for the embedded processor sources in your project. To develop software for your project using SDK, with the embedded processor in your design, do the following:

1. Select File > Export > Export Hardware for SDK.

2. In the Export Hardware for SDK dialog box (Figure 3-26), specify the following options, and click OK.

   - **Source**: Specifies the source XPS project file to export.
   - **Export to**: Specifies the location which to export the hardware. By default, the hardware files are written to the local project directory, under:
     <project>.sdk/SDK/SDK_Export/hw
   - **Workspace**: Specifies the location of the workspace to be used by SDK. By default, the SDK workspace files are written to the local project directory under:
     <project>.sdk/SDK/SDK_Export
   - **Include Bitstream**: Copies the bitstream file to the location specified in the Export to field.
   - **Export Hardware**: Generates the files necessary to support software development for the embedded processor design.
   - **Launch SDK**: Launches the SDK tool after the hardware files are generated.
The Vivado IDE exports the Hardware Platform Specification (system.xml) for your design, and opens the file in SDK, if you selected Launch SDK. Refer to the SDK Help for more information.

**Associating an ELF File**

To boot up an embedded processor system, both hardware and software components of the system must be downloaded to the FPGA and program memory respectively. This requires creating a bitstream file that contains the software application targeted for the block RAM. The Vivado IDE creates a hardware bitstream using the block RAMs initialized with the software executable and linkable format (ELF) file that is associated with the embedded processor. You can then use the Vivado logic analyzer to program the FPGA with the bitstream. See the *Vivado Design Suite User Guide: Programming and Debugging* (UG908) [Ref 16].

In the Vivado IDE, you can add or update the ELF files associated with available processor instances as follows:

1. Select **Tools > Associate ELF Files**.

2. In the Associate ELF Files dialog box *(Figure 3-27)*, specify the ELF file to use for all available processor instances, either when generating the bitstream file or when simulating the design.

   **Note:** ELF files added to the project as design sources are available in the Design Sources hierarchy of the dialog box. Those added to the project as simulation sources are available in the Simulation Sources hierarchy.
The ELF file populates the block RAMs specified in the BMM file. The bitstream file created by Vivado IDE now includes the block RAM initialized with the selected executable code. For more information, see the *EDK Concepts, Tools, and Techniques Guide* (UG683) [Ref 17].

**Tcl Commands for Adding and Associating an ELF File**

Following are the associated Tcl commands:

- **Tcl Command**: `add_files` and `set_property`

- **Tcl Command Examples**:

  When generating the bitstream, you can use the following Tcl commands to add and associate an ELF file with the processor:

  ```tcl
  add_files -norecurse <path-to-elf-file>/<elf-file>.elf
  set_property MEMDATA.ADDR_MAP_CELLS 
  {{<hierarchical-path-to-XMP>/microblaze_0}} [get_files -all 
  -of_objects [get_fileset sources_1] 
  {<path-to-elf-file>/<elf-file>.elf}]
  ```
If you want to use an ELF file when simulating the design, you can use the following Tcl commands to add and associate an ELF file with the processor:

```
add_files -fileset sim_1 -norecurse <path-to-elf-file>/<elf-file>.elf
set_property MEMDATA.ADDR_MAP_CELLS {{<hierarchical-path-to-XMP>/microblaze_0}} [get_files -all -of_objects [get_fileset sim_1] {<path-to-elf-file>/<elf-file>.elf}]
```

### Editing Source Files

The Vivado IDE provides a Text Editor in which to create or modify RTL, XDC, Tcl and other text sources. The Text Editor is syntax-sensitive and uses color-coding to distinguish RTL, XDC, and Tcl keywords. You can open multiple files simultaneously, and click the tab for each file to access to all open files.

When you modify a file, the Vivado IDE appends an asterisk (*) to the file name in the tab until the file is saved. To save the file, use one of the following methods:

- Select **File > Save File**.
- In the Vivado IDE Text Editor, select **Save File** from the popup menu.
- In the Vivado IDE Text Editor, use the **Save File** toolbar button.

If you attempt to close a file with unsaved changes, the Vivado IDE prompts you to save the changes. You can also use the Save As command to save the source file to a new location.

**Note:** For more information on the Vivado IDE Text Editor, see the *Vivado Design Suite User Guide: Using the Vivado IDE* (UG893) [Ref 7].

### Using the Text Editor

The Vivado IDE enables cross-probing between the Text Editor and other views, such as the Schematic, Messages, RTL Netlist, and Hierarchy views.

The Text Editor toolbar provides quick access to the following features:

- **Save**: Saves current changes to the open file.
- **Undo**: Undoes the last modification to the open file.
- **Redo**: Redoes the last modification to the open file.
- **Cut**: Cuts the selected section and places it on the clipboard.
- **Copy**: Copies the selected section and places it on the clipboard.
- **Paste**: Pastes the contents of the clipboard at the location specified.
• **Delete**: Deletes the selected section. The deleted section is not copied to the clipboard.

• **Toggle Line Comments**: Places appropriate comment characters at the start of the selected line(s).

• **Toggle Column Selection**: Puts editor in column selection mode. Enables column cut/copy/delete/paste.

• **Find**: Displays the Find bar at the bottom of the Text Editor window to enable searching of the file.

• **Find in Files**: Displays the Find in Files window for searching files in the entire project.

• **Language Templates**: Displays the Language Templates view. Templates for Verilog, VHDL, Tcl, and XDC are available for many common design and constraint structures.

• **Insert Template**: Inserts the selected template into the text file being edited at the cursor location. This command is only available if a template is selected.

• **Move Caret to Document Start**: Moves the cursor to the start of the document being edited.

• **Move Caret to Document End**: Moves the cursor to the end of the document being edited.

### Using Templates

The Vivado IDE provides templates for many Verilog, VHDL, and XDC structures. To view the templates select **Language Templates** from the Vivado IDE Text Editor toolbar. The Templates window appears with folders for Verilog, VHDL, and XDC. Select a template to open it in the Preview pane (Figure 3-28).

![Language Templates Preview Pane](image-url)
When a template is selected, you can use the **Insert Template** command from the Text Editor toolbar. Selecting this command copies the selected template into the file being edited at the location of the cursor.

**Using the Find/Replace in Files Commands**

You can use **Find** or **Find in Files** to search for any given text string in an open source file or a selected set of source files. You can perform the following actions:

- Enter any text string, including wildcards (*), as search criteria.
- Use the filtering options to search source files, constraint files, and report files.

For more information, see the *Vivado Design Suite User Guide: Using the Vivado IDE* (UG893) [Ref 7].

**Cross Probing to Source Files**

The Vivado IDE provides cross probing to RTL source files from the following windows:

- Schematic window (RTL elaborated, synthesis, or implementation)
- Netlist window (after synthesis or implementation)
- Device window (for an implemented design)

To cross probe, select a cell from any of these windows, and select the **Go To Definition** or **Go To Source** popup command. The RTL source opens, and the line with the instance is highlighted as shown in Figure 3-29.
Figure 3-29: Cross Probing to an RTL Source
Tcl Commands for Cross Probing to Source Files

You can use the FILE_NAME and LINE_NUMBER properties on a cell to get information about where the cell is located in the RTL source. You can then open the RTL source in a text editor and navigate to the appropriate line number. Following is the associated Tcl command:

- **Tcl Command**: `get_cells`
- **Tcl Command Example**: The following example shows how to use the `get_cells` Tcl command to get a specific instance of a cell, query the properties of that cell object, and report the file and line of interest:

```tcl
set cellName dac_spi_i0
set fileName [get_property FILE_NAME [get_cells $cellName]]
set lineNum [get_property LINE_NUMBER [get_cells $cellName]]
puts "Cell: $cellName is instanced in file: $fileName at line number $lineNum"
```

Using Alternate Text Editors

In the Vivado IDE, you to select an alternative text editor as follows:

1. Select **Tools > Options**.
2. In the Vivado Options dialog box General page (Figure 3-30), scroll down to the Text Editor section, and select an alternate editor select from the drop-down list.
When you select an editor from the list, an executable name appears in the settings. The path to the executable needs to be in your path. See the appropriate Windows or Linux documentation for help on how to add a path to your environment.

![Vivado Options Dialog Box—General Page](image)

*Figure 3-30: Vivado Options Dialog Box—General Page*
Working with Sources in Non-Project Mode

If your editor is not listed, select **Custom Editor**. In the Custom Editor Definition dialog box (Figure 3-31), enter the name or location of the executable and the command line syntax used to run the editor.

![Custom Editor Setting](image)

**Note:** When using an alternative text editor, cross probing works differently. The file opens in the external editor but does not go to the line number automatically.

---

**Working with Sources in Non-Project Mode**

In Non-Project Mode source files are under your control, unlike with Project Mode which manages the source files for you. You directly reference the files you want to be processed with various Tcl commands, such as `read_xdc`, `read_verilog`, `read_vhdl`, and `read_ip`. For more information on Project Mode and Non-Project Mode, see the *Vivado Design Suite User Guide: Design Flows Overview* (UG892) [Ref 1]. For more information on Tcl commands, see the *Vivado Design Suite Tcl Command Reference Guide* (UG835) [Ref 5].
Following is an example of a Non-Project Mode script, which reads in a variety of source files:

```tcl
# create_bft_batch.tcl  
# bft sample design  
# A Vivado script that demonstrates a very simple RTL-to-bitstream batch flow  
#  
# NOTE: typical usage would be "vivado -mode tcl -source create_bft_batch.tcl"  
#  
# STEP#0: define output directory area.  
#  
set outputDir ./Tutorial_Created_Data/bft_output  
file mkdir $outputDir  
#  
# STEP#1: setup design sources and constraints  
#  
read_vhdl -library bftLib [ glob ./Sources/hdl/bftLib/*.vhdl ]  
read_vhdl ./Sources/hdl/bft.vhdl  
read_verilog [ glob ./Sources/hdl/*.v ]  
read_xdc ./Sources/bft_full.xdc  
#  
# STEP#2: run synthesis, report utilization and timing estimates, write checkpoint design  
#  
synth_design -top bft -part xc7k70tfbg484-2 -flatten rebuilt  
write_checkpoint -force $outputDir/post_synth  
report_timing_summary -file $outputDir/post_synth_timing_summary.rpt  
report_power -file $outputDir/post_synth_power.rpt  
#  
# STEP#3: run placement and logic optimization, report utilization and timing estimates, write checkpoint design  
#  
opt_design  
place_design  
phys_opt_design  
write_checkpoint -force $outputDir/post_place  
report_timing_summary -file $outputDir/post_place_timing_summary.rpt  
#  
# STEP#4: run router, report actual utilization and timing, write checkpoint design, run drc, write verilog and xdc out  
#  
route_design  
write_checkpoint -force $outputDir/post_route  
report_timing_summary -file $outputDir/post_route_timing_summary.rpt  
report_timing -sort_by group -max_paths 100 -path_type summary -file $outputDir/post_route_timing.rpt  
report_clock_utilization -file $outputDir/clock_util.rpt  
report_utilization -file $outputDir/post_route_util.rpt  
report_power -file $outputDir/post_route_power.rpt  
report_drc -file $outputDir/post_imp_drc.rpt  
write_verilog -force $outputDir/bft_impl_netlist.v  
write_xdc -no_fixed_only -force $outputDir/bft_impl.xdc  
#  
# STEP#5: generate a bitstream  
#  
write_bitstream -force $outputDir/bft.bit
```
Chapter 4

Elaborating the RTL Design

Overview

The Vivado® IDE offers many analysis capabilities for an RTL design. For example, you can:

- Visualize design details with Schematic and Hierarchy windows.
- Cross probe between windows.
- Run design rule checks (DRCs).
- Check messaging.
- Search the RTL netlist produced with the Find command.
- Create and apply constraints at the RTL level.

*Note:* You cannot run timing analysis at this stage.

Elaborating the Design in Project Mode

Enabled RTL source files in the project are elaborated automatically during synthesis. You can also elaborate source files manually for constraint development and RTL netlist exploration. The Messages window shows the messages from elaboration and compilation. You can select the HDL language options used during elaboration in the Vivado IDE Project Settings. For information, see General Settings in Chapter 2.

Elaboration results are not saved with the design. Every time you open the elaborated design, it is re-elaborated. After you synthesize the elaborated design, the Vivado IDE saves it as a synthesized design.
After design source files are imported into the project, use either of the following methods to elaborate and open the design:

- Select **Flow > Open Elaborated Design**.
- In the RTL Analysis section of the Flow Navigator, select **Open Elaborated Design** to load the elaborated netlist, the active constraint set, and the target device into memory.

To specify the design name to elaborate, use either of the following methods:

- Select **Flow > New Elaborated Design**.
- In the Flow Navigator, select **New Elaborated Design** from the RTL Analysis popup menu.

When you open an elaborated design, the Vivado IDE automatically elaborates the RTL source files, generates the top schematic view, and displays the design in the default view layout. **Figure 4-1** shows the RTL Schematic window with the default view layout of the elaborated design.

![Figure 4-1: Elaborated Design in the RTL Schematic Window](image-url)
Elaborating the Design in Project Mode

The Vivado IDE automatically identifies the top module for the design in most cases. In some cases, where there might be multiple candidates, the tool prompts you to choose the top module for the design. You can also manually define the top module by selecting **Set as Top** from the popup menu in the Sources window.

**Note:** In the Hierarchy view of the Sources window, the top module icon identifies the current top module.

**Tcl Command for Elaborating the Design in Project Mode**

Following is the associated Tcl command:

- **Tcl Command:** `synth_design -rtl -name <project_name>`
- **Tcl Command Example:** `synth_design -rtl -name rtl_1`

**Viewing Elaboration Messages**

The Messages window displays the results of the compilation and flags irregularities in the RTL source files under the Elaborated Design section (Figure 4-2).

You can filter the Messages window to display errors or warnings or informational messages from the results of RTL elaboration. To enable or disable the display of Errors, Critical Warnings, Warnings, or Informational messages, select a checkbox in the banner of the Messages window.

You can select any of the warning or error messages in the Messages window to load the corresponding RTL source file with the selected source code highlighted in the Vivado IDE Text Editor.

---

![Figure 4-2: Elaborated Design Messages](image_url)
Analyzing the RTL Logic Hierarchy

The Vivado IDE provides the following views into the logical design hierarchy:

- **RTL Netlist window**: Shows an expandable logic tree.
- **RTL Hierarchy window**: Shows a graphical representation of the logic hierarchy.
- **RTL Schematic window**: Shows a view in which to explore the logic and hierarchy in a schematic representation.

By default, when you elaborate a design by selecting *Elaborate Design* in the Flow Navigator, the RTL Schematic displays for the entire design. All views cross-select offering a unique set of capabilities to explore and analyze the logical design. For more information, see the *Vivado Design Suite User Guide: Using the Vivado IDE* (UG893) [Ref 7].

Exploring the Elaborated Design Schematic

You can select any level of logic hierarchy in the RTL Netlist window and display it in the RTL Schematic window. To invoke the RTL Schematic window for any selected logic, do one of the following:

- Select **Tools > Schematic**.
- In the RTL Netlist window, select **Schematic** from the popup menu.

For more information on traversing, expanding and exploring the RTL Schematic, see the *Vivado Design Suite User Guide: Using the Vivado IDE* (UG893) [Ref 7].

**Note**: After you elaborate the elaborated design, you can use the **Find** command to search for logic objects using a range of filtering techniques.

Using the RTL Hierarchy Window

The Vivado IDE includes an RTL Hierarchy window, which is useful for viewing the hierarchy of a design. To invoke the RTL Hierarchy view for any selected logic, do one of the following:

- Select **Tools > Show Hierarchy**.
- In the RTL Netlist or Schematic window, select **Show Hierarchy** from the popup menu.

These windows have full cross probing support. Logic selected in the RTL Netlist or Schematic window is highlighted in the RTL Hierarchy window.

Exploring the RTL Source Files

You can select any logic element in the RTL Netlist view or Schematic and open the instantiation of that object in the RTL source file it is instantiated in. You can also open the definition of the logic in the RTL file it is defined in.
Elaborating the Design in Project Mode

To open the instantiation or definition of any selected logic in the RTL source file, select the object and select Go To Instantiation or Go to Definition from the popup menu. The Vivado IDE opens the appropriate source file with the specific instance highlighted.

Running DRCs

The following sections describe selecting DRCs rules and analyzing DRC violations in the Vivado IDE. For information on running DRCs using Tcl commands, see the Vivado Design Suite Tcl Command Reference Guide (UG835) [Ref 5]. For information on creating custom DRCs, see the Vivado Design Suite User Guide: Using Tcl Scripting (UG894) [Ref 4].

RECOMMENDED: Running RTL DRCs enables you to find design issues early, during the elaboration stage prior to synthesis, which saves time over the course of your design.

Selecting DRC Rules

1. Select Tools > Report DRC.

   Note: Alternatively, you can select Report DRC in the Flow Navigator, or enter the following command in the Tcl Console: report_drc -name <results_name>.

2. In the Report DRC dialog box (Figure 4-3), set the following options, and click OK:

   - **Results name**: Specify the name for the DRC results, which appear in a tab in the DRC window. Entering a unique name makes it easier to identify the results for a particular run during debug in the DRC window. By default, the output file name matches the name you enter.
   - **Output file**: Optionally, enter a file name to save the DRC results to a file. To select a path other than the default, use the browse button.
   - **Rule deck**: Specify a rule deck to run on the design. A rule deck is a collection of design rule checks grouped for convenience. The rule deck is run at different stages of the FPGA design flow, such as after synthesis or implementation.
     - **default**: Runs a default set of checks recommended by Xilinx.
     - **bitstream_checks**: Runs checks associated with bitstream generation.
     - **methodology_checks**: Runs checks on the XDC files and on the RTL file when an elaborated design is open.
     - **opt_checks**: Runs checks associated with logic optimization.
     - **placer_checks**: Runs checks associated with placement.
     - **router_checks**: Runs checks associated with routing.
     - **timing_checks**: Runs checks associated with timing constraints.
   - **Rules to Check**: After specifying a rule deck, modify the rules to run as needed.
Analyzing DRC Violations

If violations are found, the DRC window opens, as shown in Figure 4-4. The DRC window displays the rule violations found, grouped under the various rule categories defined in the Run DRC dialog box.
The rule violations are categorized by severity and are color coded as follows:

- **Informational**: Makes you aware of a possible issue. 🔄
- **Warning**: Suggests an issue that might need resolution. 🚨
- **Critical Warning**: Highlights issues that you are strongly encouraged to fix before proceeding. 😱
- **Error**: Highlights issues that prevent proper implementation of your design. 😱

**TIP:** To turn off warnings and informational messages and see only the errors reported, toggle the **Hide Warning and Informational Messages** toolbar button.

You can list DRC violations individually or group violations by rule. To change the display, click the **Group By Rule** toolbar button. When violations are listed individually, you can click the header of the **Severity** column to sort violations by severity. To sort the column:

- Click the column header to sort data in the table in an increasing order.
- Click the column header again to sort the data in the table in a decreasing order.

**Note:** For more information, see the [Vivado Design Suite User Guide: Using the Vivado IDE](https://www.xilinx.com) (UG893) [Ref 7].

When you select a violation message in the DRC window, the objects associated with the violation are selected in other open windows, such as the Netlist or Schematic windows. This lets you quickly locate and examine the elements of the design that are associated with a specific violation.
In addition, the violation properties are shown in the Violation Properties window (Figure 4-5) by default. In the DRC window, you can also select **Violation Properties** from the popup menu to open the Violation Properties window. The Violation Properties window shows both a **General** view of the DRC rule violation and specific **Details** of the design elements that violate the rule. The Details view includes links to specific design objects that violate the DRC. Click the links to view the design object in the RTL Netlist window, the Device window, the Schematic window, or the source RTL file.

![Violation Properties Window](image)

**Figure 4-5:** Violation Properties Window

**Tcl Command for Running RTL DRCs**

Following is the associated Tcl command:

- **Tcl Command:** `report_drc`
- **Tcl Command Example:** `report_drc -name drc_1`

**Note:** By default, a text-based report is produced. You can use the `-name` option to create an interactive tab for the report.
Elaborating the Design in Non-Project Mode

In Non-Project Mode, you can perform elaboration of the RTL. You can also cross probe back to the RTL and run DRCs. Cross probing requires that you load the Vivado IDE using the `start_gui` Tcl command. You can perform DRCs with or without the Vivado IDE.

Following is a script that sources various files and elaborates the RTL using the `synth_design` Tcl command with the `-rtl` option. The script also loads the Vivado IDE so you can cross probe back to the RTL source from the schematic or netlist.

**Note:** When you load Vivado IDE in Non-Project Mode, there is no Flow Navigator. Instead, you must use the Tools menu and Tcl Console to accomplish tasks.

```tcl
# create_bft_batch.tcl
# bft sample design
# A Vivado script that demonstrates a very simple RTL-to-bitstream batch flow
#
# NOTE: typical usage would be "vivado -mode tcl -source create_bft_batch.tcl"
#
# STEP#0: define output directory area.
#
set outputDir ./Tutorial_Created_Data/bft_output
file mkdir $outputDir
#
# STEP#1: setup design sources and constraints
#
read_vhdl -library bftLib [ glob ./Sources/hdl/bftLib/*.vhdl ]
read_vhdl ./Sources/hdl/bft.vhdl
read_verilog [ glob ./Sources/hdl/*.v ]
read_xdc ./Sources/bft_full.xdc
#
# STEP #2 Elaborate the RTL and start the GUI for interaction
#
synth_design -top bft -part xc7k70tfbg484-2 -rtl
start_gui
#
# Use stop_gui to quit the GUI and return back to the Vivado IDE Tcl command line
```
Chapter 5

Debugging the Design

Overview

Debugging an FPGA design is a multi-step, iterative process. Like most complex problems, it is best to break the FPGA design debugging process down into smaller parts, for example, by focusing on making a smaller section of the design work rather than trying to make the whole design work at one time. An example of a proven design and debug methodology is to iterate through the design flow, adding one module at a time and making it function properly in the context of the whole design. You can use this design and debug methodology in any combination of the following design flow stages:

• RTL-level design simulation
• In-system debugging

In addition to using the Set up Debug wizard, you can also use Tcl commands to create, connect, and insert debug cores into your synthesized design netlist. For more information on debugging, see the Vivado Design Suite User Guide: Programming and Debugging (UG908) [Ref 16].

RTL-Level Design Simulation

You can functionally debug the design during the simulation verification process. Xilinx® provides a full design simulation feature in the Vivado® simulator. You can use the Vivado simulator to perform RTL simulation of your design. The benefits of debugging your design in an RTL-level simulation environment include full visibility of the entire design and the ability to quickly iterate through the design and debug cycle. For more information on how to configure and launch simulation, see the Vivado Design Suite User Guide: Logic Simulation (UG900) [Ref 13].
In-System Debugging

The Vivado IDE also includes a logic analysis feature that enables you to perform in-system debugging of the post-implemented design on an FPGA device. The benefit of in-system debugging is that you are able to debug a timing-accurate, post-implemented design in the actual system environment at system speeds. The limitations of in-system debugging includes somewhat lower visibility of debug signals compared to using simulation models and potentially longer design, implementation, and debug iterations, depending on the size and complexity of the design.

The Vivado IDE provides several different ways to debug your design. You can use one or more of these methods to debug your design, depending on your needs. For more information, see the Vivado Design Suite User Guide: Programming and Debugging (UG908) [Ref 16].
Appendix A

Additional Resources

Xilinx Resources

For support resources such as Answers, Documentation, Downloads, and Forums, see the Xilinx® Support website at:

www.xilinx.com/support.

For a glossary of technical terms used in Xilinx documentation, see:


Solution Centers

See the Xilinx Solution Centers for support on devices, software tools, and intellectual property at all stages of the design cycle. Topics include design assistance, advisories, and troubleshooting tips.

References

9. ISE to Vivado Design Suite Migration Guide (UG911)