## Revision History

The following table shows the revision history for this document.

<table>
<thead>
<tr>
<th>Section</th>
<th>Revision Summary</th>
</tr>
</thead>
<tbody>
<tr>
<td>04/04/2018 Version 2018.1</td>
<td>General updates Editorial updates only. No technical content updates.</td>
</tr>
</tbody>
</table>
# Table of Contents

Revision History ................................................................................................................. 2

**Chapter 1: Vivado Design Suite Overview**
- What is the Vivado Design Suite? ................................................................................. 5
- Introducing the Vivado IDE ......................................................................................... 6

**Chapter 2: Migrating Designs to the Vivado Design Suite**
- Overview ...................................................................................................................... 7
- Migration Considerations .............................................................................................. 7

**Chapter 3: Getting Started with the Vivado Design Suite**
- Installing the Vivado Design Suite ............................................................................... 9
- Launching the Vivado Design Suite .............................................................................. 10

**Chapter 4: Learning About the Vivado Design Suite**
- Overview ...................................................................................................................... 14
- Documentation Navigator ............................................................................................. 14
- Design Hubs .................................................................................................................. 15
- Vivado Quick Help ........................................................................................................ 16
- QuickTake Video Tutorials ............................................................................................ 17
- Tool Tutorials ................................................................................................................ 17
- Documentation Suite .................................................................................................... 17

**Chapter 5: Learning About the UltraFast Design Methodology**
- Overview ...................................................................................................................... 18
- UltraFast Design Methodology Guide for the Vivado Design Suite ........................... 18
- UltraFast Design Methodology Checklist .................................................................... 19

**Appendix A: Additional Resources and Legal Notices**
- Xilinx Resources .......................................................................................................... 20
- Solution Centers ............................................................................................................ 20
- Documentation Navigator and Design Hubs ............................................................... 20
- References ..................................................................................................................... 21
Chapter 1

Vivado Design Suite Overview

What is the Vivado Design Suite?

The Vivado® Design Suite is designed to improve productivity. This tool suite is architected to increase the overall productivity for designing, integrating, and implementing systems using the Xilinx® UltraScale™ and 7 series devices, Zynq® UltraScale+™ MPSoc device, and Zynq®-7000 All Programmable (AP) SoC. Xilinx devices are now much larger and come with a variety of new technology, including stacked silicon interconnect (SSI) technology, up to 28 gigabyte (GB) high speed I/O interfaces, hardened microprocessors and peripherals, analog mixed signal, and more. These larger and more complex devices create multidimensional design challenges, when handled incorrectly, that can prevent the achievement of faster time-to-market and increased productivity. With the Vivado Design Suite, you can accelerate design implementation with place and route tools that analytically optimize for multiple and concurrent design metrics, such as timing, congestion, total wire length, utilization and power. The Vivado Design Suite provides you with design analysis capabilities at each design stage. This allows for design and tool setting modifications earlier in the design processes where they have less overall schedule impact, thus reducing design iterations and accelerating productivity.

The Vivado Design Suite replaces the existing Xilinx ISE® Design Suite of tools. It replaces all of the ISE Design Suite point tools, such as Project Navigator, Xilinx Synthesis Technology (XST), implementation, CORE Generator™ tool, Timing Constraints Editor, ISE Simulator (ISim), ChipScope™ Analyzer, Xilinx Power Analyzer, FPGA Editor, PlanAhead™ design tool, and SmartXplorer. All of these capabilities are now built directly into the Vivado Design Suite and leverage a shared scalable data model. Built on the shared scalable data model of the Vivado Design Suite, the entire design process can be executed in memory without having to write or translate any intermediate file formats, which accelerates run times, debug, and implementation while reducing memory requirements.

All of the Vivado Design Suite tools are written with a native tool command language (Tcl) interface. All of the commands and options available in the Vivado Integrated Design Environment (IDE), which is the graphical user interface (GUI) for the Vivado Design Suite, are accessible through Tcl. The Vivado Design Suite also provides powerful access to the design data for reporting and configuration as well as the tool commands and options.
You can interact with the Vivado Design Suite using:

- GUI-based commands in the Vivado IDE
- Tcl commands entered in the Tcl Console in the Vivado IDE, in the Vivado Design Suite Tcl shell outside the Vivado IDE, or saved to a Tcl script file that is run either in the Vivado IDE or in the Vivado Design Suite Tcl shell
- A mix of GUI-based and Tcl commands

A Tcl script can contain Tcl commands covering the entire design synthesis and implementation flow, including all necessary reports generated for design analysis at any point in the design flow.

---

**Introducing the Vivado IDE**


The Vivado IDE provides new users with an intuitive interface and gives advanced users the power they require. All of the tools and tool settings are written in native Tcl. You can run analysis and assign constraints throughout the design process. For example, the tools can provide timing or power estimations after synthesis, placement, or routing. Because the database is accessible through Tcl, you can make changes to constraints, design configuration, or tool settings in real time, often without forcing re-implementation.

The Vivado IDE introduces the concept of opening designs in memory. Opening a design effectively loads the design netlist at that particular stage of the design flow, assigns the constraints to the design, and applies the design to the target device. This allows you to visualize and interact with the design at each design stage. The Vivado IDE enables you to open designs after register-transfer level (RTL) elaboration, synthesis, and implementation. You can make change to constraints, logic or device configuration, and implementation results. You can also use design checkpoints to save the current state of any design. A design checkpoint is a snapshot of the design at any stage of the design process that includes the netlist, constraints, and implementation results. Vivado automatically creates design checkpoints at each stage of the flow that can be opened and analyzed.

For more information on the Vivado IDE, see the [Vivado Design Suite User Guide: Using the Vivado IDE](https://www.xilinx.com/support/documentation/user_guides/ug893.pdf) [Ref 3]. For more information on analyzing designs, see the [Vivado Design Suite User Guide: Design Analysis and Closure Techniques](https://www.xilinx.com/support/documentation/user_guides/ug906.pdf) [Ref 4].
# Chapter 2

## Migrating Designs to the Vivado Design Suite

### Overview

The Xilinx® ISE® Design Suite supports projects targeting all generations of Xilinx devices, including 7 series and Zynq®-7000 AP SoC devices. The Vivado® Design Suite supports Xilinx® UltraScale™ and 7 series devices, Zynq® UltraScale+™ MPSoC device, and Zynq®-7000 All Programmable (AP) SoC devices, and offers enhanced tool performance, especially on large or congested designs.

Because both ISE Design Suite and Vivado Design Suite support 7 series devices, you have the opportunity to migrate tools. For detailed information on design migration, see the *ISE to Vivado Design Suite Migration Guide* (UG911) [Ref 5].

### Migration Considerations

When migrating, consider the following:

- **IP**: You can migrate existing ISE Design Suite projects and IP to Vivado Design Suite projects and IP. The Vivado Design Suite can use ISE Design Suite IP during implementation. However, updating to the latest Vivado Design Suite native IP is highly recommended to leverage the latest IP updates and to use proper constraints. The Vivado Design Suite is tested and validated with native Vivado Design Suite IP only.

  **Note**: ISE IP is only supported for 7-Series devices. ISE format IP (.ngc) are no longer supported with UltraScale devices. Users should migrate their IP to native Vivado format prior to beginning UltraScale designs.

- **Source files**: You can add ISE Design Suite source files from an existing ISE Design Suite project to a new project in the Vivado Design Suite.

  **Note**: ISE Design Suite schematic (SCH) and Architecture Wizard (XAW) source files are not supported in the Vivado Design Suite.
• **Run results**: Run results are not migrated. However, new run results are generated after implementing the design in the Vivado tools.

• **Constraints**: User constraint format (UCF) files used for the design must be converted to Xilinx design constraints (XDC) format for use with Vivado Design Suite. For information on migrating UCF constraints to XDC, see this link in the *ISE to Vivado Design Suite Migration Guide* (UG911) [Ref 5]. For more information about XDC, see the *Vivado Design Suite User Guide: Using Constraints* (UG903) [Ref 6].

---

**CAUTION!** Do not migrate from ISE Design Suite to Vivado Design Suite while in the middle of an in-progress ISE Design Suite project, because design constraints and scripts are not compatible between these environments. Instead, start a new design using the Vivado Design Suite.
Chapter 3

Getting Started with the Vivado Design Suite

Installing the Vivado Design Suite

The ISE® Design Suite and the Vivado® Design Suite are now released separately and must be installed separately. Both suites are available from the Downloads page on the Xilinx® website [Ref 7].

IMPORTANT: The Vivado Design Suite is available to all ISE Design Suite customers who are currently in warranty, at no additional cost.

All current, in-warranty seats of the ISE Design Suite will receive an entitlement to the current Vivado Design Suite release. All current, in-warranty seats of the Vivado Design Suite will receive an entitlement to the equivalent ISE Design Suite edition.

You can customize the Vivado Design Suite installation based on the tools and data you require. In addition, you can customize by installing only certain Xilinx device families, such as the Kintex® or Artix® device families.

Detailed installation, licensing and release information is available in the following documents:

• Vivado Design Suite User Guide: Release Notes, Installation, and Licensing (UG973) [Ref 1]

  Note: This document includes information on operating system (OS) support. It also includes detailed information on the Xilinx Information Center, which periodically checks for new releases and updates from Xilinx and is the replacement for XilinxNotify.

• Xilinx ISE Design Suite 14: Release Notes, Installation, and Licensing (UG631) [Ref 2]

  Note: This document includes information on operating system (OS) support. It also includes detailed information on the Xilinx Information Center, which periodically checks for new releases and updates from Xilinx and is the replacement for XilinxNotify.
Launching the Vivado Design Suite

You can launch the Vivado Design Suite and run the tools using different methods depending on your preference. For example, you can choose a Tcl script-based compilation style method in which you manage sources and the design process yourself, also known as Non-Project Mode. Alternatively, you can use a project-based method to automatically manage your design process and design data using projects and project states, also known as Project Mode. Either of these methods can be run using a Tcl scripted batch mode or run interactively in the Vivado IDE. For more information on the different design flow modes, see this link in the Vivado Design Suite User Guide: Design Flows Overview (UG892) [Ref 8].

VIDEO: For more information on design flows, see the Vivado Design Suite QuickTake Video: Design Flows Overview.

Working with Tcl

If you prefer to work directly with Tcl, you can interact with your design using Tcl commands using either of the following methods:

- Enter individual Tcl commands in the Vivado Design Suite Tcl shell outside of the Vivado IDE.
- Enter individual Tcl commands in the Tcl Console at the bottom of the Vivado IDE.
- Run Tcl scripts from the Vivado Design Suite Tcl shell.
- Run Tcl scripts from the Vivado IDE.

For more information about using Tcl and Tcl scripting, see the Vivado Design Suite User Guide: Using Tcl Scripting (UG894) [Ref 9]. For a step-by-step tutorial that shows how to use Tcl in the Vivado tools, see the Vivado Design Suite Tutorial: Design Flows Overview (UG888) [Ref 10].

Launching the Vivado Design Suite Tcl Shell

Use the following command to invoke the Vivado Design Suite Tcl shell either at the Linux command prompt or within a Windows Command Prompt window:

```
vivado -mode tcl
```

Note: On Windows, you can also select Start > All Programs > Xilinx Design Tools > Vivado <version> > Vivado <version> Tcl Shell.
Launching the Vivado Tools Using a Batch Tcl Script

You can use the Vivado tools in batch mode by supplying a Tcl script when invoking the tool. Use the following command either at the Linux command prompt or within a Windows Command Prompt window:

```
vivado -mode batch -source <your_Tcl_script>
```

**Note:** When working in batch mode, the Vivado tools exit after running the specified script.

Working with the Vivado IDE

If you prefer to work in a GUI, you can launch the Vivado IDE from Windows or Linux. For more information on the Vivado IDE, see the *Vivado Design Suite User Guide: Using the Vivado IDE* (UG893) [Ref 3].

**VIDEO:** To learn more about using the Vivado IDE, see the Vivado Design Suite QuickTake Video: Getting Started with the Vivado IDE.

**RECOMMENDED:** Launch the Vivado IDE from your working directory. This makes it easier to locate the project file, log files, and journal files, which are written to the launch directory.

Launching the Vivado IDE on Windows

Select **Start > All Programs > Xilinx Design Tools > Vivado <version> > Vivado <version>**.

**Note:** You can also double-click the Vivado IDE shortcut icon on your desktop.

**Figure 3-1:** Vivado IDE Desktop Icon

**TIP:** You can right-click the Vivado IDE shortcut icon, and select **Properties** to update the Start In field. This makes it easier to locate the log files and journal files, which are written to the launch directory.

Launching the Vivado IDE from the Command Line on Windows or Linux

Enter the following command at the command prompt:

```
vivado
```

**Note:** When you enter this command, it automatically runs `vivado -mode gui` to launch the Vivado IDE. You can, type `vivado -help` to see the various command line options for use when launching the Vivado tool.
Chapter 3: Getting Started with the Vivado Design Suite

Launching the Vivado IDE from the Vivado Design Suite Tcl Shell

Enter the following command at the Tcl command prompt:

```
start_gui
```

Using the Vivado IDE

When you launch the Vivado IDE, the Getting Started page (Figure 3-2) displays and provides you with different options to help you begin working with the Vivado Design Suite.

![Vivado IDE Getting Started Page](image)

**Figure 3-2:** Vivado IDE Getting Started Page

Starting with a Project

You can create or open a project, and add source files to define your design. The Quick Start section of the Getting Started Page provides links for easy access to the following steps:

- Create a project using the New Project wizard.
- Open existing projects.
- Open example projects provided by Xilinx.

**Note:** You can also open recently accessed projects from the Recent Projects list.
Chapter 3: Getting Started with the Vivado Design Suite

If you are working with a project, the tool automatically manages your design and keeps track of design file status. You can launch predefined design flow steps, and access results reports along the way.

For more information on design entry, see the Vivado Design Suite User Guide: System-Level Design Entry (UG895) [Ref 11]. For information on the next steps in the design flow, see the Vivado Design Suite User Guide: Design Flows Overview (UG892) [Ref 8].

Managing IP

You can create an IP location to configure and manage IP remotely, which allows access from different design projects and source control management systems. You can use the Vivado IP catalog to browse and customize delivered IP as well as open existing IP and repositories.

For more information on design entry, see the Vivado Design Suite User Guide: System-Level Design Entry (UG895) [Ref 11]. For information on IP, see the Vivado Design Suite User Guide: Designing with IP (UG896) [Ref 12].

Opening the Hardware Manager

You can open the Vivado Design Suite Hardware Manager to program your design into a device. The Vivado logic analyzer and Vivado serial I/O analyzer features of the tool enable you to debug your design. For example, you can add ILA, VIO, Memory IP, and JTAG-to-AXI cores to your design for debugging in the Vivado logic analyzer, or use the IBERT example design from the Xilinx IP catalog to test and configure the GTs in your design with the Vivado serial I/O analyzer.

For more information on these tools, see the Vivado Design Suite User Guide: Programming and Debugging (UG908) [Ref 13].

Accessing the Tcl Store

The Xilinx Tcl Store is an open source repository of Tcl code designed primarily for use in FPGA designs with the Vivado Design Suite. The Tcl Store provides access to multiple scripts and utilities contributed from different sources, which solve various issues and improve productivity. You can install Tcl scripts and also contribute Tcl scripts to share your expertise with others.

For more information on working with Tcl scripts and the Xilinx Tcl Store, see this link in the Vivado Design Suite User Guide: Using Tcl Scripting (UG894) [Ref 9].

Reviewing Documentation and Videos

From the Getting Started page, you can open documentation, including user guides, tutorials, videos, and the release notes, in the Xilinx Documentation Navigator.

For more information on the Documentation Navigator and the Vivado Design Suite documentation, see Chapter 4, Learning About the Vivado Design Suite.
Chapter 4

Learning About the Vivado Design Suite

Overview

This chapter provides information on where to learn more about the Vivado® Design Suite.

RECOMMENDED: For a hands-on approach to learning the tool, follow the QuickTake Video Tutorials and the Tool Tutorials.

TIP: For quick access to information on different parts of the Vivado IDE, click the Vivado Quick Help button ? in the window or dialog box.

Documentation Navigator

You can view the Xilinx® tool and hardware documentation in the Xilinx Documentation Navigator (DocNav) or on the Xilinx website. DocNav is integrated with the Vivado Design Suite. It provides an environment to access and manage the entire set of Xilinx documentation for hardware and software products, training, and support materials.

To open the Documentation Navigator:

- In the Vivado IDE, select any documentation link on the Getting Started page or in the Help menu.
- On Windows, select Start > All Programs > Xilinx Design Tools > DocNav.
  
  Note: You can also double-click the DocNav shortcut icon on your desktop
- At the Linux command prompt, enter docnav
Chapter 4: Learning About the Vivado Design Suite

Features of the Documentation Navigator include:

- **Catalog**: Displays all available Xilinx software and hardware documents, QuickTake videos, Design Advisories, and Application Notes.
  - **Filters**: Allows you to view documentation by specific document types, specific devices, or other relevant categories.
  - **Search**: Enables you to find documentation based on the specified search terms. The search capability works for documentation both in the local repository and on the Xilinx website.

- **Design Hubs**: Provides quick access to documentation, training, and information for specific design tasks.

- **UltraFast™ Design Methodology Checklist**: Perform the Checklist on your design to ensure Xilinx recommended design practices are followed for the best user experience and design performance.

- **Quick Download**: Documentation Navigator manages downloading Xilinx documentation to your local desktop.

- **Documentation Update**: Documentation Navigator monitors and indicates when documents are updated on the Xilinx website.

**RECOMMENDED:** Click the **Update Catalog** button at the top of the Documentation Navigator to update to the latest document catalog from the Xilinx website. This ensures the latest documents and videos are available.

---

### Design Hubs

Xilinx Design Hubs provide links to documentation organized by design tasks and other topics, which you can use to learn key concepts and address frequently asked questions. To access the Design Hubs:

- In the Xilinx Documentation Navigator, click the **Design Hub View** tab.
- On the Xilinx website, see the **Design Hubs** page.
Chapter 4: Learning About the Vivado Design Suite

Vivado Quick Help

The Vivado Quick Help system is available from within the Vivado IDE by clicking on the button in dialog boxes, windows, and wizards. A browser-like window opens with an overview of the feature, and the various inputs or settings that drive it. The Vivado Quick Help system also provides references to user guides, QuickTake videos, and other documentation for a specific feature.

The Quick Help browser window includes a search function for locating text within a specific help file. The browser has back and forward buttons for viewing the history of Quick Help windows viewed while working in the Vivado IDE.

The button in wizards and dialog boxes is located in the lower left corner (Figure 4-1). In windows, the button is located in the upper-right corner.

Figure 4-1: Quick Help Example
QuickTake Video Tutorials

Xilinx provides a series of short training videos that focus on specific design tasks to help you learn to use the Vivado IDE. The videos are available in the Documentation Navigator, from the Vivado Design Suite QuickTake Video Tutorials on the Xilinx website, and on YouTube.

Tool Tutorials

There are a variety of step-by-step software tool tutorials to help you get working in the Vivado IDE quickly. The tutorials provide step by step instructions to perform specific design tasks in the tool using small example designs. Each tutorial has a series of independent labs relevant to the tutorial subject matter. The tutorials are available in the Documentation Navigator and from the Vivado Design Suite Documentation page on the Xilinx website.

Documentation Suite

• Vivado Design Suite User Guides: These guides are categorized by design task for easy navigation to the information you need. User guides contain detailed information about running specific commands and performing specific design tasks within the Vivado Design Suite. They are available from the Vivado Design Suite User Guides page on the Xilinx website.

• Reference Guides: These guides provide reference information for topics, such as Tcl commands, constraints, and device libraries. They are available from the Vivado Design Suite Reference Guides page on the Xilinx website.

• Methodology Guides: These guides provide high-level guidance for performing specific design tasks, such as design migrating and large design guidance. They are available from the Vivado Design Suite Methodology Guides page on the Xilinx website.
Chapter 5

Learning About the UltraFast Design Methodology

Overview

The Xilinx UltraFast™ design methodology provides tips and suggestions for each stage of the design process when using the Vivado® Design Suite, including:

- Design flow planning
- Printed circuit board (PCB) and field programmable gate array (FPGA) device planning
- Design creation
- Implementation
- Configuration and debug
- Working with Revision Control Systems

UltraFast Design Methodology Guide for the Vivado Design Suite

The UltraFast Design Methodology Guide for the Vivado Design Suite (UG949) [Ref 14] describes the recommended methodology for optimizing design results and maximizing efficiency when using the Vivado tools. This guide also includes an appendix with the items from the UltraFast Design Methodology Checklist (XTP301) [Ref 15], and each item links to relevant information in the guide.
UltraFast Design Methodology Checklist

The *UltraFast Design Methodology Checklist* is designed to facilitate a faster design cycle with the best results. It includes a set of items to consider for each stage of the design process and provides recommended actions to take as well as links to additional information. The checklist is available in spreadsheet format at the *UltraFast Design Methodology Checklist* (XTP301) [Ref 15]. You can also access the checklist from within the Xilinx Documentation Navigator as follows. For more information on Xilinx Documentation Navigator, see Documentation Navigator in Chapter 4.

1. Click the **Design Hub View** tab.
2. At the top of the menu on the left side, click **Create Design Checklist**.
3. In the New Design Checklist dialog box, fill out the information and click **OK**.
4. The new checklist opens, and the tabs across the top provide navigation (Figure 5-1).

   The Title Page tab provides basic information on using the checklist, and the other tabs provide checklist items and recommendations.

   ![Figure 5-1: UltraFast Design Methodology Checklist Tabs in Xilinx Documentation Navigator](image)

---

* **Getting Started**  
  UG910 (v2018.1) April 4, 2018  
  www.xilinx.com
Appendix A

Additional Resources and Legal Notices

Xilinx Resources

For support resources such as Answers, Documentation, Downloads, and Forums, see Xilinx Support.

Solution Centers

See the Xilinx Solution Centers for support on devices, software tools, and intellectual property at all stages of the design cycle. Topics include design assistance, advisories, and troubleshooting tips.

Documentation Navigator and Design Hubs

Xilinx Documentation Navigator provides access to Xilinx documents, videos, and support resources, which you can filter and search to find information. To open the Xilinx Documentation Navigator (DocNav):

• From the Vivado IDE, select Help > Documentation and Tutorials.
• On Windows, select Start > All Programs > Xilinx Design Tools > DocNav.
• At the Linux command prompt, enter docnav.

Xilinx Design Hubs provide links to documentation organized by design tasks and other topics, which you can use to learn key concepts and address frequently asked questions. To access the Design Hubs:

• In the Xilinx Documentation Navigator, click the Design Hubs View tab.
• On the Xilinx website, see the Design Hubs page.

Note: For more information on Documentation Navigator, see the Documentation Navigator page on the Xilinx website.
Appendix A: Additional Resources and Legal Notices

References

These documents provide supplemental material useful with this guide:

2.  **ISE® Design Suite 14: Release Notes, Installation, and Licensing** (UG631)
5.  **ISE to Vivado Design Suite Migration Guide** (UG911)
7.  **Xilinx Downloads**
10.  **Vivado Design Suite Tutorial: Design Flows Overview** (UG888)
15.  **UltraFast Design Methodology Checklist** (XTP301)
16.  **Vivado Design Suite Documentation**

Training Resources

1.  **Designing FPGAs Using the Vivado Design Suite 1 Training Course**
2.  **Vivado Design Suite QuickTake Video: Design Flows Overview**
3.  **Vivado Design Suite QuickTake Video: Getting Started with the Vivado IDE**
4.  **Vivado Design Suite QuickTake Video Tutorials**

Please Read: Important Legal Notices

The information disclosed to you hereunder (the “Materials”) is provided solely for the selection and use of Xilinx products. To the maximum extent permitted by applicable law: (1) Materials are made available “AS IS” and with all faults, Xilinx hereby DISCLAIMS ALL WARRANTIES AND CONDITIONS, EXPRESS, IMPLIED, OR STATUTORY, INCLUDING BUT NOT LIMITED TO WARRANTIES OF
Appendix A: Additional Resources and Legal Notices

MERCHANDISE, NON-INFRINGEMENT, OR FITNESS FOR ANY PARTICULAR PURPOSE; and (2) Xilinx shall not be liable (whether in contract or tort, including negligence, or under any other theory of liability) for any loss or damage of any kind or nature related to, arising under, or in connection with, the Materials (including your use of the Materials), including for any direct, indirect, special, incidental, or consequential loss or damage (including loss of data, profits, goodwill, or any type of loss or damage suffered as a result of any action brought by a third party) even if such damage or loss was reasonably foreseeable or Xilinx had been advised of the possibility of the same. Xilinx assumes no obligation to correct any errors contained in the Materials or to notify you of updates to the Materials or to product specifications. You may not reproduce, modify, distribute, or publicly display the Materials without prior written consent. Certain products are subject to the terms and conditions of Xilinx’s limited warranty, please refer to Xilinx’s Terms of Sale which can be viewed at https://www.xilinx.com/legal.htm#tos; IP cores may be subject to warranty and support terms contained in a license issued to you by Xilinx. Xilinx products are not designed or intended to be fail-safe or for use in any application requiring fail-safe performance; you assume sole risk and liability for use of Xilinx products in such critical applications, please refer to Xilinx’s Terms of Sale which can be viewed at https://www.xilinx.com/legal.htm#tos.

AUTOMOTIVE APPLICATIONS DISCLAIMER

AUTOMOTIVE PRODUCTS (IDENTIFIED AS “XA” IN THE PART NUMBER) ARE NOT WARRANTED FOR USE IN THE DEPLOYMENT OF AIRBAGS OR FOR USE IN APPLICATIONS THAT AFFECT CONTROL OF A VEHICLE (“SAFETY APPLICATION”) UNLESS THERE IS A SAFETY CONCEPT OR REDUNDANCY FEATURE CONSISTENT WITH THE ISO 26262 AUTOMOTIVE SAFETY STANDARD (“SAFETY DESIGN”). CUSTOMER SHALL, PRIOR TO USING OR DISTRIBUTING ANY SYSTEMS THAT INCORPORATE PRODUCTS, THOROUGHLY TEST SUCH SYSTEMS FOR SAFETY PURPOSES. USE OF PRODUCTS IN A SAFETY APPLICATION WITHOUT A SAFETY DESIGN IS FULLY AT THE RISK OF CUSTOMER, SUBJECT ONLY TO APPLICABLE LAWS AND REGULATIONS GOVERNING LIMITATIONS ON PRODUCT LIABILITY.

© Copyright 2012–2018 Xilinx, Inc. Xilinx, the Xilinx logo, Artix, ISE, Kintex, Spartan, Virtex, Vivado, Zynq, and other designated brands included herein are trademarks of Xilinx in the United States and other countries. All other trademarks are the property of their respective owners.