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Vivado HLS Design Flow Lab

Introduction

This lab provides a basic introduction to high-level synthesis using the Vivado HLS tool flow. You will use
Vivado HLS in GUI mode to create a project. You will simulate, synthesize, and implement the provided
design.

Objectives

After completing this lab, you will be able to:

Create a new project using Vivado HLS GUI

Simulate a design

Synthesize a design

Implement a design

Perform design analysis using the Analysis capability of Vivado HLS
Analyze simulator output using Vivado and XSim simulator

Procedure

This lab is separated into steps that consist of general overview statements that provide information on
the detailed instructions that follow. Follow these detailed instructions to progress through the lab.

This lab comprises 8 primary steps: You will create a new project in Vivado HLS, run simulation, run
debug, synthesize the design, open an analysis perspective, run SystemC and RTL co-simulation, view
simulation results using Vivado and XSim, and export and implement the design in Vivado HLS.

General Flow for this Lab

Step 1: Step 2: Step 3: S Stip 4: Step 5:
Creating a Run C Run ynthesize Analyze using
New I:> Simulation I:> Debugger |:> the design |:> Analysis
Project Perspective
Step 6: Step 7: Step 8:
Run C/RTL Viewing Export RTL
Co-Simulation |:> Simulation |:> pand
Results in
Vivado Implement
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Create a New Project Step 1

1-1. Create a new project in Vivado HLS targeting Zynq xc7z020clg484-1
(ZedBoard) or xc7z010clg400-1 (Zybo).

1-1-1. Launch Vivado HLS: Select Start > All Programs > Xilinx Design Tools > Vivado 2014.4 >
Vivado HLS > Vivado HLS 2014.4

A Getting Started GUI will appear.

VIVADO! ...

Quick Start Recent Projects

High-Level Synthesis

alphablend
Ch\temp\alphablend

I/“ / matrixmul.prj
'\ 1 Chxuphhis\labs\labl\matrixmul.prj

Create New Project Open Project Open Example Project yuv_filter.prj
Chxuphhis\labs\lab2yyuv_filter.prj

firpr
Documentation Chxuph\sys_designt2014_2_zyng_labs_1\lab6\fir.prj

adders.prj
Ch\xuphhls\adders.prj

ﬁ Y l] proj_hls_stream

1 L § C\Users\parimalp XLNX\hls_stream\proj_hls_stream

il RK \Users\parimalp XLNX\hls_stream\proj_his.

2 . : proj_axi_stream_no_side_channel_data
Tutorials User Guide Release Motes Guide

Ch\Users\parimalp XLNX\axi_stream_no_side_channel_data\proj_axi_streai

Figure 1. Getting Started view of Vivado-HLS

1-1-2. In the Getting Started GUI, click on Create New Project. The New Vivado HLS Project wizard
opens.

1-1-3. Click the Browse... button of the Location field and browse to ¢:\xup\hls\labs\lab1 and then click
OK.

1-1-4. For Project Name, type matrixmul.prj

Zyng 1-2 www.xilinx.com/university v
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¢ New Vivado HLS Project L_@‘d_\:-_J

Project Configuration AGC

Create Vivado HLS project of selected type

Project name: matrixmul.prj|

Location: C\xup\hls\labs Browse...

Next > nist Cancel

Figure 2. New Vivado HLS Project wizard
1-1-5. Click Next.

1-1-6. In the Add/Remove Files window, type matrixmul as the Top Function name (the provided
source file contains the function, to be synthesized, called matrixmul).

1-1-7. Click the Add Files... button, select matrixmul1.cpp file from the ¢:\xup\hls\labs\lab1 folder, and
then click Open.

1-1-8. Click Next.

1-1-9. In the Add/Remove Files for the testbench, click the Add Files... button, select
matrixmul_test.cpp file from the ¢:\xup\hls\labs\lab1 folder and click Open.

1-1-10. Select the matrixmul1_test.cpp in the files list window and click the Edit CFLAG... button, type
-DHW_COSIM, and click OK.

1-1-11. Click Next.

1-1-12. In the Solution Configuration page, leave Solution Name field as solution1 and set the clock
period as 10 (for ZedBoard) or 8 (for Zybo). Leave Uncertainty field blank it will take 1.25 as the
default value for ZedBoard and 1 for Zybo.

1-1-13. In the Device Selection Dialog page, select Parts Specify field, and select the following filters to
select the xc7z2020¢clg484-1 (ZedBoard) or xc7z010clg400-1 (Zybo) part, and click OK:
o Family: Zynq
o Sub-Family: Zynq
o Package: clg484 (for ZedBoard) or clg400 (for Zybo)
o Speed Grade: -1

v www.xilinx.com/university Zynq 1-3
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¢ Device Selection Dialog

. -8 ﬁ
Support for devices prior to series 7 and Zyng requires an additional license.
Please contact your Xilinx representative for more details.
RTL Tool Specify Filter
I Auto ~ Product Category: | All ~ | Package: clg484 | ~
B Boaras Family: zyng ~ | Speed Grade: | -1 -
L Sub-Family: zynq ~ Temp Grade: | All %
Search: ¥
Device Family Package Speed SLICE LUT FF DSP BRAM
|9xc72020c|9484-1 zyng clg484 -1 13300 53200 106400 220 280 |
<[ 1 3
OK l [ Cancel ]
4 Device Selection Dialog . - . @
Support for devices prior to series 7 and Zynq requires an additional license.
Please contact your Xilinx representative for more details.
RTL Tool Specify Filter
Auto ~ Product Category: | All ~ | Package: clgd00 ~
@ Boards Family: zynq ~ | Speed Grade: [ -1 -
Sub-Family: zynq ~ | Temp Grade: | All v
Search: ¥
Device Family Package Speed SLICE LUT FF DSP BRAM
@xc7z020clg400-1  zynq clg400 -1 13300 53200 106400 220 280
@xc7z010clg400-1 _ zyng clg400 -1 4400 17600 35200 80 120
< 1l »

Figure 3. Using Parts Specify option in Part Selection Dialog

You can also select the Boards specify option (only for ZedBoard) and select one of the listed
board if the desired target board is listed.
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s Device Selection Dialog

>

Please contact your Xilinx representative for more details.

Support for devices prior to series 7 and Zynq requires an additional license.

RTL Tool Specify Filter
Auto <~ | @Parts Family: zynq -
[l Package: All v
[l Speed Grade: | All %
Search: ¥
Board Part Family Package Spee
8 Zyng ZC706 Evaluation Platform xc7z045ffg900-2 zynq ffg900 -2
8 Zyng ZC702 Evaluation Platform xc7z020clg484-1 zynq clg484 -1
IiZedBoard Zynq Evaluation and Develo... | xc7z020clg484-1 zynq clg484 -1
8 MicroZed Board xc7z010clg400-1 zynq clg400 -1

Cancel

Figure 4. Using Boards Specify option in Part Selection Dialog

1-1-14. Click Finish.

You will see the created project in the Explorer view. Expand various sub-folders to see the

entries under each sub-folder.

[ Explorer &2 ¥ = O
4 25 matrixmul.prj
» ! Includes
4 = Source
[¢ matrixmul.cpp
> fi= Test Bench
a4 Y= solution1
4 & constraints
< directives.tcl
W script.icl

Figure 5. Explorer Window

1-1-15. Double-click on the matrixmul.cpp under the source folder to open its content in the information

pane.
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57 #include "matrixmul.h"

58

59 void matrixmul(

78 mat_a t a[MAT_A ROWS][MAT A COLS],

71 mat_b_t b[MAT B ROWS][MAT B _COLS],

72 result t res[MAT_A ROWS][MAT B _COLS])
734

74 f/ Iterate over the rows of the A matrix
75 Row: for(int i = @; i < MAT_A ROWS; i++) {
76 // Iterate over the columns of the B matrix
)

]

Col: for(int j = @; j < MAT_B _COLS; j++) {

78 // Do the inner product of a row of A and col of B
79 res[1i][3i] = @;

1] Product: for(int k = @; k < MAT_B ROWS; k++) {

B1 res[1][J] += a[i][k] * b[k][]];

B2 b

B3 b

B4 1}

85}

Figure 6. The Design under consideration

It can be seen that the design is a matrix multiplication implementation, consisting of three nested
loops. The Productloop is the inner most loop performing the actual Matrix elements product and
sum. The Colloop is the outer-loop which feeds the next column element data with the passed
row element data to the Product loop. Finally, Row is the outer-most loop. The res][i][j]=0 (line
79) resets the result every time a new row element is passed and new column element is used.

Run C Simulation Step 2
2-1.  Run C simulation to view the expected output.
2-1-1. Select Project > Run C Simulation or click on * from the tools bar buttons, and Click OK in
the C Simulation Dialog window.
2-1-2. The files will be compiled and you will see the output in the Console window.
Zynq 1-6 www.xilinx.com/university v
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2-1-3.

LH

B Console 22 . @] Errors| & Warnings =% @A

Vivado HLS Cansole

Starting C simulation ...

C:/Xilinx/Vivado HLS/2014.4/bin/vivado_hls.bat C:/xup/hls/labs/labl/matrixmul.pr

@I [LIC-101] Checked out feature [HLS]

@I [HLS-18] Running 'C:/Xilinx/Vivado HLS/2014.4/bin/unwrapped/win6d.o/vivado_hl
for user 'parimalp’ on host 'xsjparimalp3@’ (Windows NT_ amd64 versio
in directory "C:/xup/hls/labs/labl’

@I [HLS-1@] Opening project 'C:/xup/hls/labs/labl/matrixmul.prj’.

@I [HLS-18] Opening solution 'C:/xup/hls/labs/labl/matrixmul.prj/solutionl’.

@I [SYM-201] Setting up clock 'default' with a period of 1@ns.

@I [LIC-181] Checked out feature [HLS]

@I [HLS-10] Setting target device to "xc7zP20clgd84-1"

make: “csim.exe' is up to date.

{

{870,906,942}

{1086,1131,1176}

{1382,1356,1410}

¥

@I [SIM-1] CSim done with @ errors.

@I [LIC-101] Checked in feature [HLS]

a4

l='Ev=v =

| I

Figure 7. Program output

Double-click on matrixmul_test.cpp under testbench folder in the Explorer to see the content.

You should see two input matrices initialized with some values and then the code executes the
algorithm. If HW_COSIM is defined then the matrixmul function is called and compares the output
of the computed result with the one returned from the called function, and prints Test passed if
the results match.

If HW_COSIM had not been defined then it will simply output the computed result and not call the
matrixmul1 function.

Run Debugger Step 3

3-1.

3-1-2.

Run the application in debugger mode and understand the behavior of the
program.

Select Project > Run C Simulation or click on * from the tools bar buttons. Select the Launch
Debugger option and click OK.

The application will be compiled with —g option to include the debugging information, the compiled
application will be invoked, and the debug perspective will be opened automatically.

The Debug perspective will show the matrixmul1_test.cpp in the source view, argc and argv
variables defined in the Variables view, Outline view showing the objects which are in the current
scope, thread created and the program suspended at the main() function entry point.
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¢ Vivado HLS - matrixmul.prj (C:\xup\hls\labs\labl\matrixmul.prj) E@]ﬁ
File Edit Project Solution Run Window Help
: 0> BNIRRIRDIG B D@ RE B« ® %5 Debug |l | Synthesis &5 Analysis
1% Debug 2 [y Exploref v v= 85 % Breakp |!if Registe | &< Express | # Module =0
4 [€] matrixmul.prj.Debug [C/C++ Application] =] [ =

4 B csim.exe [10912] Name Type Value

4 ¢ Thread [1] 0 (Suspended : Breakpoint) ®: argc int 1
IE main() at matrixmul_test.cpp:72 0x401398] » argv char ** 0x9a4e00
»i gdb
< 1 »

£ matrixmul_csynth.rpt B matrixmul_csim.log [ matrixmul_test.cpp £2 = 8 = B8
o 72 [ - CELRY o % -

73 mat_a_t in_mat_a[3][3] = { U jostream

74 {11, 12, 13}, = matrixmul.h

75 {14, 15, 16}, 5 i

76 {17, 18 ,19} D S

77 I e main(int, char*)

78 mat_b_t in_mat_b[3]1[3] = { =

79 {21; 22; 23},

80 {24, 25, 26},

81 {27, 28, 29}

82 };

83 result_t hw_result[3][3], sw_result[3][3];

84 int err cnt = 0:
< )

B Console 2 &) Tasks| (2] Problems| O Executables| 0 Memory xEEE B4 =08
matrixmul.prj.Debug [C/C++ Application] csim.exe

Writable Smart Insert 7251

Figure 8. A Debug perspective

3-1-3. Scroll-down in the source view, and double-click in the blue margin at line 105 where it is about to
output “{“in the output console window. This will set a break-point at line 105. .
The breakpoint is marked with a blue circle, and a tick
184 /f Print result matris
125 cout << "{" << endl;
3-1-4. Similarly, set a breakpoint at line 101 on the matrixmul() function
3-1-5. Using the Step Over (F6) button ( =) several times, observe the execution progress. Do it for
about 19 times and observe the variable values as well as computed software result.
Zynq 1-8 www.xilinx.com/university v
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/ iVivado HLS - matrixmul.prj (C:\xup\hls\labs\labl\matrixmul.prj) ﬁ@@

File Edit Project Solution Run Window Help
ftRBIEE B RE|«|®

, | Synthesis &< Analysis

%5 Debug 32 5 Explorer & o> M| 2 @ ¢« % i ¥ < 0|®=Variables &3, % Breakpoints| i Registers| =\ Modules =0
[€] matrixmul.prj.Debug [C/C++ Application] =t 3| |eg et ¥

i C\xup\hls\labs\labl\matrixmul.prj\solution1\csim\build\csim.exe [11368] Name Type Value -
o Thread [1] 0 (Suspended : Step) 0= k int il
= main() at matrixmul_test.cpp:94 0x40140a [ int Y
»i gdb 00 int 0
#in_mat_a char [3][3]  Ox28feef
# hw_result short [3][3] Ox28fed4
= err_cnt int 0 5
(* in_mat_b char [3][3] O0x28fee6 b
4 (% sw_result short [3][3] Ox28fec2
(= sw_result[0] short [3] 0x28fec2
= sw_result[1] short [3] 0x28fec8
*® sw_result[2] short [3] 0x28fece
< i »
< )

[ matrixmul_test.cpp 2 = O|[E Outline & =g
90 // Iterate over the columns of the B matrix - FEALRY o %Y
91 sw_;esu}l]t[i][j] S Bé ; . el s = iostream
92 o the inner product of a row of A and col o N
93 ét/:r(int k = 0; k < MAT B ROWS; kes) { = ' matrxmulh

> 94 [ sw_result[i][j] += in_mat_a[i][k] * in_mat_b[k][3]; = StdA i
95 T = e main(int, char**) : int

< » < 1 »

& Console | % Tasks |[£( Problems | @ Executables| 0 Memory [¢9= Variables <1> 2 % B | |rim Y =8

Name Type Value =
®: argc int 1 =
» argv char ** 0x364bd8
0= k int 1
= j int 1 -

Figure 9. Debugger’s intermediate output view

Now click the Resume ( “® ) button to complete the software computation and stop at line 101.

3-1-6
3-1-7. Observe the following computed software result in the variables view.
(t9= Variables 22 . % Breakpoints | ifif R_egisters B Mo;ﬂlule;:_ = _
_ B XK AT
Name Type Value =
= in_mat_b char [3][3] Ox28feeb
4 (= sw_result short [3][3] Ox28fec2
4 (@ gy result[0] short [3] Ox28fec2
9= sw_result[0][( short 870 F
= sw_result[0][1 short 906
9= sw_result[0][: short 942
4 (2 gy result[1] short [3] Ox28fec8
9= sw_result[1][( short 1086
69- sw_result[1][1 short 1131 =
9= sw_result[1][: short 1176
4 (2 sw_result[2] short [3] Ox28fece
9= sw_result[2][( short 1302
9= sw_result[2][] short 1356
9= sw_result[2][: short 1410 =
| T »
< )

Figure 10. Software computed result

www.xilinx.com/university
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3-1-8. Click on the Step Into (F5) button ( =*-) to traverse into the matrixmul module, the one that we
will synthesize, and observe that the execution is paused on line 75 of the module.

3-1-9. Using the Step Over (F6) several times, observe the computed results. Once satisfied, you can
use the Step Return (F7) button to return from the function.

3-1-10. The program execution will suspend at line 105 as we had set a breakpoint. Observe the
software and hardware (function) computed results in Variables view.

= Variables 2 . % Breakpoints| il Registers| =i Modules = ]
<5 3] ¥ e 7
Name Type Value =
4 (2 hw_result short [3][3] Ox28fed4d
4 (2 hw_result[0] short [3] Ox28fed4
6= hw_result[0][0] short 870
6d= hw_result[0][1] short 906
6= hw_result[01[2] short 042
= hw_result[1] short [3] Ox28feda
= hw_result[2] short [3] Ox28feel
&= err_cnt int 0
= in_mat_b char [31[3] 0Ox28feeb 3
4 = sw_result short [3][3]  Ox28fec2
4 (= sw result[0] short [3] Ox28fec2
)= sw_result[0][0] short 870
69= sw_result[0][1] short 906
09= sw_result[0][2] short 942
= sw result[1] short [3] Ox28fec8
(= sw_result[2] short [3] 0x28fece -
4 il 3

4 [

Figure 11. Computed results

3-1-11. Set a breakpoint on line 134 (return err_cnt;), and click on the Resume button.

The execution will continue until the breakpoint is encountered. The console window will show
the results as seen earlier (Figure 7).

3-1-12. Press the Resume button or Terminate button to finish the debugging session.

Synthesize the Design Step 4

4-1. Switch to Synthesis view and synthesize the design with the defaults. View
the synthesis results and answer the question listed in the detailed section
of this step.

4-1-1. Switch to the Synthesis view by clicking on the tools bar.

Zynqg 1-10 xilinx.com/university v
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4-1-2. Select Solution > Run C Synthesis > Active Solution or click onthe ¥ button to start the
synthesis process.

4-1-3. When synthesis is completed, the Synthesis Results will be displayed along with the Outline pane.
Using the Outline pane, one can navigate to any part of the report with a simple click.

5l matrixmul_csim.log 1=l matrixmul_csynth.rpt 2

Synthesis Report for ‘'matrixmul’

General Information:

Date: Mon Jan 12 14:03:58 2015

Version: 2014.4 (Build 1071461 on Tue Nov 18 16:42:57 PM 2014)
Project: matrixmul.prj

Solution: solutionl

Product family:
Target device:

zyngq
xc7z020clg484-1

Performance Estimates
= Timing (ns)
= Summary
Clock Target  Estimated  Uncertainty
default 10.00 6.38 125
= Latency (clock cycles)
= Summary
Latency Interval

min  max min  max Type
106 106 107 107  none

Figure 12. Report view after synthesis is completed

4-1-4. If you expand solution1 in Explorer, several generated files including report files will become
accessible.

[ Explorer 3 = O
4 =% matrixmul.prj
> mi Includes
> 2 Source

» = Test Bench
= solution1

[ 9

« # constraints
& directives.tcl
& scripticl
4 = csim
> &= build
» = report
4 = syn
4 = report
2l matrixmul_csynth.rpt
4 (= systemc
lel matrixmul.cpp
Lgl matrixmul.h
4 = verilog
s matrixmul.v
4 (= vhdl
s matrixmul.vhd

Figure 13. Explorer view after the synthesis process

v www.xilinx.com/university Zyng 1-11
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Note that when the syn folder under the Solution1 folder is expanded in the Explorer view, it will
show report, systemC, verilog, and vhdl sub-folders under which report files, and generated
source (vhdl, verilog, header, and cpp) files. By double-clicking any of these entries will open the
corresponding file in the information pane.

Also note that if the target design has hierarchical functions, reports corresponding to lower-level

functions are also created.

4-1-5. The Synthesis Report shows the performance and resource estimates as well as estimated

latency in the design.

4-1-6. Using scroll bar on the right, scroll down into the report and answer the following question.

Question 1

Estimated clock period:

Worst case latency:
Number of DSP48E used:
Number of FFs used:

Number of LUTs used:

4-1-7. The report also shows the top-level interface signals generated by the tools.

= matrixmul_csim.log

Interface

RTL Ports
ap_clk
ap_rst
ap_start
ap_done
ap_idle
ap_ready
a_address0
a_cel
a_q0
b_address)
b_cel
b_qg0
res_address0
res_cel
res_we0
res_d0

=0 matrixmul_csynth.rpt &2

Bits

I N T T S - T S S e Sy S Ry B e e

[y
[=3}

Protocol
ap_ctrl_hs
ap_ctrl_hs
ap_ctrl_hs
ap_ctrl_hs
ap_ctrl_hs
ap_ctrl_hs
ap_memory
ap_memory
ap_memory
ap_memory
ap_memory
ap_memory
ap_memory
ap_memory
ap_memory

ap_memory

Source Object
matrixmul
matrixmul
matrixmul
matrixmul
matrixmul
matrixmul

a

oD T W oW

res

res

res

res

Figure 14. Generated interface signals

C Type
return value
return value
return value
return value
return value
return value

array
array
array
array
array
array
array
array
array

array

You can see ap_clk, ap_rst and ap_* control signals are automatically added to every design by
default. The ap_start, ap_done, ap_idle, and ap_ready are top-level signals used as
handshaking signals to indicate when the design is able to accept next computation command
(ap_ready), when the next computation is started (ap_start), and when the computation is
completed (ap_done). Other signals are generated based on the design interface itself.

Zyng 1-12
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Analyze using Analysis Perspective Step 5

5-1. Switch to the Analysis Perspective and understand the design behavior.

5-1-1. Select Solution > Open Analysis Perspective or click on (** Debug [+ Isynthesis 5 Analysis | )to
open the analysis viewer.

The Analysis perspective consists of 5 panes as shown below. Note that the module and loops
hierarchies are displayed unexpanded by default.

The Module Hierarchy pane shows both the performance and area information for the entire
design and can be used to navigate through the hierarchy. The Performance Profile pane is
visible and shows the performance details for this level of hierarchy. The information in these two
panes is similar to the information reviewed earlier in the synthesis report.

The Performance view is also shown in the right-hand side pane. This view shows how the
operations in this particular block are scheduled into clock cycles.

o The left-hand column lists the resources

o The top row lists the control states (c0 to ¢5) in the design. Control states are the internal
states used by High-Level Synthesis to schedule operations into clock cycles. There is a
close correlation between the control states and the final states in the RTL Finite State
Machine(FSM) but there is no one-to-one mapping

¢ Vivado HLS - matrixmul.prj (C:\xup\hls\labs\labl\matrixmul.prj) ﬂl&]
File Edit Project Solution Window Help
@ Ridgv 6@ %5 Debug |+ | Synthesis
=] Module Hierarchy)| = B || B matrixmul_csim.log =1l matrixmul_csynth.rpt V = 0
RAM P.|.FE T |
= E 25 LUTG jLatency Interva Current Module : matrixmul
© matrixmul 0 1 62 63 106 107
[oneration\cControls..| co | c1 | c2 | c3 | ca | ¢c5 |
1-...®Row [
< 1 »
£” Performance Profilel‘ Resource Profile &2 = 8
BR;\M DSP FF LUT BitsPO BitsP1 BitsP2 Ban
‘ »

Figure 15. Analysis perspective

5-1-2. Click on loop Row to expand, and then click on sub-loops Col and Product to fully expand the
loop hierarchy.

v www.xilinx.com/universit Zynqg 1-13
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=l matrixmul_csim.log

Current Module

|Dn9raﬂnn\Cnntnﬂ S

=l matrixmul_csynth.rpt

: matrixmul

co | c1

= Performance - matrixmul i3

C?

C3

c4a

ChH

-IR.owW

RS S S R e e e e e
N—,owo~NOUWBWN R oL N WAWLN-

23

i(phi mux)
exitcond2 (icmp)
i 1(+)
p addr7(-)
SICol
J (phi mux)
exitcondl (icmp)
i 1(+)
p addrs (+)
-IProduct

res load(phi...

k(phi mux)
node 42 (write)
exitcond (icmp)
k 1(+)

addrl (+)
load (read)
addr3 (-)
addr4 (+)
load (read)
tmp 7 (*)

tmp 8 (+)

od g op g

Figure 16. Performance matrix showing top-level Row operation

From this we can see that in the first state (C1) of the Row the loop exit condition is checked and
there is an add operation performed. This addition is likely the counter to count the loop iterations,
and we can confirm this.

The operations resulting from the loops are colored yellow, the standard operations are colored
purple, and sub-blocks will be colored green (in our case we don’t have any lower-level functions).

5-1-3. Select the grey block for the adder in state C1, right-click and select Goto Source.
The source code pane will be opened, highlighting line 75 where the Row loop index is being
tested and incremented. In the next state (C2) it starts to execute the Colloop.
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[El matrixmul_csim.| =0 matrixmul_csynt = Performance - m &2 = B || ¢ C Source 2 =l

File: C\xup\hls\labs\labl\matrixmul.cpp

VI T INGIGIGIHLG.

64 //Revision History:

Current Module : matrixzmul

-

| Oneration\Control 5...| co | [~

1 ERow

2 | i(phi mux) " Riaht-click here | .

3 Lo e Nk include "matrixmul.

L) ggvoid matrixmul{
ddr7 (-

g o= () 70 mat a t a[MAT A ROWS][MZ

= S B 71 mat_b_t b[MAT_B_ROWS][MA

8 exitcondl (icmp) ;g{ result_t res[MAT_A_ROWS][M

9 J1(+) .
10 D addrs (+) 74 /! lterate over_the rows of the A
11 SProduct =| | 75 Row: for(inti=0; i< MAT_A R(

: 76 // lterate over the columns of th
load(phi...
ié ifghioiug * 77 Col: for(intj = 0; j < MAT B_Ct
14 T D i) ;g reg)[?][f;]? r[r}?.ne-,' product of a ro
itcond (i o
LEE 80 Product for(int k = 0; k < MA
17 p addri (+) 81 res[il{il += al[illk] * bIK]{il;
18 a load(read) 82 H
19 p addr3(-) 3 1 I
20 p addrd (+) 84 } 3
21 b load(read) ::}
22 tmp 7 (*)
72 tmn A (+) B 27
< 1 » 38 S
P 1 ] »

Performance | Resource

Figure 17. Cross probing into the source file

5-1-4. In C2, click on the operations (e.g. p_addr8) in the Col loop to see the source code highlighting
(line 79) update.
5-1-5. Expand the Performance Profile hierarchy and note iteration latencies, Trip counts, and overall
latencies for each of the nested loops.
£F Performance Profile 2 . | . Resource Profile = 8
Pipelined Latency InitiationInterval Iteration Latency Trip count
4 o matrixmul; - 106 107 - -
4 o Row no 105 - 35 3
4 o (ol no 33 - 11 3
@ Product no 9 - 3 3
Figure 18. The Performance Profile output
The number of iterations can also be noted by holding the mouse over the loop in the
Performance view (a dialog box shows the loop statistics).
11 -IProduct — .
12 res load(phi... Ripelest no
13 k(phi mux) Latency: 9
14 node 42 (write) Initiation Interval: -
15 exitcond (icmp) Iteration Latency: 3
16 k 1(+) Trip count: 3
17 p addrl (+)
18 a load(read)
19 p addr3(-)
Figure 19. Loop information
i' XILINX www.xilinx.com/university Zynq 1-15
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Note that the initiation interval does not have a number as this loop is not pipelined.

5-1-6. Click next to the matrixmul entry in the Module Hierarchy and observe that the entry is not
expanded, since there are no lower-level functions defined in the design.

5-1-7. Select the Resource Profile tab and observe various resources and where they have been used.
You can expand Expressions and Registers sections to see how the resources are being used by
which operations.

£° Performance Profile || . Resource Profile |2 - 0
BRAM DSP FF LUT BitsPO BitsP1
4@ matrixmul 0 1 62 63
- 821 [fO Ports(3) 32
fs Instances(0) 0 0 0 o0
=8 Memories(0) 0 0 0 0
» %, Expressions(12) 0 1 0 40 48 45
- i Registers(13) 62 66
FIFO(0) 0 0 0 0
> Multiplexers(3) 0 0 23 23

Figure 20. The Resource Profile tab view

5-1-8. In the Performance Matrix tab, select the Resource tab (at the bottom of the page), and expand
Expressions, I/0 Ports, and Memory Ports entries to view the type of operations, resources
used, and in which state they are being used.
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(=l matrixmul_csim.log

Current Module

=l matrixmul_csynth.rpt

: matrixmul

&= Resource - matrixmul 3

|Resource\Control Sten| co | ¢1 | ¢2 | 3 | ca | c¢s
1 EI/O Ports
2 res (pl) write
3 b(p0) read
4 a{p0) read
5 EMemory Ports
6 a(p0) read
7 b (p0) read
8 res (pl) write
9 EExXpressions
i0 i phi fu 79 phi_mux
11 i1 fu 128 ==
12 p addr? fu 150 =
13 exitcondz fu 122 icmp
14 j phi fu 90 phi_mux
1H p addrE fu 176 E
16 j 1 fu 166 o
il exitcondl fu 1&0 iemp
18 k phi fu 114 phi_mux
19 res load phi £ phi_mux
20 p addrd4 fu 246 =&
21 k1 fu 196 +
22 p addrl fu 210 =&
23 p addr3 fu 236 =
24 exitcond fu 190 icmp
25 tmp 8 fu 272 +
26 tmp 7 fu 266 &

Performance |Resource

Figure 21. The Resource tab

5-1-9. Click on the Synthesis tool bar button to switch back to the Synthesis view.

Run C/RTL Co-simulation Step 6

6-1. Run the C/RTL Co-simulation with the default settings of SystemC. Verify
that the simulation passes.

6-1-1. Select Solution > Run C/RTL Cosimulation or if you are in the synthesis view, click on the ¥
toolbar button to open the dialog box so the desired simulations can be selected and run.
A C/RTL Co-simulation Dialog box will open.

6-1-2. Select the SystemC option.

This allows the simulation to be performed using the built-in C compiler. To perform the
verification using Verilog and/or VHDL, you can select the HDL and choose the simulator from the
drop-down menu or let the tools use the first simulator that appears in the PATH variable.
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4 Co-simulation Dialog - ﬁ

C/RTL Co-simulation

Verilog/VHDL Simulator Selection

Auto N/

RTL Selection "
Q@) SystemC Verilog VHDL "

Options
| Setup Only

Dump Trace
"] Optimizing Compile
| Reduce Diskspace

Compiled Library Location

Input Arguments

|| Do not show this dialog box again.

oK | [ Cancel

\

Figure 22. A C/RTL Co-simulation Dialog

6-1-3. Click OK to run the SystemC simulation.

The C/RTL Co-simulation will run, generating and compiling several files, and then simulating the
design. It goes through three stages.

o First, the C test bench is executed to generate input stimuli for the RTL design

» Second, an RTL test bench with newly generated input stimuli is created and the RTL
simulation is then performed

Finally, the output from the RTL is re-applied to the C test bench to check the results
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In the console window you can see the progress and also a message that the test is passed.
This eliminates writing a separate testbench for the synthesized design.

Vivado HLS Console

Starting C simulation ...
C:/Xilinx/Vivado HLS/2014.4/bin/vivado_hls.bat C:/xup/hls/labs/labl/matrixmul.prij/solud

@1
@1

@1
@1
@I
@I
@I

{

[LIC-101] Checked out feature [HLS]

[HLS-1@] Running 'C:/Xilinx/Vivado HLS/2014.4/bin/unwrapped/win6d.o/vivado hls.exe’
for user 'parimalp’' on host 'xsjparimalp3@' (Windows NT_amd64 version 6.1)
in directory 'C:/xup/hls/labs/labl’

[HL5-1@] Opening project "C:/xup/hls/labs/labl/matrixmul.prj’.

[HLS-18] Opening solution 'C:/xup/hls/labs/labl/matrixmul.prj/solutionl’.

[SYN-201] Setting up clock 'default’ with a period of 1@ns.

[LIC-101] Checked out feature [HLS]

[HLS-18] Setting target device to "xc7z020clgdg84-1"'

Compiling ../../../../matrixmul test.cpp in debug mode

Compiling ../../../../matrixmul.cpp in debug mode

Generating csim.exe

{870,906,942}
{1086,1131,1176}
{1302,1356,1410}

}

Test passed.

@I [SIM-333] Generating C post check test bench ...
@I [SIM-12] Generating RTL test bench ...

Build using "C:/Xilinx/Vivado HLS/2014.4/msys/bin/g++.exe"
Compiling AESL_automem_a.cpp

Compiling AESL_automem_b.cpp

Compiling AESL_automem_res.cpp

Compiling matrixmul.autotb.cpp

Compiling matrixmul.cpp

Generating cosim.sc.exe

@I [SIM-11] Starting SystemC simulation ...

SystemC 2.3.0-AST --- Jul 4 2013 12:03:34
Copyright (c) 1996-2012 by all Contributors,
ALL RIGHTS RESERVED

Mote: VCD trace timescale unit is set by user to 1.000000e-812 sec.

Info: /OSCI/SystemC: Simulation stopped by user.
@I [SIM-316] Starting C post checking ...

{

{870,906,942}
{1086,1131,1176}
{1302,1356,1410}

¥

Test passed.
@I [SIM-1@@e] *** C/RTL co-simulation finished: PASS ***
@I [LIC-181] Checked in feature [HLS]

Figure 23. Console view showing simulation progress

6-1-4. Once the simulation verification is completed, the simulation report tab will open showing the

results. The report indicates if the simulation passed or failed. In addition, the report indicates the

measured latency and interval.
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Since we have selected only SystemC, the result shows the latencies and interval (initiation)
which indicates after how many clock cycles later the next input can be provided. Since the
design is not pipelined, it will be latency+1 clock cycles.

=l matrixmul_cosim.rpt &2

Cosimulation Report for ‘'matrixmul’

Result
Latency Interval
RTL Status min  avg max min  avg max
VHDL NA  MNA  NA NA  NA NA MNA
Verilog NA  NA  NA NA  NA  NA MNA

SystemC Pass 106 106 106 107 107 107

Figure 24. Co-simulation results

Viewing Simulation Results in Vivado Step 7

7-1.  Run Verilog simulation with Dump Trace option selected.

7-1-1.  Select Solution > Run C/RTL Cosimulation or click on the ¥ button in the Synthesis view to
open the dialog box so the desired simulations can be run.

7-1-2. Click on the Verilog RTL Selection option, leaving Verilog/VHDL Simulator Section option to Auto.

Optionally, you can click on the drop-down button and select the desired simulator from the
available list of XSim, ISim, ModelSim, and Riviera.

7-1-3. Select Allfor the Dump Trace option and click OK.

Zynq 1-20 www.xilinx.com/university v
xup@xilinx.com i‘ XILINX@
© copyright 2015 Xilinx



Lab Workbook Vivado HLS Design Flow Lab

'+ | Co-simulation Dialog e

C/RTL Co-simulation

Verilog/VHDL Simulator Selection

Auto v

RTL Selection

SystemC EVerilog VHDL
Options
| Setup Only
Dump Trace |all v

"] Optimizing Compile
"] Reduce Diskspace

Library Directory

Figure 25. Setting up for Verilog simulation and dump trace

When RTL verification completes the co-simulation report automatically opens showing the
Verilog simulation has passed (and the measured latency and interval). In addition, because the
Dump Trace option was used and Verilog was selected, two trace files entries can be seen in the
Verilog simulation directory
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4 [= sim
> = autowrap
: = report
> = systemc
=
4 = verilog
sl AESL automem_a.v
sl AESL_automem_b.v
sl AESL automem_res.v
' check_sim.tcl
sl matrixmul.autotb.v
=l matrixmul.performance.result.transaction.xml
matrixmul.pr]
matrixmul.resultlatrb
@ matrixmul.tcl
s matrixmuly

matrixmul.wcfg
matrixmul.wdb

A run_sim.tcl
run_xsim.bat
sim.bat

=l xelab.log
xelab.pb
Xsim.jou

=l xsim.log

+ = xsim.dir

Figure 26. Explorer view after the Verilog RTL co-simulation run

The Cosimulation report shows the test was passed for Verilog along with latency and Interval
results. It also shows the SystemC results of the previous run.

.

el matrixmul_csynth.rpt | 2]l matrixmul_cosim.rpt 2 2

Cosimulation Report for 'matrixmul’

Result
Latency Interval
RTL Status min  avg max min  avg max
VHDL NA  NA  NA  NA  NA NA NA

Verilog Pass 106 106 106 107 107 107
SystemC Pass 106 106 106 107 107 107

Export the report({html) using the Export Wizard

Figure 27. Cosimulation report

7-2. Start Vivado 2014.4 and enter Tcl commands to open and view the dumped
traces.

7-2-1. Select Start > All Programs > Xilinx Design Tools > Vivado 2014.4 > Vivado 2014.4 to start
the Vivado Design Suite program.
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7-2-2.

7-2-3.

7-2-4.

7-2-5.

7-2-6.

7-2-7.

In the Vivado Tcl console, enter the following commands one by one:
cd c:/xup/hls/labs/lab1/matrixmul.prj/solution1/sim/Verilog
current_fileset

open_wave_database matrixmul.wdb

open_wave_config matrixmul.wcfg

The above commands will load the project, simulation results, and open the waveform.

In the waveform window, click on the full zoom tool button (') to see the entire simulation of
one iteration.

Select a_address0 in the waveform window, right-click and select Radix > Unsigned Decimal.
Similarly, do the same for b_address0 and res_addressO0 signals.

Similarly, set the a_q0, b_q0, and res_d0 radix to Signed Decimal.

Scroll the waveform little, so you can view the main interface signals (ap_¥).

B matrixmulwcfg® x oC

ﬁ‘-‘ﬁh‘-‘ﬁﬁ..,.,,,.-‘-‘-‘-‘-‘ﬁ.”,..Hl'l'l'l'l'l‘....".,‘l'-'l'l'l'l'n.,...,.Fl'.'l'l'l'l'l..,....l

ﬂ'ﬂﬂﬂﬂﬂ-ﬂﬁ'-ﬂ (o K Ko P X0 X X ) 1--ﬂﬂﬂﬁﬂ'ﬂﬂﬂﬂ---l

Figure 28. Full waveform showing iteration worth simulation

Simulation run was for 1205 ns. Note that as soon as ap_start is asserted, ap_idle has been de-
asserted (at 135 ns) indicating that the design is in computation mode. The ap_idle signal
remains de-asserted until ap_done is asserted at 1195 ns, indicating completion of the process.
This indicates 106 clock cycles latency (1195 -135 => 1060 ns).

Using Zoom In button, view area of 165 ns and 550 ns.
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™ a_addre
1% a_cel

B a_ql

B b_addr
1 b_ced

Figure 29. Zoomed view

Observe that the design expects element data by providing a_address0, a_ceo, b_address0,
b_ceo signals and outputs result using res_d0, res_we0, and res_ce0.

7-2-8. View various part of the simulation and try to understand how the design works.
7-2-9. When done, close Vivado by selecting File > Exit. Click OK if prompted, and then No to close the
program without saving.
Export RTL and Implement Step 8
8-1. In Vivado HLS, export the design, selecting VHDL as a language, and run
the implementation by selecting Evaluate option.
8-1-1. In Vivado-HLS, select Solution > Export RTL or click on the & button to open the dialog box so
the desired implementation can be run.
An Export RTL Dialog box will open.
+' | Export RTL Dialog i
Export RTL -
Format Selection
ilP Catalog ) VConfiguration.../
Options
Evaluate 1Verilog 'j
Do not show this dialog box again.
‘ OK ‘ L Cancel
Figure 30. A Export RTL Dialog box
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With default settings (shown above), the IP packaging process will run and create a package for
the Vivado IP Catalog. Other options, available from the drop-down menu, are to create IP
packages for System Generator for DSP/System Generator for DSP using ISE, create a pcore for
Xilinx Platform Studio, or create a Synthesized checkpoint.

8-1-2. Click on the drop-down menu of the Options field, and select VHDL and click on the Evaluate
check box as the preferred language and to run the implementation tool.

8-1-3. Click OK and the implementation run will begin.

You can observe the progress in the Vivado HLS Console window. It goes through several
phases:
o Exporting RTL as an IP in the IP-XACT format
o RTL evaluation, since we selected Evaluate option
o Goes through Synthesis
o Goes through Placement and Routing

Starting export RTL ...

C:/Xilinx/Vivado_HLS/2014.4/bin/vivado_hls.bat C:/xup/hls/labs/labl/matrixmul.prj/solu

@I [LIC-1@1] Checked out feature [HLS]

@I [HLS-18] Running '"C:/Xilinx/Vivado_HLS/2014.4/bin/unwrapped/win64.o/vivado_hls.exe"
for user 'parimalp’' on host 'xsjparimalp3@’ (Windows NT_amd64 version 6.1)
in directory 'C:/xup/hls/labs/labl’

@I [HLS-18] Opening project 'C:/xup/hls/labs/labl/matrixmul.prj’.

@I [HLS-1@] Opening solution "C:/xup/hls/labs/labl/matrixmul.prj/solutionl’.

@I [SYN-201] Setting up clock 'default’ with a period of 1@ns.

@I [LIC-1@1] Checked out feature [HLS]

@I [HLS-10] Setting target device to 'xc7z020clgd84-1"

@I [IMPL-8]|Exporting RTL as an IP in IP-XACT.|

@I [IMPL-8] Starting RTL evaluation using Vivado ...
C:\xup\hls\labs\labl\matrixmul.prj\solutionl\impl\vhdl>vivado -notrace -mode

®EREX% Vivado v2014.4 (64-bit)
*##% Gl Build 1071353 on Tue Nov 18 18:29:27 MST 2014
**%*% TP Build 1878531 on Tue MNov 18 ©1:1@:18 MST 2014
** Copyright 1986-2014 Xilinx, Inc. All Rights Reserved.

source run_vivado.tcl -notrace

[Mon Jan 12 15:35:28 2015] |Launched synth_l...l

Run output will be captured here: C:/xup/hls/labs/labl/matrixmul.prj/solutionl
[Mon Jan 12 15:35:28 20151 Waiting for svynth 1 to finish...

Implementation tool: Xilinx Vivado v.2014.4

Device target: xc7z020c1gd84-1
Report date: Mon Jan 12 15:37:25 -8800 2015
#=== Resource usage ===

SLICE: 38

LUT: 114

FF: 60

DSP: (5]

BRAM: 5]

SRL: 5]

#=== Final timing ===

CP required: 10.000

CP achieved: 7.693

Timing met
INFO: [Common 17-206] Exiting Vivado at Mon Jan 12 15:37:25 2015...
@I [LIC-101] Checked in feature [HLS]

Figure 31. Console view
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When the run is completed the implementation report will be displayed in the information pane.

=l matrixmul_cosim.rpt | =l matrixmul_exportrpt 2 =l matrixmul_csynth.rpt |2 matrixmul_exportrpt &2
Export Report for ‘matrixmul’ Export Report for ‘matrixmul’
General Information General Information
Report date: Mon Jan 12 15:37:24 -0800 2015 Report date: Man Jan 12 16:23:49 -0800 2015
Device target. %c7z020clg484-1 Device target: xc7z010clg400-1
Implementation tool: Xilinx Vivado v.2014.4 Implementation tool: Xilinx Vivado v.2014.4
Resource Usage Resource Usage
VHDL VHDL
SLICE 38 SLICE 39
LuT 114 LuT 112
FF 60 FF 60
DSP 0 DSP 0
BRAM 0 BRAM
SRL 0 SRL 0
Final Timing Final Timing
VHDL WHDL
CPrequired  10.000 CPrequired ~ 10.000

CP achieved | 7.693' CP achieved 7.907

Figure 32. Implementation results in Vivado HLS

Observe that the timing constraint was met, the achieved period (6.176 ns), and the type and
amount of resources used.

8-1-4. Collapse the Explorer view and observe that impl folder is created under which ip, report, Verilog,
and vhdl sub-folders are created.

L Explorer &3
4 % matrixmul.prj

» [ Includes

> = Source

: = Test Bench

a = solutiont
- 4 constraints
= csim
= impl
+ = sim
s = syn

Figure 33. Explorer view after the RTL Export run
8-1-5. Expand the Verilog and vhdl sub-folders and observe that the Verilog sub-folder only has the ril

file whereas vhdl sub-folder has several files and sub-folders as the synthesis and
implementation runs were made for it.
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It includes project.xpr file (the Vivado project file), matrixmul1.xdc file (timing constraint file),
project.runs folder (which includes synth_1 and impl_1 sub-folders created by the synthesis and

implementation runs) among others.

4 = solution1
- 4 constraints
= csim
4 = impl
» Eip
: = report
> = verilog
4 (= yhdl
= autoimpl.log
& extraction.tcl
=l impl.bat
= matrixmul.result.rb
st matrixmul.vhd

= matrixmul.xdc

=l projectxpr
W run_vivado.tcl

W settings.tcl

=l vivado.jou

E vivado.log
» = project.cache
4 = project.runs
» = impl_1
> = synth_1
4 (= report
£l matrixmul_timing_routed.rpt
£l matrixmul_timing_synth.rpt
£l matrixmul_utilization_routed.rpt
£l matrixmul_utilization_synth.rpt

Figure 34. The implementation directory

8-1-6. Expand the ip folder and observe the IP packaged as a zip file

(xilinx_com_hls_matrixmul_1_0.zip), ready for adding to the Vivado IP catalog.
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a = solution1
. 4 constraints
> = csim
4 = impl
4 = ip
|5 autoimpl.log
= auxiliary.xml
[=l componentxml
pack.bat
% run_ippacktcl
vivado.jou
|= vivado.log

¥ilinx_com_hls_matrixmul_1_0.zip
= bd
- ## constraints

: 1= doc
> = example
> = hdl
> = misc
= subcore
> = xgui
» = report
» = verilog
4 (= yhdl

Figure 35. The ip folder content

8-1-7. Close Vivado HLS by selecting File > Exit.

Conclusion

In this lab, you completed the major steps of the high-level synthesis design flow using Vivado HLS. You
created a project, adding source files, synthesized the design, simulated the design, and implemented the
design. You also learned how to use the Analysis capability to understand the scheduling and binding.

Answers

1. Answer the following questions:

Estimated clock period: 6.38 ns
Worst case latency: 106 clock cycles
Number of DSP48E used: 1
Number of FFs used: 62
Number of LUTs used: 63
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