UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 64447

Vivado 2015.1, AXI Interconnect v2.1 - The IP Data in the repository is incompatible with the current instance

Description

When upgrading an IP Integrator design to Vivado 2015.1, the following message occurs, and is not able to be upgraded. How do I resolve this?

The IP Data in the repository is incompatible with the current instance (despite having identical Version and Revision). You will need to update the IP before viewing the customization and generating outputs.

Solution

This issue is caused by the missing revision update in the AXI Interconnect. Continue with the normal upgrade flow and the warning should disappear.

This issue will be fixed starting in Vivado 2015.2.

AR# 64447
Date Created 05/05/2015
Last Updated 06/10/2015
Status Active
Type General Article
Tools
  • Vivado Design Suite - 2015.1
IP
  • AXI Interconnect