UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 31691

10.1.03, 11.1, 11.2 ChipScope Pro - "ERROR: ChipScope Insertion failed"

Description

When I attempt to insert ChipScope cores in my design using the ChipScope Core Inserter, I receive the following error messages:

>Core generation step complete.
#
# An unexpected error has been detected by HotSpot Virtual Machine:
#
# EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x297ad9b4, pid=2304, tid=6092
#
# Java VM: Java HotSpot(TM) Client VM (1.5.0_14-b03 mixed mode)
# Problematic frame:
# C [libPortability.dll+0x4d9b4]
#
# An error report file with more information is saved as hs_err_pid2304.log
#
# If you would like to submit a bug report, please visit:
# http://java.sun.com/webapps/bugreport/crash.jsp
#
"ERROR: ChipScope Insertion failed"

Why does this occur?

Solution

This issue is caused by a mismatch in theService Pack between your ISE software install and your ChipScope Pro tool install. They should match; ISE 10.1 Service Pack 3 should be used with ChipScope Pro 10.1 Service Pack 3. Using ChipScope Pro 10.1.03 with an earlier ISE software version results in the above Java Hotspot error. This principle also applies for all subsequent 11.x releases.

Another possible cause is the path that is specified for the input netlist, output netlist, and output directory. If these are greater than 256 characters, try moving them to a location closer to the root, or mapping the drive so that the path is shorter.

AR# 31691
Date Created 09/16/2008
Last Updated 05/19/2012
Status Active
Type Error Message